Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-28-2014, 02:40 PM   #1
Pentaxian
troika's Avatar

Join Date: Dec 2012
Location: Seattle, WA USA
Posts: 845
Import Mystery

Here's a new one for me.

I have some new photos on my card (K5ii) from Thanksgiving and a dozen or so old ones that I hadn't deleted from a few weeks ago. When I put the card in my mac and try to import into lightroom, it sees that old photos, but not the new ones. Looking at the files on the computer, I don't especially see the new photos either, but when I put the card back and the camera and view through the LCD screen...new photos are there.

I'm baffled. I've done this same procedure the same way about 1,000,000 times with exactly the same result. Tried it on two different macs....I'm stumped. Any ideas?

11-28-2014, 02:43 PM   #2
Pentaxian
aleonx3's Avatar

Join Date: Jul 2007
Location: Brampton, Ontario
Photos: Gallery | Albums
Posts: 3,873
QuoteOriginally posted by troika Quote
Here's a new one for me.

I have some new photos on my card (K5ii) from Thanksgiving and a dozen or so old ones that I hadn't deleted from a few weeks ago. When I put the card in my mac and try to import into lightroom, it sees that old photos, but not the new ones. Looking at the files on the computer, I don't especially see the new photos either, but when I put the card back and the camera and view through the LCD screen...new photos are there.

I'm baffled. I've done this same procedure the same way about 1,000,000 times with exactly the same result. Tried it on two different macs....I'm stumped. Any ideas?
Are those RAW files? DNG or PEF?
11-28-2014, 02:45 PM   #3
Pentaxian
troika's Avatar

Join Date: Dec 2012
Location: Seattle, WA USA
Posts: 845
Original Poster
RAW files for sure. DNG, I believe.
11-28-2014, 02:50 PM   #4
Pentaxian
aleonx3's Avatar

Join Date: Jul 2007
Location: Brampton, Ontario
Photos: Gallery | Albums
Posts: 3,873
I am equally stumped.. unless the file attribute is changed to 'hidden' as it can not be seen in the computer, but how can the camera change that?

11-28-2014, 02:58 PM   #5
Forum Member
bernhardn's Avatar

Join Date: Apr 2014
Location: Meppel, Drenthe, The Netherlands
Photos: Gallery | Albums
Posts: 70
And when you look in the finder? does it show something?
Or maybe you accidentally changed the Color space from sRGB to Adobe RGB!
11-28-2014, 03:14 PM   #6
New Member




Join Date: Mar 2014
Photos: Albums
Posts: 12
I would try to plug the camera directly to the Mac with the card inside it - I usupect that you have a damaged sector on the card, which can still be read by the camera but not by the Mac onboard reader.

Just in case, I would try it on a few different computers as well just to check if you have a poor card reader or if the card is damaged (If other machines have trouble to read the files, PC included, it would confirm an issue on the card). Like for DVDs and CDs, some readers are always more competent than others at managing dodgy sectors.
11-28-2014, 03:21 PM   #7
Pentaxian




Join Date: Dec 2011
Photos: Albums
Posts: 579
I would wonder if you have somehow created a duplicate file structure on your SD card. You should be able to check this out by inserting the card into your Mac and opening it up on the Mac to look at the file structure. It could be that somehow the folder structure may have been disrupted so that, for example, you may have 2 sets of folders labelled DCIM or you may find some other disruption in the folder structure. (I am a Windows user so I can't give you a step by step on how to do this in a Mac). Once you can locate where on your card your new images are stored, you should be able to transfer them to your computer by dragging and dropping, if necessary.


Once you get the files transferred to your computer, you would probably do best to erase and re-format the SD card if this is the case.


Good luck.
11-28-2014, 08:16 PM   #8
Junior Member




Join Date: Jan 2011
Location: Libau, MB
Photos: Gallery
Posts: 30
QuoteOriginally posted by troika Quote
Here's a new one for me.

I have some new photos on my card (K5ii) from Thanksgiving and a dozen or so old ones that I hadn't deleted from a few weeks ago. When I put the card in my mac and try to import into lightroom, it sees that old photos, but not the new ones. Looking at the files on the computer, I don't especially see the new photos either, but when I put the card back and the camera and view through the LCD screen...new photos are there.

I'm baffled. I've done this same procedure the same way about 1,000,000 times with exactly the same result. Tried it on two different macs....I'm stumped. Any ideas?
I have a similar problem with my K5. Please try opening the card like a file with the computer and not to import it with a photography program. If it is there copy and paste your new pictures folder into the desired picture folder then let me know if they work in your photography program. About 4 months ago I started having my problem with my K5 and I tried 4 computers with inconsistent mixed results. I phoned Pentax and Computech Camera repair and they all felt that I may have a board problem. As I have extended warranty and a K3 I have yet to send it out however I can say the cards I had problems with in the K5 are fine in the K3. For the record I shot PEF+Jpg and DNG +Jpg. Please keep me posted as I have shoot in Dec that I need 2 bodies for then I will send the K5 in and the more info I have the better.

11-28-2014, 09:45 PM   #9
Pentaxian
troika's Avatar

Join Date: Dec 2012
Location: Seattle, WA USA
Posts: 845
Original Poster
Thanks everyone. I'll work on it more when I get a little time. I've done this frequently with this camera and these computers for a couple of years now. This card is not new, either, so something odd is going on. We'll work on it and report back.
11-28-2014, 10:18 PM   #10
Pentaxian
aleonx3's Avatar

Join Date: Jul 2007
Location: Brampton, Ontario
Photos: Gallery | Albums
Posts: 3,873
Troika, I am stumped and interested to know why... I know you said you tried it on a different MACs but the same result (image can be seen in camera but not while connected to computer). Would you be able to test it on a Windows PC instead?
11-29-2014, 05:25 AM   #11
Forum Member
bernhardn's Avatar

Join Date: Apr 2014
Location: Meppel, Drenthe, The Netherlands
Photos: Gallery | Albums
Posts: 70
I believe there is an option in the camera to protect your images, I don't know the K5.
11-29-2014, 11:35 AM   #12
Pentaxian
troika's Avatar

Join Date: Dec 2012
Location: Seattle, WA USA
Posts: 845
Original Poster
So, Thanksgiving photos are lost (there were some good ones in there too). The camera (LCD Screen) stopped seeing them too. I could see folders on the card when viewed on the computer and the folder with the last batch of photos still had those pictures accessable in them. What looked like the new photo folders was some odd single file that didn't do anything.

Very odd. I reformatted the card and took a few photos, which imported without issue. I don't know what to chalk this up to, but I guess I just need to see if it happens again.
11-29-2014, 12:05 PM   #13
Loyal Site Supporter
Mikesul's Avatar

Join Date: Sep 2009
Location: Phoenix, AZ
Posts: 2,472
QuoteOriginally posted by troika Quote
So, Thanksgiving photos are lost (there were some good ones in there too). The camera (LCD Screen) stopped seeing them too. I could see folders on the card when viewed on the computer and the folder with the last batch of photos still had those pictures accessable in them. What looked like the new photo folders was some odd single file that didn't do anything.

Very odd. I reformatted the card and took a few photos, which imported without issue. I don't know what to chalk this up to, but I guess I just need to see if it happens again.
OOPS! Too bad you reformatted but all is not necessarily lost. There are programs which can recover files from corrupted SD Cards (sometimes even after simple reformatting). Some cost money but there are a number of shareware and freeware programs which do a decent job. Here is a link to a discussion of several.

6 data recovery tools for SD cards, USB drives and more | Computerworld
11-29-2014, 12:28 PM   #14
Pentaxian
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 3,895
I recommend PhotoRec. There is a Mac OS version. I tested about half a dozen free recover tool programs and PhotoRec is I think the best. It recognizes PEF files. It does no harm to run different programs however as long as you don't write the recovered files back to the card..
11-29-2014, 02:30 PM   #15
Pentaxian
troika's Avatar

Join Date: Dec 2012
Location: Seattle, WA USA
Posts: 845
Original Poster
Oh, wish I hadn't reformatted the card.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, import, pentax help, photography, photos, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Import duty to US nicoprod General Photography 6 11-19-2014 07:55 AM
can't import photos Venom3300 Troubleshooting and Beginner Help 12 07-18-2014 09:50 PM
Lightroom DNG on import? johngs Digital Processing, Software, and Printing 2 01-24-2014 06:25 PM
DNG files import failure Greyser Pentax K-3 3 11-06-2013 11:44 PM
Import camera presets in Lightroom? audiobomber Digital Processing, Software, and Printing 8 04-15-2013 01:23 PM



All times are GMT -7. The time now is 07:02 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top