Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-12-2014, 11:19 PM   #1
New Member




Join Date: Dec 2014
Posts: 3
[K30] Memory card error

Hey guys, i have this confusing problem about memory card error on my K30. It happens randomly awhile after shooting. Last shot was fine and suddenly the next one couldn't be read (while the camera is turning on). Sometimes everything's alright. But recently this problem occurs very often.


Each time this happens, the only way i can solve this is taking out the memory card then input again. very annoying. I try several brand new SDHCs but there's no result. I suppose the error was on the camera, and take it to the Pentax Distributor (in Vietnam) for helps. They told me if it was on the camera so there were no chance to repair it. Because memory adapter is glutinous to mainboard, it has to replace whole the mainboard, that's impossible ! i bought this K30 from amazon US 6 months ago, there's no garrantee in vietnam unless i return to the amazon US (it's quite complicated )
If anyone has the same problem, pls give me some advices, it would be appreciated !

12-13-2014, 12:40 AM - 1 Like   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,128
It's more likely that your memory card is faulty. If an in-camera format doesn't fix the problem, try getting a new sandisk or lexar card- and make sure it's not a counterfeit!

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

12-13-2014, 12:51 AM - 1 Like   #3
Veteran Member
rburgoss's Avatar

Join Date: May 2008
Location: San Jose, Costa Rica
Photos: Gallery | Albums
Posts: 972
QuoteOriginally posted by Adam Quote
It's more likely that your memory card is faulty. If an in-camera format doesn't fix the problem, try getting a new sandisk or lexar card- and make sure it's not a counterfeit!
+1

If problem is at mainboard, it will happen all the time with any size/brand memory card. In third world countries, chances to be scammed with counterfit (anything) are very high. Even in the USA you are not 100% free of counterfit goods. Just buy your memory cards from reputable retailers, from well known brands and from someone that you can file warranty claims.
12-13-2014, 03:35 AM   #4
New Member




Join Date: Dec 2014
Posts: 3
Original Poster
QuoteOriginally posted by rburgoss Quote
+1

If problem is at mainboard, it will happen all the time with any size/brand memory card. In third world countries, chances to be scammed with counterfit (anything) are very high. Even in the USA you are not 100% free of counterfit goods. Just buy your memory cards from reputable retailers, from well known brands and from someone that you can file warranty claims.
Thanks. I'm pretty sure i'm using an authentic lexar card. this occurs occasionally :'( while shooting. i guess it's caused by the spot of interaction between the card and the mainboard. i dont know...

Attached Images
View Picture EXIF
5530  Photo 
12-13-2014, 05:46 AM - 1 Like   #5
Banned




Join Date: Feb 2013
Posts: 390
I had memory card errors randomly in my K30 with PNY cards, switched to SanDisk and all has been well since.
12-13-2014, 06:04 AM - 1 Like   #6
Veteran Member




Join Date: Jul 2009
Location: Ottawa, Canada
Posts: 342
QuoteOriginally posted by voduyynhien Quote
Thanks. I'm pretty sure i'm using an authentic lexar card. this occurs occasionally
With my K200D, I used to get these problems regularly with generic Lexar cards, and even with Sandisk Ultra cards. I found I could minimize the problems somewhat by shooting RAW rather than RAW+,
and by NOT pressing the "preview" button until the camera was done writing a series of photos to the card.

Then I lost the Lexar cards and bought a Sandisk Extreme - never had the problem once. The Sandisk Ultra works fine on my K30, though slower than the Sandisk Extremes. I've never seen the memory
card error problem on my K30, but I've never tried shooting with cheaper cards since I lost the Lexars.

As suggested by others, try getting something like a Sandisk Extreme from a reputable dealer.
12-13-2014, 07:04 AM - 1 Like   #7
Site Supporter
dakight's Avatar

Join Date: Sep 2014
Location: Phoenix, AZ
Photos: Albums
Posts: 1,178
Get a good, well-known brand of memory card and format it in camera before you use it. It's more likely that the problem is the memory card than the camera. Always format a new memory card in the camera and if you haven't done that with the one you're using try it; it just might solve the problem. Good luck.
12-13-2014, 09:03 AM - 1 Like   #8
Veteran Member
rburgoss's Avatar

Join Date: May 2008
Location: San Jose, Costa Rica
Photos: Gallery | Albums
Posts: 972
How to spot or identify fake memory cards:

Tutorial: How to spot a fake memory card

How to spot fake SanDisk, SD, and other memory cards | eBay

Beware Counterfeit Memory Cards Being Shipped From Amazon Warehouses

https://www.avforums.com/threads/fake-sd-cards-test-yours-now.1347842/

RMPrepUSB, Easy2Boot and USB booting...: A faster test for 'fake' SD cards and USB Flash drives!

12-13-2014, 09:21 AM - 1 Like   #9
Veteran Member
EarlVonTapia's Avatar

Join Date: Oct 2012
Location: Vancouver
Photos: Gallery
Posts: 1,152
QuoteOriginally posted by voduyynhien Quote
Thanks. I'm pretty sure i'm using an authentic lexar card. this occurs occasionally :'( while shooting. i guess it's caused by the spot of interaction between the card and the mainboard. i dont know...
I bought some Lexar cards for my K30 before. They sucked. I was experiencing the same problems as you.

I went back to Sandisk, and now Eye-Fi cards, and I've never had those problems again.

Lexar sucks.
12-13-2014, 11:44 AM - 1 Like   #10
Forum Member
gtis's Avatar

Join Date: Mar 2011
Location: south yorkshire
Photos: Gallery
Posts: 82
QuoteOriginally posted by Al_Kahollick Quote
I had memory card errors randomly in my K30 with PNY cards, switched to SanDisk and all has been well since.
Hi
I have the same problem with my k3 using PNY cards as well
Going to buy two 16g sandisk cards
Neil
12-13-2014, 12:05 PM - 1 Like   #11
Site Supporter
ripper2860's Avatar

Join Date: Mar 2014
Location: Dallas, TX
Posts: 889
QuoteOriginally posted by gtis Quote
Hi
I have the same problem with my k3 using PNY cards as well
Going to buy two 16g sandisk cards
Neil
Strange. I've been using 2x 32GB PNY Elite cards in my K3 since I got it and I have one in my K500. I have never had an error, but I do only shoot RAW (not RAW+).
12-13-2014, 04:51 PM - 1 Like   #12
Banned




Join Date: Feb 2013
Posts: 390
QuoteOriginally posted by ripper2860 Quote
Strange. I've been using 2x 32GB PNY Elite cards in my K3 since I got it and I have one in my K500. I have never had an error, but I do only shoot RAW (not RAW+).

I was able to use them in my K20 with no problems there either, only had trouble in the K30. There have been many threads about different camera models not playing well with various cards. Guess each model has it's own likes / dislikes when it comes to cards.
12-13-2014, 05:00 PM - 1 Like   #13
Forum Member
gtis's Avatar

Join Date: Mar 2011
Location: south yorkshire
Photos: Gallery
Posts: 82
QuoteOriginally posted by ripper2860 Quote
Strange. I've been using 2x 32GB PNY Elite cards in my K3 since I got it and I have one in my K500. I have never had an error, but I do only shoot RAW (not RAW+).
Hi
I use 16g PNY performance cards and shoot in raw+
So that could be the problem
Neil
12-14-2014, 07:16 AM   #14
New Member




Join Date: Dec 2014
Posts: 3
Original Poster
Thanks all you guys ! I appreciate your advices very much. Theses lead to the conclusion that i should use a SANDISK card and had better shoot in RAW than RAW+ . I'll try it immediately in few days and then give feedback on this issue. I hope it works !
12-14-2014, 10:52 AM - 1 Like   #15
Veteran Member
rburgoss's Avatar

Join Date: May 2008
Location: San Jose, Costa Rica
Photos: Gallery | Albums
Posts: 972
QuoteOriginally posted by voduyynhien Quote
Thanks all you guys ! I appreciate your advices very much. Theses lead to the conclusion that i should use a SANDISK card and had better shoot in RAW than RAW+ . I'll try it immediately in few days and then give feedback on this issue. I hope it works !
I really don't think you need to change shooting file format. Just follow this simple and easy rules:

1. Get your memory cards ONLY from trusted reputable sources that will honor any given warranty.

2. Always format cards IN CAMERA, not in computer. Same goes for deleting individual files.

3, Make sure you are runing a good, up to date antivirus program in your computer. Run antivirus on mem cards BEFORE opening them on any file browser. Lets AV software finish scan before starting to transfer files.

4. Always practice good habits when inserting or removing cards from camera or computer. In camera always turn off camera to insert or remove cards. In computer make sure card access is finished before removing. Better yet use the USB /flash drive stop utility every time before removing.

5. Avoid strong magnetic fields around memory cards (speakers, TV sets, metal detectors, microwave ovens, electric motors, etc) although damage from magnetic sources is rare, it can happen.

6. Keep card's contacts clean, including fingerprints. Never allow them to get wet.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
amazon, camera, card, error, k30, mainboard, memory, pentax help, photography, troubleshooting, vietnam
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Memory Card Error Doggai Troubleshooting and Beginner Help 3 08-14-2014 04:34 PM
Optio S1 memory card error Stevedrummer Troubleshooting and Beginner Help 3 06-19-2014 05:19 PM
Memory card error jerryleejr Pentax K-r 8 03-05-2014 06:18 PM
memory card error ron chatlos Visitors' Center 3 02-26-2014 06:40 PM
Pentax Kr - Memory Card Error STLfan Troubleshooting and Beginner Help 4 06-11-2013 12:13 PM



All times are GMT -7. The time now is 10:09 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top