Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-03-2015, 12:13 AM   #16
Site Supporter
K57XR's Avatar

Join Date: Feb 2011
Location: Colorado, USA
Posts: 828
QuoteOriginally posted by CameraObscura Quote
Tried all possibilities: door open; door closed; with card; without card. Normally, when I insert a SD card, the card access light blinks momentarily, even if the camera is turned off. Now when I insert the card, nothing happens.
From your description above it seems there is no power going into the camera. If I'm not mistaken even a camera with toasted firmware will still flash the access light when a card is inserted as long as there is power. Have you checked the three battery contacts inside the compartment, in case one or more is somehow stuck recessed?

Not sure it will help but it's worth a try?
1) Make sure the power switch is off
2) Push a fully charged battery in as far as it will go and hold it there
3)Turn the camera on while holding/pressing the battery in at the same time.

Good luck.

05-03-2015, 04:56 AM   #17
Site Supporter




Join Date: Mar 2014
Photos: Gallery
Posts: 982
there is a little switch under the sdcard door, push it down andI will bet you it will fire up. Inspect it carefully you will find it. I won a k-30 off Ebay brand new not one actuation because they at Roberts camera could get it to turn on. I put it in debug mode via the thread and viola. the only drawback was it would record shots slower than 200th of a second So I didn't give up after carefully playing around I discovered that the sdcard door was not pushing the switch down far enough ,once I solved this I have a NEW CAMERA. I will put my money on it , that this is your problem. report back
05-24-2015, 12:48 PM   #18
New Member




Join Date: Jan 2013
Posts: 24
Original Poster
I agree that it sounds like a power problem. However, the battery contacts are good and clean.

I also tried the little switch under the SD card door. No go.

---------- Post added 05-24-15 at 02:25 PM ----------

I finally gave up and listed it on eBay for parts/repair. If it seems easy to fix and someone wants to have a go at it, now is your chance.
05-24-2015, 02:33 PM   #19
Site Supporter




Join Date: Mar 2014
Photos: Gallery
Posts: 982
set your sd card for debug

05-24-2015, 03:02 PM   #20
New Member




Join Date: Jan 2013
Posts: 24
Original Poster
No luck. Copied the MODSET.492 file to the root of the SD card, placed the card in the camera, and held the AV +/- button while turning on the camera. No sign of life.
05-24-2015, 03:29 PM   #21
Site Supporter




Join Date: Mar 2014
Photos: Gallery
Posts: 982
try no sd card , first with the door open then with it closed

---------- Post added 05-24-15 at 06:32 PM ----------

QuoteOriginally posted by CameraObscura Quote
No luck. Copied the MODSET.492 file to the root of the SD card, placed the card in the camera, and held the AV +/- button while turning on the camera. No sign of life.
also work that sdcard door switch out , in otherword use a q-tip and pump it in and out for a long time and vigorously . then try
05-24-2015, 05:09 PM   #22
New Member




Join Date: Jan 2013
Posts: 24
Original Poster
Tried with the SD card door open, then with the card door closed.

Worked the card door switch for some minutes, removed and replaced the battery and tried again, with the door open and closed.

Still no sign of life.
05-24-2015, 05:16 PM   #23
Site Supporter




Join Date: Mar 2014
Photos: Gallery
Posts: 982
guess its over and out

05-24-2015, 05:24 PM   #24
New Member




Join Date: Jan 2013
Posts: 24
Original Poster
Unfortunately, it seems so. I hadn't used it much but it took some good pictures when I did.

Thanks to all who responded here.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, cameras, card, door, k-01, page, pentax help, photography, price, refurb, repair, repairs, ricoh, sd, sd card, troubleshooting, website
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K30 will not turn on theoicarry Troubleshooting and Beginner Help 4 08-29-2014 04:16 PM
K-01 with Tamron 70-200 will not nail focus treebeard Pentax K-01 8 03-22-2013 05:46 AM
Help! Pentax K-r won't turn on? Marie Anette Pentax K-r 9 02-10-2013 04:08 PM
K-5 will not turn on - Pentax Support advice carrrlangas Troubleshooting and Beginner Help 2 01-10-2013 11:02 AM
K-m DSLR Will Not Turn On Robbie28 Troubleshooting and Beginner Help 7 02-26-2011 09:22 AM



All times are GMT -7. The time now is 07:34 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top