Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-04-2015, 08:13 AM   #1
New Member




Join Date: Dec 2008
Posts: 23
Pentax K5 card reader failure

Sadly, my K5 card reader stopped working. When I put any of the cards I have in it, the camera says: "No card in the camera".

Sometimes it works for a couple seconds and I may even be able to take a shot or two, but then it stops again.

I think this is likely a mechanical fault, possible related to me dropping the camera once.

I know there are better bodies out there, but I am not currently ready for a splurge on a new body.

Anyone has an idea of how much approximately servicing this issue would cost and if it's worth it? BTW, I currently reside in Singapore. Thx.

01-04-2015, 08:57 AM   #2
Forum Member




Join Date: Oct 2011
Posts: 88
QuoteOriginally posted by mickeymon Quote
Sadly, my K5 card reader stopped working. When I put any of the cards I have in it, the camera says: "No card in the camera".

Sometimes it works for a couple seconds and I may even be able to take a shot or two, but then it stops again.

I think this is likely a mechanical fault, possible related to me dropping the camera once.

I know there are better bodies out there, but I am not currently ready for a splurge on a new body.

Anyone has an idea of how much approximately servicing this issue would cost and if it's worth it? BTW, I currently reside in Singapore. Thx.
I assume you tried a different card? If its the camera, and I assume its out of warranty, by the time you send it in and get someone to even open it up to give and opinion you might as well have bought a new camera as the cost of even doing that would be at least half or more of the total current value of your camera.
My advice would be to look for a clearance sale on a K5ii or K5iis. Better way to spend your money.
01-04-2015, 11:29 AM   #3
New Member




Join Date: Jan 2015
Posts: 12
There might be couple of reasons.

Firstly, I would check other card.
Then try checking if the card slot is clean.
The next step, put the card in, simulate closing the door by holding the door micro switch(be careful) and try moving the card in the camera on while having it on.

This way you can check if it's the card or camera itself. Or the card reader.

Depending on the card reader board (involves opening the camera) some other steps might be taken. If the reader is communication via fpcb (flex cable) the cable might be damaged, cut or it might loose connection. If the reader pins are soldered to the circuit board it might be one of the pins broken or loosing connection.

All the above needs some skills and patience but can be done at home. Or if you do not feel confident enough you can take it to a special workshop, the price will depend on the type of damage and unfortunately often on the mood of the technician. [;
01-05-2015, 01:37 PM   #4
Pentaxian
emalvick's Avatar

Join Date: Feb 2008
Location: Davis, CA
Photos: Gallery
Posts: 1,475
If you don't want to buy a new body, you could just buy a used K-5 to replace the one you have. That might be cheaper than a fix, but I'd only suggest that if you determine it is the camera and not the card.

Anytime I've had anything like you describe, it has been the cards. This is especially the case with cheaper cards or know less reliable brands.

01-05-2015, 03:24 PM   #5
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,452
QuoteOriginally posted by mickeymon Quote
When I put any of the cards I have in it, the camera says: "No card in the camera".
Is there any chance that all of the cards you are attempting to use have been used on a Mac computer, but without a clean dismount to eject? Even worse, have any been formatted using the format function on your computer (Mac or PC)?

You might want to try reformatting using the software available from the SD Association:

https://www.sdcard.org/downloads/formatter_4/


Steve
01-05-2015, 05:26 PM   #6
Junior Member




Join Date: Dec 2009
Location: Eureka, MO
Posts: 30
QuoteOriginally posted by stevebrot Quote
Is there any chance that all of the cards you are attempting to use have been used on a Mac computer, but without a clean dismount to eject? Even worse, have any been formatted using the format function on your computer (Mac or PC)?

You might want to try reformatting using the software available from the SD Association:

https://www.sdcard.org/downloads/formatter_4/


Steve
If using it on a Mac be sure and empty your trash can after deleting your photos from the card while the card is STILL in the computer. This removes the backup data that Mac leaves on the card. Otherwise you may not have any space even though your camera isn't showing the previous data. I notice that you didn't try to format the card in the camera in your opening post. May be worth a try?
01-05-2015, 07:18 PM   #7
Veteran Member
DavidSKAF3's Avatar

Join Date: Nov 2013
Location: Tompkins County, NY
Photos: Albums
Posts: 542
My desktop pc's built-in SD card reader recently failed. There seems to be no apparent reason, e.g., like your camera having been dropped. No cards worked anymore. So maybe it just failed. I had to replace the card reader, which is a far easier task than it would be with your K-5. If no cards work, I'd say only a pro technician can solve your problem now.

Last edited by DavidSKAF3; 01-05-2015 at 11:45 PM.
01-06-2015, 07:54 AM   #8
New Member




Join Date: Dec 2008
Posts: 23
Original Poster
QuoteOriginally posted by stevebrot Quote
Is there any chance that all of the cards you are attempting to use have been used on a Mac computer, but without a clean dismount to eject? Even worse, have any been formatted using the format function on your computer (Mac or PC)?

You might want to try reformatting using the software available from the SD Association:

https://www.sdcard.org/downloads/formatter_4/


Steve
Woohoo, this may have solved the problem! The cards seem to work now, after being reformatted with that software.
I have used these cards on my PCs (Win and Linux) and also formatted them there at some point.

Thank you very much!

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, k5, k5 card reader, k5 card reader failure, pentax help, pentax k5 card, photography, reader, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Transferring images - card reader or camera cable? ChooseAName Pentax DSLR Discussion 26 06-19-2013 01:19 PM
SD card reader alamo5000 Troubleshooting and Beginner Help 3 03-18-2013 05:39 AM
Remote Control F, Card Reader, Card, Strap & Cloth $19.99 at Henry's pete-tarmigan Pentax Price Watch 7 02-07-2013 11:00 AM
card reader corrupting Pentax raw files? Douglas_of_Sweden Pentax DSLR Discussion 9 05-04-2008 01:56 AM



All times are GMT -7. The time now is 05:23 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top