Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-12-2015, 04:08 PM   #1
New Member
adriano perticone's Avatar

Join Date: Oct 2014
Posts: 14
Mirror stuck problem in K-50 posible solution

I find a posible solution at the mirror stuck problem. In my case i have the problem only with the kit lens. While taking a picture the mirror would go up to capture the image, would return partially and get stuck midway. The camera was trying to align the mirror to its correct position but was failing again and again and eventually it hanged. I tried to power it off and even that would not happen. The only option left was to remove the battery.
With my other lenses, i never have a problem. I have a Sigma 28-105 DG, a Pentax 80-320, a tokina 19-35, a takumar 50 and a smc 35-80. The solution (untill now) was cover one contact with a piece of adhesive tape. In mi case, i never have again the problem.

Attached Images
View Picture EXIF
NIKON D810  Photo 
01-12-2015, 04:54 PM   #2
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 9,832
Does anyone know what that contact does?
01-12-2015, 04:55 PM   #3
Loyal Site Supporter




Join Date: Aug 2011
Photos: Albums
Posts: 1,861
Interesting. Thanks for sharing.
What is the contact for? I noticed only some DA/DAL lenses have it, while FA lenses don't. Do you notice any issue focusing or metering or camera recording lens information after blocking this contact?
01-12-2015, 04:57 PM - 1 Like   #4
Veteran Member




Join Date: Nov 2010
Location: Huntsville, Alabama
Posts: 422
It is the ground on lenses with plastic mounts.

With metal mounts the whole mount is the ground.

01-12-2015, 05:08 PM   #5
Loyal Site Supporter




Join Date: Aug 2011
Photos: Albums
Posts: 1,861
QuoteOriginally posted by cyclone3d Quote
It is the ground on lenses with plastic mounts.
So it looks it is fine to block it?
01-12-2015, 05:09 PM   #6
New Member
adriano perticone's Avatar

Join Date: Oct 2014
Posts: 14
Original Poster
works ok blocked.
01-12-2015, 06:45 PM   #7
Site Supporter




Join Date: Jan 2011
Posts: 2,391
interesting. how did you reach that conclusion? was it the only lens with the aforesaid contact?
01-12-2015, 11:51 PM - 1 Like   #8
Pentaxian
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 15,400
The contact is , as others have said, the ground for the lens on plastic mount lenses.

Metal mount lenses do not need this because the whole lens mount is conducting.

It is interesting, because I would expect that masking this contact could lead to failure of the lens to be identified or communicate properly. You say masking it made everything better, but in liking at the contact it seems very dirty. Perhaps cleaning it is required. Maybe the intermittent nature of the contact is the issue not it being present.

If this were the case, every metal mount lens would exhibit the problem as well, and I am sure theybdont

01-13-2015, 01:18 AM   #9
Veteran Member




Join Date: Nov 2010
Location: Huntsville, Alabama
Posts: 422
Yep. I say either the ground point on that mount or the bayonet on the camera itself it too dirty to get good contact.

Clean it up and it should work just fine.

"Masking", quite literally, the problem is not a correct fix.
01-13-2015, 06:26 AM   #10
Site Supporter




Join Date: Sep 2014
Photos: Albums
Posts: 897
There is the possibility that the kit lens was not manuf'd properly. The only way to test this would be to try with another plastic mount DA/DAL lens.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, mirror, pentax help, photography, solution, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mirror stuck problem in new Pentax K-50 gurpreet_cpq Pentax K-30 & K-50 46 06-08-2016 10:19 AM
Mirror stuck problem with Pentax K-7 Hans-Christian K Troubleshooting and Beginner Help 6 04-03-2014 04:32 PM
K-30: Mirror Slap Sound Solution? Elley Troubleshooting and Beginner Help 8 04-28-2013 06:18 PM
645 mirror stuck in up position gawan Pentax Medium Format 3 11-21-2011 03:38 PM
MX Problem - Mirror Stuck Leslie P Pentax Film SLR Discussion 3 11-04-2007 02:28 PM



All times are GMT -7. The time now is 09:45 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top