Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-13-2015, 06:19 AM   #1
Junior Member




Join Date: May 2007
Location: saronno Italy
Photos: Gallery
Posts: 26
on my old *ist DS photo preview doesn't work any more

after 10 years of working, suddenly I realized that I cannot see the images on the LCD screen after shooting, I get "Camera cannot display this image", either in Raw or Jpeg.
In advanced view, I get a ? instead of image and all field are --- . Tried different SD cards, formatted them in the machine, no way to have it work again.Images can be downloaded on my computer,

Any idea, or shall I declare it out-of-work??

01-13-2015, 06:35 AM   #2
Loyal Site Supporter
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 10,068
Hmmmm... So it creates the files and you can read them on a computer but won't display them. Odd. I would think trying to replace firmware is a possible fix but maybe a dangerous one. If it misread the firmware things could get worse. I think I would only use it in an emergency and then as though you were using film, multiple shots with bracketing for important pics.
01-13-2015, 07:03 AM   #3
Veteran Member
chromo's Avatar

Join Date: Feb 2010
Location: North Coast NSW
Photos: Gallery | Albums
Posts: 572
Try a reset
01-13-2015, 08:39 AM   #4
Junior Member




Join Date: May 2007
Location: saronno Italy
Photos: Gallery
Posts: 26
Original Poster
Reset was tried but no luck... I get a Bogus dqt index 15 error when opening jpeg files with a viewer, while raw files can be opened with The Gimp, even if not previewed on the camera
I fear that camera is dying :-(

01-13-2015, 07:50 PM   #5
Veteran Member




Join Date: Sep 2013
Location: Pasadena, CA
Photos: Albums
Posts: 1,118
Did you try another memory card?
01-13-2015, 11:02 PM   #6
Junior Member




Join Date: May 2007
Location: saronno Italy
Photos: Gallery
Posts: 26
Original Poster
yes, three different SD's
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, ds photo preview, pentax help, photography, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sigma 70-300mm f4-5.6 Macro DG Lens doesn't work on my Pentax k3 Tiago Visitors' Center 8 12-17-2014 12:43 PM
Can't view my images/playback doesn't work? txacoli Pentax K-5 4 01-23-2014 04:45 PM
Question Why doesn't my photo appear anymore? RobG Site Suggestions and Help 2 01-17-2014 01:01 PM
My *ist DS just won't die jhaji Pentax DSLR Discussion 4 04-12-2013 10:07 PM
*ist ds won't play back after taking photo octoma Troubleshooting and Beginner Help 5 07-06-2012 05:26 AM



All times are GMT -7. The time now is 11:15 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top