Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-16-2015, 01:58 PM   #1
Inactive Account




Join Date: Nov 2014
Posts: 9
Full manual control with M lens

I have a K-50 and just purchased a Pentax 100mm F4 Macro M lens.
I don't know how to set up the camera for full manual control: exposure, shutter and ISO.
I set it up according to the user manual for M lenses with the aperture ring enabled, E-dial programmed to Tv SHIFT.
Shutter speed changes when the camera is in different light.
I need to have full control of the settings as I am stitching together digital captures of artwork. I can't have subtle shifts of exposure as it shows up in the stitched image.
As a clue, no matter what I set on the Mode it always is on Av. Even the M mode shows up as Av on the LCD. So I am guessing i have a wrong setting somewhere. Maybe E-dial should not be set to "Tv SHIFT"?
Any thoughts?
Terry

01-16-2015, 02:04 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,948
QuoteOriginally posted by tsurfing Quote
Maybe E-dial should not be set to "Tv SHIFT"?
The green button should be set to Tv shift, not the e-dial. Also, you are probably still in auto ISO, when that's enabled M mode shows up as TAv.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

01-16-2015, 02:06 PM   #3
Site Supporter
boriscleto's Avatar

Join Date: Dec 2009
Location: Liverpool, NY
Photos: Gallery
Posts: 12,285
QuoteOriginally posted by tsurfing Quote
I have a K-50 and just purchased a Pentax 100mm F4 Macro M lens.
I don't know how to set up the camera for full manual control: exposure, shutter and ISO.
I set it up according to the user manual for M lenses with the aperture ring enabled, E-dial programmed to Tv SHIFT.
Shutter speed changes when the camera is in different light.
I need to have full control of the settings as I am stitching together digital captures of artwork. I can't have subtle shifts of exposure as it shows up in the stitched image.
As a clue, no matter what I set on the Mode it always is on Av. Even the M mode shows up as Av on the LCD. So I am guessing i have a wrong setting somewhere. Maybe E-dial should not be set to "Tv SHIFT"?
Any thoughts?
Terry
Turn off AutoISO. The camera will work in TAv unless you set the ISO to manual. This is because the K50 inherited its firmware from the K-01 which used AutoISO in manual mode as a pseudo TAv. Other Pentax cameras automatically turn off AutoISO when the camera is set to M mode.
01-16-2015, 02:31 PM   #4
Inactive Account




Join Date: Nov 2014
Posts: 9
Original Poster
I had it set at ISO 100 before I first posted.

I am trying to set everything up to have the same exposure over multiple images.

01-16-2015, 02:43 PM   #5
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,948
QuoteOriginally posted by tsurfing Quote
I am trying to set everything up to have the same exposure over multiple images.
If you've set the ISO manually and are in M mode, you'll always get the same exposure unless you change the shutter speed yourself or press the green button. If you don't, there could be something wrong with your camera's shutter, or the aperture diaphragm in your lens (more likely).

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

01-16-2015, 03:08 PM   #6
Inactive Account




Join Date: Nov 2014
Posts: 9
Original Poster
Problem is that when i set the Dial on top to M, It says Av on the LCD. I can't lock the shutter speed. the speed varies in different light. Somehow it is set to adjust automatically for that. Need that ability to freeze all the settings with this lens in this application.
01-16-2015, 03:24 PM   #7
Ole
Administrator
Ole's Avatar

Join Date: Sep 2006
Location: Copenhagen, Denmark
Photos: Gallery | Albums
Posts: 3,783
The only explanation is that ISO is set to Auto ISO. You need to confirm that ISO is on manual. I don't know about the K-50, but on a K-3 the display in the viewfinder will say "ISO auto" to the left of the ISO number unless it is in manual ISO mode. You should double check your ISO setting.
01-16-2015, 03:45 PM   #8
Inactive Account




Join Date: Nov 2014
Posts: 9
Original Poster
I will double check tonite

01-17-2015, 10:05 AM   #9
Inactive Account




Join Date: Nov 2014
Posts: 9
Original Poster
QuoteOriginally posted by Ole Quote
The only explanation is that ISO is set to Auto ISO.
That was it...
The ISO was not changing in different light in M mode so I thought it was on manual.
I pressed the ISO button saw that the variable ISO was selected, changed it to the manual ISO at 100. I set up the camera to capture the art, set the aperture on the lens to f11, pushed the green button to meter the light which set the speed of the shutter to 0.8 seconds. I used that through the series of images overlapping to make sure the stitching will work. All the images came out perfect so thanks for the time to walk me thru it
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
av, camera, control, e-dial, exposure, lens, m mode, manual aperture, manual exposure, manual focus, mode, pentax help, photography, shutter, troubleshooting, tv shift
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
exposure control and manual lens mns Pentax K-01 6 09-20-2013 06:15 AM
Vivitar DM Modules with manual control elliott Flashes, Lighting, and Studio 2 02-11-2013 07:45 PM
No manual control for M lenses ChopperCharles Pentax K-01 8 11-27-2012 04:31 PM
full manual control with fader ND? karl79 Video and Pentax HDSLRs 3 02-16-2010 10:53 AM
Canon EOS 550D with full manual control and 1080p 30 FPS. Firmware update time now? netrex Video and Pentax HDSLRs 17 02-10-2010 12:13 PM



All times are GMT -7. The time now is 05:54 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top