Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-31-2015, 01:12 PM   #1
New Member




Join Date: Jan 2015
Photos: Gallery
Posts: 12
Flu Card serving blank (black) page

Hi,

I've been a long time lurker in these forums, having found a lot of information about my cameras of choice. But today I'm stumped.

I own a Pentax K3 with a Flu Card. Starting a few days ago it now only serves a blank, black page in the browser. No controls, no preview, nothing. After first attempts with my phone's browser I decided to give a desktop browser a chance to see whether there were any issues with the page, or whether some recent OS update on the phone had broken it. But no, same problem in Safari. And indeed I'd get an error message in it's dev console:

Code:
SyntaxError: Invalid character '\u65533'
(anonyme Funktion)192.168.1.1:1
Or in Firefox (which I know not to be supported, but features some better debugging tools):

Code:
SyntaxError: illegal character
...s = 21; pagePlayb������������
Ok, there definitely is an issue with the code. I then saved the downloaded html file and opened it up in a text editor. And searching for above "pagePlayb" does indeed bring up some odd looking code:

Code:
 pageStatus = 21;    pagePlayb������������������������������������������������������������������������...
(followed by many more of these � characters, #65533)

It seems as if somehow my Flu card has got corrupted and is serving broken code. Has anybody seen this before?

I tried to fix the filesystem (which did indeed report issues), but would assume the code was stored in some read-only place, protected from being overridden. I did reset the communication settings, too. To no avail.

The card's firmware version is 00.01.00.01, Content Version 00.01.00.02.

Any help would greatly be appreciated.

Regards,

Michael

02-01-2015, 07:02 PM   #2
Junior Member




Join Date: Feb 2014
Posts: 47
Can you try to re-install the latest firmware by following the procedure at the support page?

Latest K-3 Firmware Update : Software Downloads | RICOH IMAGING

You should wait for enough time to complete the upgrade process before you remove the card from PC (step 6 of the updating procedure).
02-01-2015, 09:13 PM   #3
Veteran Member
rburgoss's Avatar

Join Date: May 2008
Location: San Jose, Costa Rica
Photos: Gallery | Albums
Posts: 972
Just recently bough K3 with flu card, which gave me several headaches before ( with the help of some forum members) could figure out what was wrong and how to fix it.

Check this thread: https://www.pentaxforums.com/forums/58-troubleshooting-beginner-help/286418-k...-both-new.html

One issue not mentioned in that thread and is probably related to your problem, is your smartphone's (tablet's) browser's cache, thar it may be trying to load the pentax flucard from cached memory intead of actual new connection.

Try clearing browser cache by deleting browsing history and then establishing new connection with camera, starting with camera off, then turn on, wait 30 seconds then check wifi connections. Pick flucard, open browser and hit refresh button on browser.

This should establish a fresh new connection without showing any previous error message that may be cached.

Let us know your findings.
02-02-2015, 05:12 AM   #4
New Member




Join Date: Jan 2015
Photos: Gallery
Posts: 12
Original Poster
QuoteOriginally posted by K-3-lover Quote
Can you try to re-install the latest firmware by following the procedure at the support page?
Thanks K-3-lover! I re-flashed the latest firmware, and this indeed brought the card back to life. I should have tried this earlier...

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
browser, camera, card, character, code, flu, flu card, flu card flucard k3, issues, page, pentax help, photography, troubleshooting, version
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K3 + flu card "memory card error" (both new) rburgoss Troubleshooting and Beginner Help 28 02-10-2015 01:16 PM
eyefi card to remote view or only flu card? Daniel Darko Troubleshooting and Beginner Help 25 06-20-2014 05:12 AM
Pentax FLU card Tjompen1968 Pentax K-3 4 01-02-2014 01:36 PM
K-r and flu-card or eye-fi card fizzyvimto Pentax K-r 2 01-02-2014 12:58 AM
Error Blank thread page Russell-Evans Site Suggestions and Help 3 06-28-2010 07:06 AM



All times are GMT -7. The time now is 04:03 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top