Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-05-2015, 10:31 PM   #1
Veteran Member




Join Date: Jan 2015
Location: Salt Lake City, Utah
Photos: Albums
Posts: 305
Flashing red Aperture/Shutter in live view

I tried using a Takumar - F Zoom 28-80mm MACRO 1:3.5-1:4.5 on my K-50 and the f number etc turned red on live view mode.

Now I know it's because the lens doesn't wasn't on A mode for aperture, but is there anything else I should know about using A type lenses? It's all so new to me that I feel like I don't know what I'm doing.

What is the best mode to shoot in with lenses like this?

02-06-2015, 04:36 AM   #2
Emperor and Senpai
VoiceOfReason's Avatar

Join Date: Jun 2010
Location: Nashville, IN
Posts: 5,114
On a lens like this keep it set to a and use your aperture wheel on the camera body to adjust the aperture. Do that and you will be good to go as with your normal kit lens.
02-06-2015, 03:35 PM   #3
Veteran Member




Join Date: Jan 2015
Location: Salt Lake City, Utah
Photos: Albums
Posts: 305
Original Poster
QuoteOriginally posted by VoiceOfReason Quote
On a lens like this keep it set to a and use your aperture wheel on the camera body to adjust the aperture. Do that and you will be good to go as with your normal kit lens.
Thank you!
02-09-2015, 05:25 AM   #4
Senior Member




Join Date: Jan 2014
Location: viking country
Photos: Albums
Posts: 272
If the aperture is not set to A you will need to enter the meny of the camera to allow shooting anyway. Read more here: https://www.pentaxforums.com/forums/54-pentax-lens-articles/110657-how-use-me...k-x-k-7-a.html

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
a type lenses, camera, lenses, mode, pentax help, photography, troubleshooting, view
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
645Z has long shutter lag at Live View mode thomaskplee Pentax Medium Format 7 01-11-2015 02:04 AM
K-r problem solved (temporary) by pressing shutter in live view Shingkyo Pentax K-r 7 06-30-2014 04:13 AM
K5 Live View: Live Exposure Adjustments Visible in "M" Mode? godwinaustin Pentax K-5 6 08-13-2013 08:11 PM
red flashing in lcd screen rca1 Pentax DSLR Discussion 5 04-07-2012 11:11 AM
Red display on K-x Live View Lloyd Troubleshooting and Beginner Help 4 10-17-2010 07:23 PM



All times are GMT -7. The time now is 05:07 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top