Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-14-2015, 07:36 PM   #1
New Member




Join Date: Feb 2015
Posts: 4
A3/a3000

Hi all,

Hoping someone in the know can work out why my A3 is no longer working. I've shot 1 roll and have 10 on the current roll. Went to use it today and not working. Battery light test indicates batteries are not working but I've tried it with new batteries and still nothing. Any tips or tricks greatly appreciated.

Got quoted $NZ90 for just a diagnostic test which is more than the camera!

Thanks!

02-14-2015, 09:28 PM   #2
Loyal Site Supporter
Bruce Clark's Avatar

Join Date: Mar 2010
Location: Brookfield, Victoria
Photos: Gallery | Albums
Posts: 3,698
Check and clean your battery terminals. If left with flat batteries for any length of time you might have some corrosion on the terminals. I am not sure of the construction but a cotton bud with cleaning alcohol or turpentine if not too bad. Use sparingly and be careul not to get fluids on the camera body. Alternatively a cosmetic emery board can be a useful tool to clean terminals if they are badly corroded. Try the cotton bud first before the emery board. The emery board should be the last resort as the abrasion may remove nickel plating on the terminals.
03-07-2015, 04:04 PM   #3
New Member




Join Date: Feb 2015
Posts: 4
Original Poster
QuoteOriginally posted by Bruce Clark Quote
Check and clean your battery terminals. If left with flat batteries for any length of time you might have some corrosion on the terminals. I am not sure of the construction but a cotton bud with cleaning alcohol or turpentine if not too bad. Use sparingly and be careul not to get fluids on the camera body. Alternatively a cosmetic emery board can be a useful tool to clean terminals if they are badly corroded. Try the cotton bud first before the emery board. The emery board should be the last resort as the abrasion may remove nickel plating on the terminals.
Thanks Bruce! Finally got round to trying this today and it worked. Great tip - thanks for sharing.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, camera, pentax help, photography, roll, test, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
pentax A3? baron4004 Pentax Film SLR Discussion 7 11-28-2013 11:32 AM
Pentax A3 sticky shutter. hks_kansei Pentax Film SLR Discussion 8 11-20-2013 11:30 AM
Pentax A3/A3000 Ole Pentax Film SLR Discussion 2 12-30-2010 03:26 AM
A3 - what the heck is A3 anyway? doggydude Photographic Technique 16 12-18-2006 12:14 PM



All times are GMT -7. The time now is 07:35 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top