Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-15-2015, 10:32 AM   #1
Senior Member




Join Date: Feb 2014
Posts: 241
K50 not recognizing my 55-300

I recently received a HD 55-300 WR lens from the pentax store. Everything seems to work great but I noticed last evening when processing photos that the exif say "Unknown Lens"

Any ideas why this would be happening? I don't see that issue with my other lenes.

02-15-2015, 10:51 AM   #2
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,771
What software are you using? Check the EXIF with another program like Exif Reader or Faststone. Sometimes the software needs updating before it recognizes a new lens.
02-15-2015, 10:53 AM   #3
Site Supporter
boriscleto's Avatar

Join Date: Dec 2009
Location: Liverpool, NY
Photos: Gallery
Posts: 12,872
Your software doesn't have the latest version of the EXIF library, therefore it does not recognize the LensID code.

Try ExifTool

ExifTool by Phil Harvey

GUI for Windows

ExifToolGUI
[GUI2 Program
02-15-2015, 04:12 PM   #4
Forum Member
markf's Avatar

Join Date: Jul 2013
Location: Chicago
Posts: 55
I have the same issue with Lightroom.

02-15-2015, 05:30 PM   #5
Des
Loyal Site Supporter
Des's Avatar

Join Date: Jan 2014
Location: Sth Gippsland Victoria Australia
Photos: Albums
Posts: 2,015
It's probably the PP software. But have you installed the latest firmware on the K-50? Pentax Firmware Update Guide - Tutorial Videos | PentaxForums.com
02-15-2015, 08:44 PM   #6
Senior Member




Join Date: Feb 2014
Posts: 241
Original Poster
Thanks everyone. It hadn't occured to me that it might just be the software. I'm pretty sure that is the case. I'm using Apple Aperature.
02-15-2015, 08:52 PM   #7
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
Just to explain it.

The camera only stores the lens ID in the exif. It's up to the processing / viewing software to translate this to a name.
02-15-2015, 09:45 PM   #8
Site Supporter
boriscleto's Avatar

Join Date: Dec 2009
Location: Liverpool, NY
Photos: Gallery
Posts: 12,872
QuoteOriginally posted by TedW Quote
Thanks everyone. It hadn't occured to me that it might just be the software. I'm pretty sure that is the case. I'm using Apple Aperature.
On OS X ExifTool is a command line only program. You have to use Terminal. It's actually easy to use, you just type exiftool -ShutterCount /path/to/file. You can drag and drop the file in the Terminal window to automatically add the path.

Name:  Screen Shot 2015-02-15 at 11.44.11 PM.png
Views: 108
Size:  54.6 KB

Name:  Screen Shot 2015-02-15 at 11.44.25 PM.png
Views: 109
Size:  56.9 KB

GraphicConverter has ExifTool built in. Can't remember if it shows the -ShutterCount tag or not.

02-16-2015, 12:34 PM   #9
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,474
QuoteOriginally posted by TedW Quote
Thanks everyone. It hadn't occured to me that it might just be the software. I'm pretty sure that is the case. I'm using Apple Aperature.
QuoteOriginally posted by sterretje Quote
Just to explain it.

The camera only stores the lens ID in the exif. It's up to the processing / viewing software to translate this to a name.
Yep...the "friendly" lens name is not in the exif, but is pulled from a look-up table in the software. Aperture is notorious for lack of exif camera/lens support and the Adobe products are not much better. Phil Harvey's ExifTool is generally up to date and also has the advantage of providing a reasonable compromise for lens ids where there are duplicates (certain lenses in the Sigma, Tamron, Tokina, and Bayonet Takumar ranges). Another cool feature is that you can edit many fields and supply values that make sense to Aperture, Lightroom, and other products.

Unfortunately, ExifTool is a command-line program and does not provide a friendly user interface nor does it integrate smoothly into the Aperture or Lightroom work flow*. I use a free product called ExifToolGUI (see HERE**) to automatically insert the lens names into the LensModel tag where it can be read by Lightroom. This is best done before import, but does result in the name being available for catalog query.

Unfortunately, this is of little help on a Mac or Linux system. ExifToolGUI is Windows only. If you have some programming expertise a scripted or Python/Java/Whatever app might be a good solution. The ExifTool homepage provides a list of helpful resources towards the bottom of the page.


Steve

* There are Lightroom plug-ins that leverage ExifTool, but the supported features are very specific.

** Although no longer supported by the author, it is feature compatible with all ExifTool versions to date. The download is a bit hard to find, but was available HERE as of the date of this post. Highly recommended.

Last edited by stevebrot; 02-16-2015 at 03:05 PM.
02-16-2015, 12:53 PM   #10
Site Supporter
boriscleto's Avatar

Join Date: Dec 2009
Location: Liverpool, NY
Photos: Gallery
Posts: 12,872
For the info you were looking for...

Name:  Screen Shot 2015-02-16 at 2.53.04 PM.png
Views: 87
Size:  29.2 KB

This is a list of all the Pentax LensType values...

http://www.sno.phy.queensu.ca/~phil/exiftool/TagNames/Pentax.html#LensType

The value of the HD DA 55-300 WR is

QuoteQuote:
'7 203' = HD PENTAX-DA 55-300mm F4-5.8 ED WR
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, pentax help, photography, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: smc PENTAX-DA 1:4-5.8 55-300mm ED (Not DA L) Boxed DA 55-300 transam879 Sold Items 2 07-23-2014 07:41 PM
For Sale - Sold: smc PENTAX-DA 1:4-5.8 55-300mm ED (Not DA L) EXCELLENT DA 55-300 (price reduced) transam879 Sold Items 12 07-21-2014 11:21 AM
For Sale - Sold: Pentax DA*300, DA 55-300 (not DA-L) (Pricing typo fixed!) apisto Sold Items 2 01-30-2014 04:55 PM
K200D not recognizing D-BG3 grip tlemkuil Pentax DSLR Discussion 2 11-07-2010 02:51 AM
K10D not recognizing DA* 60-250 opiet70 Pentax SLR Lens Discussion 16 06-27-2010 10:28 PM



All times are GMT -7. The time now is 07:46 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top