Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-16-2015, 02:49 PM   #1
Site Supporter




Join Date: Aug 2014
Posts: 397
Sigma 70-200 HSM II not autofocus in live view

I was trying out my new Sigma 70-200mm 2.8 EX DG APO Macro HSM that I bought from a forum member and discovered that when using the lens in live view, it will not autofucus. It just shoots from one focus extreme to the other three times and then stops on infinity focus and says it is in focus. There are zero AF issues when using through the viewfinder. Has anyone else had this issue? I've tried all the AF settings I could think of.

Edit: I am using a K-3, latest firmware. The same thing happens when using a K-x.


Thanks!


Last edited by willskywalker93; 02-16-2015 at 02:52 PM. Reason: Forgot to add camera model
02-16-2015, 02:50 PM   #2
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 5,002
Send it to Sigma and they will update the firmware to fix that. I just got back a 120-400 HSM from them with the same issue. Didn't work with CDAF ever, now it works fine.
02-16-2015, 02:53 PM   #3
Site Supporter




Join Date: Aug 2014
Posts: 397
Original Poster
QuoteOriginally posted by vonBaloney Quote
Send it to Sigma and they will update the firmware to fix that. I just got back a 120-400 HSM from them with the same issue. Didn't work with CDAF ever, now it works fine.
What will that cost? Can I just do it with the USB dock? I don't have one, but I could get one if sending it in costs too much.
02-16-2015, 02:58 PM   #4
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 5,002
The dock only works on the latest lenses. It won't cost you anything but the one-way shipping to get it there. Go over to sigmaphoto.com and find the contact form or email address and ask/double-check that there is an update. Give them exact model & serial #. I'm sure they will tell you to send it in for firmware update. Their service is excellent (at New York location -- I'm assuming you are in USA?) They will send it back out in a day or two after receiving it...


Last edited by vonBaloney; 02-16-2015 at 04:10 PM.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, camera, focus, focus problem, hsm, hsm ii, ii not autofocus, live view, live view focus problem, live view focusing, pentax help, photography, sigma, sigma 70-200 hsm, troubleshooting, view
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sigma 70-200 f/2.8: Is HSM faster autofocus? gkreth Pentax SLR Lens Discussion 23 01-31-2015 10:35 AM
Converters on Sigma 70-200 HSM II? jawsy Pentax SLR Lens Discussion 19 06-11-2013 11:09 PM
Autofocus will not engage on K10 using Sigma 70-200mm f/2.8 II EX DG APO Macro HSM AF millesr Troubleshooting and Beginner Help 4 08-14-2012 11:18 PM
Sigma 70-200 HSM II vs. 70-200 HSM II OS Mehlsack Pentax SLR Lens Discussion 4 02-19-2011 10:05 AM
Sigma 70-200 2.8 HSM II + Kenko 1.5X won't autofocus? MrMuz Pentax SLR Lens Discussion 5 04-01-2009 02:59 PM



All times are GMT -7. The time now is 09:31 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top