Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-03-2015, 12:18 PM   #1
Senior Member




Join Date: Sep 2009
Location: Northern Ontario
Photos: Gallery | Albums
Posts: 221
K3 Update Question Camera Turned Itself Off?

Hi All,

Just going to say that all is well, however, I wanted to share my experience.

I started the update on my K3 successfully, with the latest file ( FWDC220B.bin ) in the root directory of the card, and pressed START.

I noticed the camera LCD screen flashing Loading, and put the camera down. A few minutes later there was no activity, and the camera seemed to have powered itself off.

There was no message saying COMPLETE, as the Ricoh page says I should get.

I waited about 5 minutes, and then pressed the shutter release button to reactivate the camera. On checking the functions, all was well and the menu says I had successfully installed the new version 1.11 of the software.

I then turned off the camera and turned it on, I seem to have a perfectly working camera.

It is possible the update happened, and then the camera did an auto power down before I noticed the COMPLETE on the LCD screen.

Just wanted to share the experience, in case some one else wonders.

03-03-2015, 12:21 PM   #2
Pentaxian
VisualDarkness's Avatar

Join Date: Nov 2011
Location: Uppsala, Sweden
Photos: Gallery
Posts: 4,439
Yes, it shuts itself off. As long as it says the right firmware version it's fine.
03-03-2015, 12:23 PM   #3
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,288
"Complete" only flashes on the screen for a bit, easy to miss it. I think many have had the same experience as you. That strange sense of dread when it looks like the camera is bricked.

But all is well
03-03-2015, 12:41 PM   #4
Senior Member




Join Date: Sep 2009
Location: Northern Ontario
Photos: Gallery | Albums
Posts: 221
Original Poster
QuoteOriginally posted by VisualDarkness Quote
Yes, it shuts itself off. As long as it says the right firmware version it's fine.
Thank goodness!

QuoteOriginally posted by jatrax Quote
"Complete" only flashes on the screen for a bit, easy to miss it. I think many have had the same experience as you. That strange sense of dread when it looks like the camera is bricked.

But all is well
Bricked is such an "APT" term.

I believe that the instructions could refer to this happening! If I did it, and you have both had the same experience, so have others. In a way I am surprised that the .bin file does not do a one time over ride on shutting off the camera, and displaying Complete for a half hour or so. In the sake of being user friendly.

All's well that ends well!

03-03-2015, 12:59 PM   #5
Moderator PEG Judges
Kerrowdown's Avatar

Join Date: Aug 2008
Location: Highlands of Scotland.
Photos: Gallery
Posts: 30,650
QuoteOriginally posted by ROBEFFY Quote
A few minutes later there was no activity, and the camera seemed to have powered itself off.
A few scary moments there then.

Good all ended well for you.
03-03-2015, 01:00 PM   #6
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 9,537
Saw something similar on my K50, freaked out for a few minutes and then found like you did that all was OK.
03-03-2015, 03:07 PM   #7
Senior Member




Join Date: Sep 2009
Location: Northern Ontario
Photos: Gallery | Albums
Posts: 221
Original Poster
QuoteOriginally posted by Kerrowdown Quote
A few scary moments there then.

Good all ended well for you.
Absolutely! Last thing I want to do is fight my favorite toy!

QuoteOriginally posted by UncleVanya Quote
Saw something similar on my K50, freaked out for a few minutes and then found like you did that all was OK.
What a feeling of relief.
03-03-2015, 03:32 PM   #8
Site Supporter




Join Date: Dec 2012
Location: Kristiansand S
Photos: Gallery | Albums
Posts: 189
Seen it...

Been there, done that....

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, experience, k3, k3 update question, lcd, minutes, pentax help, photography, screen, share, troubleshooting, update
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
A strange sound when camera turned on or off. Dewman Troubleshooting and Beginner Help 4 09-23-2014 01:43 AM
K3(Body Only) at From Amazon itself $1059 danny09 Pentax Price Watch 45 02-26-2014 09:22 PM
Is there a auto-lens retraction setting for when camera is turned off? harioharima Pentax K-01 10 02-21-2013 05:27 PM
Took K100D apart to polish dirty viewfinder, now camera turns itself off immediately loddie Pentax DSLR Discussion 12 04-08-2012 04:39 AM
K200D shake reduction turned itself off Riverlady Pentax DSLR Discussion 4 06-23-2009 06:19 PM



All times are GMT -7. The time now is 01:53 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top