Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-05-2015, 07:37 AM   #1
Site Supporter




Join Date: May 2013
Location: Nashville, TN
Posts: 18
K 30 shutdown

Any ideas? I put my K 30 up 2 weeks ago, went to use it this AM and no response at all. Changed battery for one just charged. No response again. Changed battery several times, nothing. Finally camera responded but had reverted to original set-up screen. (Date, time, etc.) Set date and time, seems to be OK. Again, any ideas?

03-05-2015, 07:50 AM   #2
Senior Member
Painter's Avatar

Join Date: Jun 2008
Location: Canada
Photos: Gallery
Posts: 275
It's possible that the battery went completely flat and rather than maintaining the capacitor that holds memory and runs the clock it draned it. How long was the new battery in the camera before you re-swapped it?
03-05-2015, 08:12 AM   #3
Site Supporter




Join Date: May 2013
Location: Nashville, TN
Posts: 18
Original Poster
Just a matter of a few minutes. When it came back to life it had been inserted about 8 to 10 minutes. I thought to begin with that it might be battery related. I am not certain that the camera was turned off when I put it up. I normally have the timer set to turn off in 5 minutes. I was just wondering if there was any other problem relating to the K 30 that might cause this.

Thanks for your prompt reply.
03-05-2015, 08:32 AM   #4
Veteran Member
JimC1101's Avatar

Join Date: Aug 2010
Location: Fremont, Ca
Photos: Albums
Posts: 393
Never heard of any problems reported.


I don't know if you use the lithium or the AA battery holder. I had a problem with my holder one day when the camera shut off, and it was fine after that. Only happened once but to make sure, I cleaned the contacts within the camera and the holder, There is electrical current there so in time, you might get some microscopic gunk that might affect the connection. Just a little Qtip with a little alcohol and I have never had the problem again.

03-05-2015, 11:46 AM   #5
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,287
QuoteOriginally posted by JimC1101 Quote
I don't know if you use the lithium or the AA battery holder.
...or if the AA holder, what batteries were loaded.


Steve
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, camera, date, ideas, pentax help, photography, response, time, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Focusingscreens.com EE-S Screen for K-3, K-5, K-5II, K-7, K-30, K-50 & K-500 Aperturae Sold Items 6 10-06-2014 06:49 AM
For Sale - Sold: KatzEye Split-Prism Focusing Screen - for K-3, K-5, K-5II, K-7, K-30, K-50 & K-500 chickentender Sold Items 7 04-15-2014 08:35 PM
New Firmware for K-500, K-50, K-5 II, K-5 IIs, K-5, K-30, K-01, K-r, and 645D is out Adam Pentax News and Rumors 60 09-16-2013 05:46 AM
Korean K-30 Focus-Peaking Test (and Overall K-30 Review) Welfl Pentax K-30 & K-50 8 08-23-2012 01:06 PM



All times are GMT -7. The time now is 12:16 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top