Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-05-2015, 07:53 PM   #1
New Member




Join Date: Mar 2015
Posts: 4
Pentax ME Super Advance Lever Misfire

I have an interesting situation, and whether or not it's common, I'm not sure. But my problem is that it's gotten to a point where I can pull the advance lever, and it goes all the way and pulls the shutter up with it, but then proceeds to let the shutter go when I let the wind lever go. The shutter button is pretty much useless at this point, because the shutter releases before I even have a chance to press the button. I don't know if the shutter is actually firing, or just opening and closing. The shutter speed changes based on how slowly I release the advance lever.

When I got the camera, I could pull the advance lever, (I don't know if it pulled the shutter up or not, I don't think so) and then release it, and it wouldn't do anything, nor would the shutter button. It would just crank, then I'd release it, and I could just crank it again. I felt little resistance. This was before some tinkering I shouldn't have done.

I've gone on a film craze this week, I think I've ordered ~6 cameras. I love getting them and then figuring out how they work. I would really appreciate any help, as this is the only one I haven't been able to fix. Thanks!

03-05-2015, 09:02 PM   #2
Pentaxian




Join Date: Jul 2013
Photos: Gallery | Albums
Posts: 598
It's a common fault. Pitch it. It isn't worth repairing.
03-05-2015, 09:12 PM   #3
New Member




Join Date: Mar 2015
Posts: 4
Original Poster
QuoteOriginally posted by Wolfeye Quote
It's a common fault. Pitch it. It isn't worth repairing.
There's nothing I can do to fix it? Is it a mechanical problem? Is it gummed up seals?
03-05-2015, 09:17 PM   #4
Site Supporter
arnold's Avatar

Join Date: Aug 2012
Location: Queensland
Photos: Gallery | Albums
Posts: 3,192
There does seem to be a weakness in the winding mechanism of the ME Super. On mine, I sometimes have to wind twice before the shutter fires. You can get it repaired by Eric if you like it enough to spend about $80. I have an MG that came with a lens. It was U/S, so I had a peek inside. I was not impressed with the quality of the parts. I think the MX must have been the best of the M series for quality.

03-05-2015, 09:22 PM   #5
New Member




Join Date: Mar 2015
Posts: 4
Original Poster
I contacted Eric, but I wasn't looking to spend 3x the amount on a repair as I did on the camera. Looks like it's going on for parts. Thank you for the replies.
03-06-2015, 07:06 AM   #6
Pentaxian




Join Date: Jul 2013
Photos: Gallery | Albums
Posts: 598
QuoteOriginally posted by freefall Quote
I contacted Eric, but I wasn't looking to spend 3x the amount on a repair as I did on the camera. Looks like it's going on for parts. Thank you for the replies.
Aye, and the next time it breaks it'll be some new thing, not covered by his warranty. These cameras are getting old and just not worth fixing.
03-06-2015, 08:41 AM   #7
Site Supporter




Join Date: Sep 2009
Location: Texas
Photos: Gallery
Posts: 3,393
QuoteOriginally posted by freefall Quote
I contacted Eric, but I wasn't looking to spend 3x the amount on a repair as I did on the camera. Looks like it's going on for parts. Thank you for the replies.
Find another in good condition and keep your current one as a parts camera for when the new one breaks.
03-06-2015, 11:10 AM - 1 Like   #8
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,158
QuoteOriginally posted by r0ckstarr Quote
Find another in good condition and keep your current one as a parts camera for when the new one breaks.
...or find a copy of the better-spec'ed Ricoh XR7 of the same vintage. My two copies have been remarkably troublefree.*


Steve

* I actually have three XR7 bodies, but one was bricked due to a chance encounter with a defective Russian fisheye

03-07-2015, 09:27 AM   #9
New Member




Join Date: Mar 2015
Posts: 4
Original Poster
At the moment, I have 9 film cameras not including the Super. K1000 SE brown is my favorite. So I'll just sell this one. It's in fantastic condition, it's too bad.
03-10-2015, 03:48 PM   #10
Site Supporter




Join Date: Oct 2012
Location: weston-super-mare
Posts: 222
I wonder if using the ME winder would solve the problem?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
advance, advance lever, button, camera, lever, pentax help, photography, release, shutter, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
pentax k1000 advance lever wetigers Troubleshooting and Beginner Help 2 05-12-2014 12:36 PM
Pentax me super wind lever problem Manchesterroses Troubleshooting and Beginner Help 5 03-13-2014 11:29 PM
ME Super advance lever not returning darrenleow Pentax Film SLR Discussion 2 01-25-2010 01:10 PM
ME Super film advance lever problem! Thursday Pentax Film SLR Discussion 8 09-12-2007 12:07 AM



All times are GMT -7. The time now is 09:45 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top