Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-08-2015, 03:06 PM   #1
Pentaxian




Join Date: Nov 2007
Location: Western Canada
Posts: 3,832
K5lls + 100 Macro issues

A friend has a K5lls and a Pentax 100 Macro (latest edition) and with this combination, the monitor info just shows MF letters, no F stop just two blinking dashes, just iso and the rest of the screen shows no other info and the monitor screen is blank and kind of dark.

She has tried her other lenses (55-300) on the K5lls body and they work fine...with all info showing on the monitor body.
It's just the 100 macro on the K5lls.

Now when she tries the 100 Macro lens on her KX body the macro and camera works fine.

Any suggestions ?

03-08-2015, 03:12 PM   #2
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,288
I assume this is DFA 100 macro WR? Or at least the version with no aperture ring? If not then make sure the aperture ring is in the 'A' position.

Other than that, getting "F _ _" means the camera does not know there is a lens on because it cannot read the lens ID. That is almost always a contact issue. So try cleaning the contacts, a buffing with a microfiber cloth should be all it needs.

If that does not work, take a careful look at the contacts on both camera and lens and make sure they all look correct.

When you say "KX" do you mean the k-x or the film body?
03-08-2015, 03:19 PM   #3
Pentaxian




Join Date: Nov 2007
Location: Western Canada
Posts: 3,832
Original Poster
QuoteOriginally posted by jatrax Quote
I assume this is DFA 100 macro WR? Or at least the version with no aperture ring? The WR without the aperture ring. If not then make sure the aperture ring is in the 'A' position.

Other than that, getting "F _ _" means the camera does not know there is a lens on because it cannot read the lens ID. That is almost always a contact issue. So try cleaning the contacts, a buffing with a microfiber cloth should be all it needs. I will suggest that she try that.

If that does not work, take a careful look at the contacts on both camera and lens and make sure they all look correct.

When you say "KX" do you mean the k-x or the film body?
The K-x digital slr camera. Not the old film slr. The one that was introduced a couple of years ago.

Thank you for your suggestions.
03-08-2015, 03:29 PM   #4
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,288
QuoteOriginally posted by lesmore49 Quote
The K-x digital slr camera. Not the old film slr.
What I figured but wanted to be sure in case there was something with a film body I was not aware of. But the k-x and k5IIs should behave identically. The only thing I can think of is that there is some small amount of tarnish on the k5IIs contacts that is causing the communication failure.

It could also be a slight misalignment of the contacts but that is highly unlikely on a Pentax lens. I have seen it on third party lenses though.

03-08-2015, 03:33 PM   #5
Marketplace Reseller
dcshooter's Avatar

Join Date: Jan 2011
Location: Washington DC
Photos: Gallery | Albums
Posts: 4,115
A pencil eraser is just about the most effective tool for cleaning tarnish off the contacts.
03-08-2015, 05:13 PM   #6
Pentaxian




Join Date: Nov 2007
Location: Western Canada
Posts: 3,832
Original Poster
A big thank you to both jatrax and dcshooter. My friend cleaned the contacts and as they say in France...'voila'....the K5lls and 100 WR macro are once again making music.

Les
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
body, camera, info, k5lls, k5lls 100 macro, macro, monitor, pentax help, photography, screen, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Issues with K-01 + DA35 Macro? luftfluss Pentax K-01 7 11-03-2014 05:50 PM
K5lls and Katzeye screen TaiChiTom Pentax K-5 7 08-14-2013 10:32 AM
Focusing issues with Sigma 105mm macro cam541 Pentax K-01 4 06-02-2013 06:20 AM
D FA Macro 100 / Tamron 90 Macro: Good for events? EarlVonTapia Pentax SLR Lens Discussion 22 05-16-2013 05:34 AM
Sigma 100-300mm f/4 serious issues CWyatt Pentax SLR Lens Discussion 12 02-25-2010 02:29 PM



All times are GMT -7. The time now is 07:50 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top