Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-12-2015, 12:04 PM   #1
New Member




Join Date: Apr 2015
Posts: 2
K5 will not power up

I bought a used K5 about 2 weeks ago. I snapped about 200 photos over that time and I have to say I absolutely love this camera. But unfortunately I went to use my camera last night and it would not turn on. Here is what happens. I turn it on and I get a sound as if the shutter is working. The LCD panel lights up for about 1/4 of a second. I can see the battery indicator showing I have a full charge, then it shuts down and will not do anything. I can turn it off and it will do the same thing again when I turn it on. I took put the battery put it on the charger just to make sure then put it back in and I got the same thing. I cleaned the contacts on the battery and still nothing. I thought about buying another battery but thought I would ask before doing that. Please help!!

04-12-2015, 12:21 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,986
It's quite possible that the battery is no longer good, especially if it wasn't used regularly in the past. It's also possible but unlikely that the electronics in the camera have gone bad.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

04-12-2015, 02:14 PM   #3
Site Supporter
demondata's Avatar

Join Date: Oct 2006
Location: Aurora, Ontario, Canada
Photos: Gallery | Albums
Posts: 326
The sound that you hear may be the sensor cleaning mechanism, which can be activated at start-up as desired, or not. Pity you can't even turn it off. If the battery is very near it's end of like, that sensor cleaning action may just suck the last bit of juice out of it. I'd get another battery - the aftermarket ones can be quite good, depending, and you'd probably need a second one anyway.
04-12-2015, 02:47 PM - 1 Like   #4
Veteran Member
crewl1's Avatar

Join Date: Jul 2010
Location: Los Angeles, CA
Photos: Gallery | Albums
Posts: 9,795
Make sure the card door is closed, the camera won't turn on if it is open.

04-12-2015, 03:23 PM   #5
Loyal Site Supporter
robgski's Avatar

Join Date: Nov 2012
Location: Shenandoah Valley, Virginia
Photos: Gallery | Albums
Posts: 1,833
QuoteOriginally posted by crewl1 Quote
Make sure the card door is closed, the camera won't turn on if it is open.
Exactly! I've forgotten to put in an SD card and close the door, and though my camera was broken, fortunately it was only me.
04-12-2015, 04:45 PM   #6
New Member




Join Date: Apr 2015
Posts: 2
Original Poster
Thank you very much for the information. As it turns out the SD card door was open. After reading this I looked to make sure all the doors were closed. When I closed the SD card door it started working again as it should. Again thank you for the valuable information.
04-12-2015, 04:56 PM   #7
Forum Member




Join Date: Aug 2013
Location: Lake Arrowhead, CA
Posts: 91
The forum members here (me excluded) are very knowledgeable and willing to share that infomation. I've learned a lot here just by reading.
04-12-2015, 09:26 PM   #8
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
QuoteOriginally posted by Bryce K Quote
I've learned a lot here just by reading.
So now you're also knowledgeable

04-12-2015, 09:35 PM   #9
Veteran Member
crewl1's Avatar

Join Date: Jul 2010
Location: Los Angeles, CA
Photos: Gallery | Albums
Posts: 9,795
QuoteOriginally posted by kaju Quote
Thank you very much for the information. As it turns out the SD card door was open. After reading this I looked to make sure all the doors were closed. When I closed the SD card door it started working again as it should. Again thank you for the valuable information.
Glad you got it sorted.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, camera, k5, pentax help, photography, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K5 IIS Focus Points Not Showing Up DavidDwight Troubleshooting and Beginner Help 7 10-08-2014 02:57 PM
K5 battery depletion message/shutter will not fire Scenesaver Pentax K-5 8 01-26-2014 08:09 AM
remote will not work on my K5 Pete C Troubleshooting and Beginner Help 7 12-23-2013 02:49 PM
K5 will not work with SLR lens; why? wlwlad Pentax K-5 3 08-24-2013 12:43 PM
Help K10D Will not Power on !!! daacon Pentax DSLR Discussion 31 12-11-2007 12:35 AM



All times are GMT -7. The time now is 02:09 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top