Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-15-2015, 10:26 AM   #1
New Member




Join Date: Apr 2015
Posts: 2
Pentax ist DS and ist DL problem

Hi everyone, im long time lurker here and finaly decided to ask you for help if you can provide any. So to keep it all simple these are my problems :
Pentax ist DS : every time i take a picture its pure white, no matter what i do with exposure and settings its always white, is it some kind of sensor problem or something else ?
Pentax ist DL : freezes every time i turn him on and makes clicking sound when i press any of the buttons.
I got these cameras as a gift and he told me they are not working and if i can fix them they are mine to use.
Any advice would be nice.
Thank you in advance !

04-15-2015, 12:58 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 42,273
Both sound like they have some defective hardware. Mostly likely not worth repairing at today's prices, unfortunately

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

04-15-2015, 01:03 PM   #3
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 9,756
A similar performance camera is the K100D or K100D Super. There is one in the marketplace that I saw recently. Alternatively you can simply look at other more modern used DSLR options.

Just for grins - is the card in the first camera newly reformatted? If you take it and mount it on your computer do you see files and can you view them?
04-15-2015, 01:30 PM   #4
Pentaxian
normhead's Avatar

Join Date: Jun 2007
Location: Near Algonquin Park
Photos: Gallery | Albums
Posts: 25,051
My *ist burned out a chip in the exposure sequence, my exposures slowly went black over about 3 weeks. I had an extended warranty, so it was repaired, and the cost of the repair was $750. I can't image these cameras are worth fixing, unless you were to try and do some chip swapping yourself. For myself, at the time of the repair the K100D was selling for about $549... they never offered me the choice of saving them $200 and just giving me one of those. After complaints from people like myself, the new warranty includes replacement in kind, in other words, if it was top of the line at the time, they buy you the current top of the line, or whatever is closest to the equivalent price of what you paid for yours.

04-16-2015, 02:04 AM   #5
New Member




Join Date: Apr 2015
Posts: 2
Original Poster
Thank you all i tought so myself but wanted to ask anyway, i guess they will be on a shelf for quite some time
05-14-2015, 08:53 PM   #6
Forum Member
Bertminator's Avatar

Join Date: Feb 2014
Posts: 79
QuoteOriginally posted by Neven Quote
Hi everyone, im long time lurker here and finaly decided to ask you for help if you can provide any. So to keep it all simple these are my problems :
Pentax ist DS : every time i take a picture its pure white, no matter what i do with exposure and settings its always white, is it some kind of sensor problem or something else ?
Pentax ist DL : freezes every time i turn him on and makes clicking sound when i press any of the buttons.
I got these cameras as a gift and he told me they are not working and if i can fix them they are mine to use.
Any advice would be nice.
Thank you in advance !
My guess would be the aperture control block may be shot. I had a similar thing happen to my K-50 recently. it would take the 1st series of photos totally UNDER exposed to the point where it was black, and in auto mode if bursting a series of same shots..the photo would go from black to ok...got it repaired under warranty, and they replaced that aperture control block. Seemed to fix things for now.
05-20-2015, 09:15 AM   #7
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 9,756
QuoteOriginally posted by Bertminator Quote
My guess would be the aperture control block may be shot. I had a similar thing happen to my K-50 recently. it would take the 1st series of photos totally UNDER exposed to the point where it was black, and in auto mode if bursting a series of same shots..the photo would go from black to ok...got it repaired under warranty, and they replaced that aperture control block. Seemed to fix things for now.
Mine went the other way but the same part was involved. Mine would horribly overexpose and then work great in the same string of pictures.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dl, ds, ist dl camera, ist ds camera, not working, pentax, pentax help, pentax ist ds, photography, problem, time, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Infrared Conversion - *ist DS and *ist DL carpents Pentax DSLR Discussion 11 09-02-2014 07:56 PM
Pentax ist ds problem with shooting denise60 Troubleshooting and Beginner Help 3 01-02-2014 07:55 PM
*ist DS or *ist DL size jct us101 Pentax DSLR Discussion 7 02-02-2009 02:18 PM
What does it mean - *ist in the name of Pentax *ist D/DS/DL ogl Pentax News and Rumors 16 05-02-2008 06:05 AM



All times are GMT -7. The time now is 06:21 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top