Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-21-2015, 05:11 PM   #1
New Member




Join Date: Mar 2015
Posts: 17
K50 With OVF Problem

My K50 is only a few months old and really like it. There is something that looks like dirt or some other contaminant in the OVF that does not show in the images. Lens is clean as is the eyepiece, so it must be internal. Since new to Pentax (except for my lovable ME Super from many years ago) and could anyone comment on whether this is a warranty covered item? It's not been in any dust and kept in a clean camera bag. Can anyone comment on warranty turnaround time? Assuming I cover shipping to them, but do they cover return? And they repair my camera and not send me a refurbished one? Many thanks Pentaxians!

04-21-2015, 05:15 PM   #2
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,426
Dust or fibers in the view finder. Likely under the focusing screen. This would not be a warranty issue. Use a rocket blower to clean or just ignore it. Even if you clean it all out something will get back in there, it is a constant battle. Note that this is in the viewfinder only and has no effect on your images. Dust spots on the images are going to be from dust on the sensor, which a another whole issue.
04-21-2015, 07:04 PM   #3
Site Supporter




Join Date: Sep 2014
Photos: Albums
Posts: 850
I get dust and fibers in my OVF all the time. If you are careful, you can take out the focusing screen to blow it out and wipe it off with a microfiber cloth. Just look straight into the mount area of the camera and you'll see the tray for the focus screen, carefully with your fingernail, pop the spring latch at the top of that tray, and it will hinge out. Take a rocket blower to the OVF cavity, and wipe the focus screen wth mf cloth or a lens brush. Place focus screen back into tray with the top tab facing up (if looking at it from the bottom of the camera with the pentax logo facing you right side up) the tab goes on the left hand side, if pentax logo is upside down and you're looking from the top of the camera, the tab would be on your right hand side. Press tray back into locked position.
04-21-2015, 07:42 PM   #4
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
QuoteOriginally posted by jimx200 Quote
There is something that looks like dirt or some other contaminant in the OVF that does not show in the images
Are you sure it's not the fresnel pattern that you see? It looks like grain would possibly be the best description? If so, it's normal.

04-21-2015, 11:33 PM   #5
Loyal Site Supporter
AquaDome's Avatar

Join Date: Jan 2014
Location: New Carlisle, IN
Photos: Gallery | Albums
Posts: 1,437
Check for dust on the mirror too.
04-22-2015, 09:49 AM   #6
New Member




Join Date: Mar 2015
Posts: 17
Original Poster
Thanks for the suggestions and fast replies. I'm taking it to a friend who is a seasoned pro (former Nat Geo staff shooter) who will clean it for me. I know his weak spot..Sierra Nevada Pale Ale...lol.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k50, k50 with ovf, ovf, pentax help, photography, troubleshooting, warranty
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K50 sensor problem Dianadcb Pentax K-30 & K-50 16 12-01-2015 06:22 AM
For Sale - Sold: Q rangefinder kit, with 01 prime, OVF, accessories audiobomber Sold Items 23 02-08-2015 09:35 AM
K50 Works with LiveView. Underexposed with Viewfinder AndrewDD Troubleshooting and Beginner Help 7 11-10-2014 05:18 PM
K50 Sensor Mount Issue/Problem? RCDREAMS Troubleshooting and Beginner Help 10 10-20-2014 01:06 PM
Metz flash with k50 Gerrys Troubleshooting and Beginner Help 2 08-20-2014 03:03 PM



All times are GMT -7. The time now is 10:00 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top