Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-01-2015, 09:21 PM   #1
New Member




Join Date: Jun 2014
Location: Sydney
Photos: Gallery
Posts: 8
Pentax K-7 Front e-dial in Manual Mode

Hi everyone,

Just writing to inquire as to whether anyone else has experienced this issue with the front e-dial on the Pentax K-7 when used in Manual metering mode. Basically, this is what happens – according to page 107 of the instruction manual, the front e-dial can be used to adjust the shutter speed after a metered reading is taken by pressing the Green button. When I attempt to do this on my K-7 (irrespective of which way the dial is turned), the shutter speed values change in one direction only (e.g. from 1/80s > 1/125s > 1/250s, etc, all the way to the maximum shutter speed).

No matter which way I turn the front e-dial, there is no way of going back to a slower shutter speed and the value indicated remains on 1/800s or whatever. I have come up with a work-around using the AE-Lock button (and adjusting the rear e-dial until the desired shutter speed is attained, after which I disengage the AE-lock button, change the aperture setting to the desired value using the rear e-dial, then use the AE-lock button to lock these settings).

Please tell me that it shouldn’t be this hard !

Thanks in advance for any advice/feedback on this issue.

05-01-2015, 10:40 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,954
QuoteOriginally posted by Photobuddy25 Quote
Hi everyone,

Just writing to inquire as to whether anyone else has experienced this issue with the front e-dial on the Pentax K-7 when used in Manual metering mode. Basically, this is what happens – according to page 107 of the instruction manual, the front e-dial can be used to adjust the shutter speed after a metered reading is taken by pressing the Green button. When I attempt to do this on my K-7 (irrespective of which way the dial is turned), the shutter speed values change in one direction only (e.g. from 1/80s > 1/125s > 1/250s, etc, all the way to the maximum shutter speed).

No matter which way I turn the front e-dial, there is no way of going back to a slower shutter speed and the value indicated remains on 1/800s or whatever. I have come up with a work-around using the AE-Lock button (and adjusting the rear e-dial until the desired shutter speed is attained, after which I disengage the AE-lock button, change the aperture setting to the desired value using the rear e-dial, then use the AE-lock button to lock these settings).

Please tell me that it shouldn’t be this hard !

Thanks in advance for any advice/feedback on this issue.
There are various e-dial customization options, and they are mode-specific. Are you sure your front e-dial is configured correctly?

This is a screenshot from the K-50 but the K-7 is similar:

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

05-01-2015, 11:55 PM   #3
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
Adam, I can't really imagine a customization that, regardless of direction, only allows increase (or decrease for that matter) of a parameter.

Photobuddy25, try TAv mode (or any other mode where the front dial is functional; or customize e.g. Av mode to use the front dial for aperture); is the behaviour the same?
Although it's just a guess, try a reset to factory defaults.
Further the dial might just be dirty (inside), but I would expect inconsistent behaviour in that case, not what you describe.
05-02-2015, 12:40 AM   #4
New Member




Join Date: Jun 2014
Location: Sydney
Photos: Gallery
Posts: 8
Original Poster
Pentax K-7 Front e-dial in Manual Mode

Hi sterretje and Adam,

Thanks for the quick responses. I will try a factory reset and then go through my customisation options, hopefully this will help. Will report back on whether this has fixed the problem, although I am inclined to agree with sterretje, as the camera should work according to the manual straight out of the box (I have been using Aperture Priority mode 99% of the time during which I had the camera).

Regards,
Chris

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
ae-lock, button, camera, change, e-dial, front, front e-dial, k-7, k-7 front e-dial, manual mode, pentax help, pentax k-7, pentax k-7 front, photography, shutter, troubleshooting, value
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-50 Rear e-dial jam (Av mode)? ps1984 Pentax K-30 & K-50 4 04-14-2015 01:13 AM
K-50 Noisy Front E-Dial suzook600 Pentax K-30 & K-50 4 02-17-2014 05:28 PM
K-30: Lost Manual Mode on E-Dial knightzerox Pentax K-30 & K-50 7 12-06-2013 11:31 PM
slow to respond/ eratic e-dial adjustment in manual mode billsantos01 Pentax DSLR Discussion 2 09-05-2013 08:49 AM
K-7 front e-dial repair? or not? steve1307 Pentax DSLR Discussion 2 09-20-2012 09:48 PM



All times are GMT -7. The time now is 02:09 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top