Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-23-2015, 02:55 PM   #1
New Member




Join Date: May 2015
Posts: 4
Pentax 67 ttl meter issue

Hello everyone!

I recently bought a Pentax 67 which came with a ttl meter prism but I cannot for the life of me get it to work.

The battery is in correctly, the contacts seem to be clean and connecting, the chain isn't broken and I had plenty of light to test it in but the needle will not budge from the bottom.

I have tried taking the lens and the prism off and putting it back on but still nothing. When I go to put the Lens (55mm f3.5) in auto mode the switch pings back to manual mode - is the supposed to happen?

I'm just a little confused at what else to do. Is it broken or am I missing something?

Thanks guys!

06-15-2015, 12:23 AM   #2
Veteran Member
Silent Street's Avatar

Join Date: Nov 2011
Location: Geelong & Richmond, Vic AUS
Posts: 547
Make sure the meter coupling chain is not broken; you stated this in your post, but just to mention it. Remove the prism and shine a torch onto the chain; the coupling tab should be to the extreme right (as you look down from the front).

When mounting a lens, keep your fingers clear of the auto-manual slider; it's very easy to unconsciously grip it and "slip" it from auto to manual during mounting (or dismounting).

The possibility of a dead circuit or switch in the meter comes to mind, but more thorough checks need to be made of the camera/prism interface and the chain condition.
06-29-2015, 05:04 AM   #3
New Member




Join Date: May 2015
Posts: 4
Original Poster
Hi silent street,
The chain is definitely not broken, I had to take it into a repair centre in the end who are fixing it for me. I think it's a dodgey circuit!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, lens, meter, mode, pentax, pentax 67 ttl, pentax help, photography, prism, troubleshooting, ttl, ttl meter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax 67 TTL prism light meter! sunshine7913 Pentax Medium Format 5 01-30-2015 02:10 PM
Pentax 67 TTL pentaprism meter problem? bienemaya Pentax Medium Format 9 04-24-2012 06:06 AM
Pentax 67 TTL prism meter window not visible vmixer Pentax Medium Format 8 11-15-2011 07:54 AM



All times are GMT -7. The time now is 10:40 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top