Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-24-2015, 02:12 PM   #1
New Member




Join Date: May 2015
Photos: Albums
Posts: 14
Help with a K-S1

Hello everyone,
New to the forum and DSLR cameras...
I bought a K-S1 yesterday ...I took a couple of pics and they were fine.
Today I was gonna have a proper go with it ...But it won't take pics....well it will and it won't if...... I try taking a pic looking through the viewfinder it wont focus and take the pic.....but when I take one using the monitor on the back .....it does.....so as you can imagine I'm at a loss.
Can anyone help?

05-24-2015, 02:44 PM   #2
Pentaxian




Join Date: Sep 2013
Location: Sydney
Photos: Albums
Posts: 844
Check the autofocus switch - it's very easy to accidentally knock onto manual focus mode. If that doesn't work, try reattaching the lens.
05-24-2015, 02:57 PM   #3
New Member




Join Date: May 2015
Photos: Albums
Posts: 14
Original Poster
done both ....when i look through veiw finder everything seems dark
05-24-2015, 03:17 PM   #4
Pentaxian
Aaron28's Avatar

Join Date: Jan 2015
Location: Huntsville, Al
Posts: 1,070
what mode ya in? are ya inside, outside?

05-24-2015, 03:19 PM   #5
New Member




Join Date: May 2015
Photos: Albums
Posts: 14
Original Poster
night time now but earlier was out in the garden in the day time ......camera would'nt focus
05-24-2015, 03:22 PM   #6
Pentaxian
Aaron28's Avatar

Join Date: Jan 2015
Location: Huntsville, Al
Posts: 1,070
what mode on were ya attempting to use?
05-24-2015, 03:28 PM   #7
New Member




Join Date: May 2015
Photos: Albums
Posts: 14
Original Poster
auto mode
05-24-2015, 03:42 PM   #8
Pentaxian
Aaron28's Avatar

Join Date: Jan 2015
Location: Huntsville, Al
Posts: 1,070
not sure why it would hunt focus in day light and be very dark....esp in the mode and since ya checked that the switch was not on manual focus.......wish I had something for ya...it will come along

05-24-2015, 03:46 PM   #9
New Member




Join Date: May 2015
Photos: Albums
Posts: 14
Original Poster
sorry my answers are probably helpful
05-25-2015, 03:16 AM   #10
New Member




Join Date: May 2015
Photos: Albums
Posts: 14
Original Poster
Don't know if this helps....but I managed to take 1 pic through the view finder.....and it was all whited out..?
05-25-2015, 07:08 AM   #11
Veteran Member




Join Date: Jul 2009
Location: London
Posts: 889
I'd do a factory reset in case you've inadvertently changed a setting.

Copied the following instructions from the web;

To restoring Pentax K-S1 to it’s factory settings, conform to the following instructions:
◾PRESS [Menu] button
◾Use E-dial to switch to “Wrench icon”
◾Select “RESET” by use the [∨/ dial down] button
◾Press OK button
05-25-2015, 07:54 AM   #12
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
If you're looking through the viewfinder and the view is dark, either mirror is up (and you will not see anything) or the aperture of the lens is closed (it should be open till the moment the photo is taken).

The result of the latter will be (as you are experiencing)
1) difficulty focusing as not enough light is available for the AF detection.
2) overexposed photos because the camera has calculated a shutter speed assuming that the lens will close down.

Remove the lens from the camera and look through it; you should see a circle of 1 or 2 mm in diameter.
There is a black (spring loaded) lever at the back of the lens; it should move easily and when you move it while looking through the lens, the circle should get bigger.

If the lever does not move easily or the circle does not get bigger, the lens is faulty.

If the lens 'works' properly, mount it on the camera and switch the camera on. If you now look into the lens, you should be able to recognize the bigger circle.

Please confirm the above and it can be taken from there.
05-25-2015, 08:26 AM   #13
Pentaxian
Aaron28's Avatar

Join Date: Jan 2015
Location: Huntsville, Al
Posts: 1,070
was thinking the aperture but it does not close down until the pic is taken.....left me wondering
05-25-2015, 09:08 AM   #14
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
QuoteOriginally posted by Aaron28 Quote
was thinking the aperture but it does not close down until the pic is taken.....left me wondering
But if it is closed before the picture is taken (think e.g. of a aperture lever that for some reason is not linked to the aperture), you will get the symptoms that OP has when using the viewfinder.
05-25-2015, 09:21 AM   #15
Pentaxian
Aaron28's Avatar

Join Date: Jan 2015
Location: Huntsville, Al
Posts: 1,070
yes.....wasn't sure
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k-s1, pentax help, photography, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fun with the K-S1 mtngal Pentax K-S1 & K-S2 279 10-13-2017 10:36 AM
Why A K-S1 Instead Of The K-50 / K-30? I'm A Pentaxian Pentax K-S1 & K-S2 71 12-24-2015 03:50 AM
K-S1 impressions (from a K-01 owner) JPT Pentax K-01 29 11-01-2014 04:35 AM
Q-S1 and K-S1 New Naming? LaurenOE General Photography 8 08-21-2014 09:36 PM
Vivitar S1 70-210mm (v3) help with aperture... c5k0 Pentax SLR Lens Discussion 2 01-29-2011 04:47 AM



All times are GMT -7. The time now is 01:46 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top