Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-24-2015, 05:19 PM   #1
Pentaxian
flaviopetrone's Avatar

Join Date: Aug 2014
Location: Reggio Emilia
Photos: Albums
Posts: 1,146
K-50 shutter stuck.

My K-50 is almost one year old and shutter count is 5200 more or less.
Yesterday I used it and everything was fine as always. Today, after a couple of shots, it started suddenly to take completely black pics.
If I use viewfinder, it takes few pictures well exposed but then starts (randomly) to take underexposed pics. Some of them are just completely black. I was thinking that the problem was the mirror, but I noticed that if I switch to live view (everything is black), I remove the lens while the camera still on and still in live view, the mirror is up in the right position but the shutter is completely closed (I can't see the sensor).

I tried to remove the battery and keep it removed for some minutes, to insert a fresh battery, to clean contacts (camera and lens), to use another lens and to make a factory reset. Nothing worked.

Is there something else I can try or I must only send it in for repair? I tried to search for other users here having the same issue but I can't find anything.

My camera is in warranty for some years more, so it is not a big problem, but usually repair takes from 1 to 3 months here in Italy and I will be without a camera in the while, since I don't own another body.

05-24-2015, 06:01 PM - 1 Like   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,959
QuoteOriginally posted by flaviopetrone Quote
My K-50 is almost one year old and shutter count is 5200 more or less.
Yesterday I used it and everything was fine as always. Today, after a couple of shots, it started suddenly to take completely black pics.
If I use viewfinder, it takes few pictures well exposed but then starts (randomly) to take underexposed pics. Some of them are just completely black. I was thinking that the problem was the mirror, but I noticed that if I switch to live view (everything is black), I remove the lens while the camera still on and still in live view, the mirror is up in the right position but the shutter is completely closed (I can't see the sensor).

I tried to remove the battery and keep it removed for some minutes, to insert a fresh battery, to clean contacts (camera and lens), to use another lens and to make a factory reset. Nothing worked.

Is there something else I can try or I must only send it in for repair? I tried to search for other users here having the same issue but I can't find anything.

My camera is in warranty for some years more, so it is not a big problem, but usually repair takes from 1 to 3 months here in Italy and I will be without a camera in the while, since I don't own another body.
If the mirror won't come down after you power cycle the camera and try to go in and out of live view, a repair will most likely be needed. It's good that you're still covered under warranty! With the dropping prices of the K-50 perhaps you could pick up a new one then sell your old one once it gets fixed?

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

05-24-2015, 06:08 PM   #3
Pentaxian
esrandall's Avatar

Join Date: Feb 2014
Location: Sumner, WA
Photos: Albums
Posts: 964
Same thing happened to my K-50 just before the one year mark. Faulty diaphragm assembly. Precision replaced it, gave the camera a tune-up, has been fine ever since. I had 13k for shots on mine, and have taken about 2k since, without issue. Adam's idea is a good one IMO, if you can secure that nice reduced price on a new one.
05-24-2015, 06:18 PM   #4
Pentaxian
flaviopetrone's Avatar

Join Date: Aug 2014
Location: Reggio Emilia
Photos: Albums
Posts: 1,146
Original Poster
QuoteOriginally posted by Adam Quote
If the mirror won't come down after you power cycle the camera and try to go in and out of live view, a repair will most likely be needed. It's good that you're still covered under warranty! With the dropping prices of the K-50 perhaps you could pick up a new one then sell your old one once it gets fixed?
Tomorrow I will go to bring it back to the shop where I bought it for sending it to repair.
Yes, the warranty on italian Pentax is 4 years (extended by the official importer), but they are much more expensive than in the USA. In this moment, K-50 body only costs 529 euro (italian version with 4 years warranty) or 450 euro (European version, with 2 years warranty, but if any problems I would need to ship it in France for warranty, that's expensive).
At the moment I can't afford it, so I will have to wait.
Anyway, thank you!

---------- Post added 05-24-15 at 06:19 PM ----------

QuoteOriginally posted by esrandall Quote
Same thing happened to my K-50 just before the one year mark. Faulty diaphragm assembly. Precision replaced it, gave the camera a tune-up, has been fine ever since. I had 13k for shots on mine, and have taken about 2k since, without issue.
Hopefully it will happen the same with mine.
Thank you.

05-25-2015, 04:20 AM - 1 Like   #5
Pentaxian
flaviopetrone's Avatar

Join Date: Aug 2014
Location: Reggio Emilia
Photos: Albums
Posts: 1,146
Original Poster
Update: the shop took the camera and sent it to the laboratory for repair it. Estimated time to have the camera back is between 3 weeks and 3 months. Let's hope to have it back as soon as possible. Thank to all.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, camera, euro, k-50, k-50 shutter, lens, mine, mirror, moment, pentax help, photography, pics, repair, shutter, troubleshooting, version, view, warranty
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mirror stuck problem in new Pentax K-50 gurpreet_cpq Pentax K-30 & K-50 46 06-08-2016 10:19 AM
Mirror stuck problem in K-50 posible solution adriano perticone Troubleshooting and Beginner Help 9 01-13-2015 06:26 AM
K-5 with occasionally stuck shutter Designosophy Pentax K-5 20 01-30-2013 06:10 PM
K-x shutter release button stuck? Priit Visitors' Center 3 10-25-2011 01:40 AM
k-x shutter permanently stuck at about 2 seconds grinchicago Pentax DSLR Discussion 8 08-19-2011 06:27 AM



All times are GMT -7. The time now is 05:42 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top