Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-25-2015, 02:33 PM   #1
New Member




Join Date: May 2015
Posts: 2
Help with my *ist DS

So I've had my *ist DS for a couple years now, got it as a birthday present from my parents. They opted for this because my dad had a bunch of old Sears lenses from his old 35mm and gave them all to me with the camera. They all worked great. Well the other day I did the Firmware 2.02 update so I could use the new SDHC cards since that's basically all I can find out there and my 2 old cars are only 1GB and obviously don't hold much. Well now my autofocus lenses still work, but all the old manual lenses won't. You hold the button down and the av light on the top screen flashes with the 2 dashes next to it and nothing happens, but swap back to the autofocus and everythings fine. Well I have 2 cheap autofocus lenses so I'm better off with my cellphone than them, I really wanna still use my camera but am about to give up on it. I can't seem to find anything about my problem or anyone else that's had the issue, can't find the original firmware to flash back, and can't get ahold of any customer support to help me. Any help you guys can give would be greatly appreciated. I'd obviously rather be able to fix the problem and keep my camera, but if it can't be resolved then I think I'm gonna bail on this thing and go to Canon or Nikon. Please help as I really don't wanna dish out that kind of cash when I feel there shouldnt be a need. Thanks

05-25-2015, 03:00 PM   #2
Pentaxian
paulh's Avatar

Join Date: Sep 2010
Location: DFW Texas
Photos: Gallery | Albums
Posts: 13,850
When using fully manual lenses, you use M mode, set your aperture on the lens' aperture ring, then press the green button to do the stop down metering. The camera will then select the correct shutter speed. Make sure in the camera setup menu, that you select "use of aperture ring permitted". There's a sticky in the beginners lens section that explains how to use manual lenses with a Pentax DSLR.

https://www.pentaxforums.com/forums/58-troubleshooting-beginner-help/110658-u...x-dslrs-f.html

Last edited by paulh; 05-25-2015 at 03:09 PM.
05-25-2015, 03:15 PM   #3
Pentaxian




Join Date: Mar 2010
Location: Frankfurt am Main
Posts: 1,092
You may have had the correct settings prior to updating the firmware. Updating can reset some of the user settings.
Also, does the display behave different if no lens is attached? If not, the camera is not detecting any lens.

I am asking, because the camera detects an attached lens by measuring the resistance from one of the contacts in the mount to the mount itself. What happens, if these old lenses have anodized mounts depends. Somewhere on the Pentax digital timeline the behaviour has changed a bit. I don't think this would happen between two firmware versions of one and the same model. I just mention it, if no other suggestion will help.
05-25-2015, 03:32 PM   #4
Pentaxian
Aaron28's Avatar

Join Date: Jan 2015
Location: Huntsville, Al
Posts: 1,070
aperture release deal prolly got reset.....set it to allow....not sure where it would be in the c settings on the ist......it's like the last on the k-r and k-50

05-25-2015, 03:42 PM   #5
Pentaxian




Join Date: Mar 2010
Location: Frankfurt am Main
Posts: 1,092
With the *istDS, It's in the third (of four) tables of "custom settings", and called "Using aperture ring".
Set it to "permitted".
05-25-2015, 03:47 PM   #6
Pentaxian
Aaron28's Avatar

Join Date: Jan 2015
Location: Huntsville, Al
Posts: 1,070
thanks fer fixin my slang!
05-25-2015, 03:49 PM   #7
New Member




Join Date: May 2015
Posts: 2
Original Poster
Hey thanks a ton, good to go..glad it was simple..weird that i never had to have the ap ring setting set before so didnt have a clue..good deal
05-25-2015, 04:21 PM   #8
Pentaxian




Join Date: Mar 2010
Location: Frankfurt am Main
Posts: 1,092
Anyone on this forum is always glad if he can help.

By the way, you can leave the setting on "permitted" all the time. It does not do any harm.
It is a mistery why Pentax sets "prohibited" as default.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
*ist, autofocus, camera, ds, firmware, help, lenses, pentax help, photography, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
*Ist DL/DS: Self timer with Auto bracket? creray Troubleshooting and Beginner Help 4 09-12-2014 06:13 AM
Problem with *ist DS redsfan73 Troubleshooting and Beginner Help 4 03-12-2014 02:13 PM
Pentax ist ds problem with shooting denise60 Troubleshooting and Beginner Help 3 01-02-2014 07:55 PM
Can I use F, FA and FA J lenses on my *ist D/*ist DS? Ole Pentax DSLR and Camera Articles 4 03-16-2008 01:10 PM
Can I use smc Pentax-A lenses on my *ist D/*ist DS? Ole Pentax DSLR and Camera Articles 3 05-18-2007 10:23 PM



All times are GMT -7. The time now is 03:06 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top