Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-27-2015, 02:01 AM   #1
New Member




Join Date: Feb 2015
Posts: 1
Exif data doesn't report manual flash information

Hi there,

I have recently bought a non P-TTL manual focus (Yongnuo YN560 mark II) which works really nice but to my surprise, either if it fires or not (the flash is physically connected through an extension cord to the hot-shoe on top of the camera body), the exif data always reports that it "did not fire".

Is this a normal? Does it happen even with P-TTL focuses?

The camera is a Pentax K-50 firmware 1.00.

Kind regards,

Arnion.

05-27-2015, 05:38 AM   #2
Pentaxian
Oldbayrunner's Avatar

Join Date: Mar 2013
Location: Havre de Grace, MD
Posts: 1,221
A manual flash only uses the power part of the hot shoe so no information is exchanged.
05-27-2015, 04:23 PM - 1 Like   #3
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,234
QuoteOriginally posted by arnion Quote
Is this a normal? Does it happen even with P-TTL...
Good question. To be honest, I have never used the exif for that purpose. I pulled out my AF 280 T (has no digital data pin) and my Sigma AF-610 DG Super (has digital data pin) and actually did the test. As Oldbayrunner commented above, most manual flash units lack the data pin that allows confirmation that the flash actually fired. The results of my short test are:
  • On-board flash off: exif = off, did not fire
  • On-board flash on P-TTL: exif = on, fired
  • On-board flash on, manual = on, fired
  • Sigma flash off: exif = off, did not fire
  • Sigma flash on, P-TTL = on, fired
  • Sigma flash on, M = on, fired
  • AF280T off = off, did not fire
  • AF280T auto-thyristor = on, fired
  • AF280T M = off, did not fire
Hmmmmmm...that next to last bullet looks a bit out of place. The AF280T lacks a digital data contact, but the exif recorded the flash correctly. What is more, it only did so in one of its automated modes. The answer lies with the history of Pentax flash automation. There was an earlier, analog flash automation protocol that that worked with the three contacts present on the AF280T and similar flashes. That earlier protocol provided confirmation for successful automated flash. Current Pentax dSLRs provide partial support for the analog protocol and are able to read the flash confirmation signal.

Summary:
  • The hot shoe is always "hot"
  • Flash confirmation requires a flash that supports that feature through either digital (four contacts) or analog (three contacts) protocol
  • Exif record of flash state is limited to flashes capable of confirmation


Steve
06-12-2015, 03:55 PM   #4
Pentaxian
mcgregni's Avatar

Join Date: Sep 2012
Location: Surrey, England
Posts: 1,509
A very good and logical summary, and thanks for the test data Steve. Presumably in manual mode the confirmation of correct exposure signal is not sent, since manual is not performing any reflectance measurements.

06-12-2015, 09:27 PM   #5
Pentaxian
Paleo Pete's Avatar

Join Date: Jun 2010
Location: Texas
Photos: Gallery | Albums
Posts: 2,872
As far as I can tell that's right, mine doesn't show either, I've always thought it would be because it's not a TTL and can't communicate with the camera.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, data, data doesn't report, did not fire, exif, exif data, external flash, flash, k-50, p-ttl, pentax help, photography, report manual flash, troubleshooting, yongnuo
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
O-GPS1 and your EXIF data - When the GPS is on, it strips data from the EXIF? Sagitta Troubleshooting and Beginner Help 17 11-23-2016 02:25 AM
K3 doesn't report lenses in EXIF RobG Pentax K-3 17 12-06-2014 12:04 PM
EXIF data won't display in DCU4 sholtzma Pentax K-5 6 08-14-2014 10:45 AM
Bower 85mm f1.4 doesn't report focal length ChopperCharles Pentax SLR Lens Discussion 3 06-13-2013 05:09 PM
Manual Lens EXIF Information interested_observer Pentax SLR Lens Discussion 15 01-05-2013 03:08 AM



All times are GMT -7. The time now is 04:25 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top