Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-02-2015, 08:51 AM   #1
New Member




Join Date: Jun 2015
Posts: 4
Pentax K10D Display and rear panel stopped working

Hi all

I am a newbie to the forum, so bear with me if I am not in the correct place to ask for help?

I have picked up a Pentax K10D body from ebay, thinking it might be a simple thing to fix. Its screen does not show any display and also none of the rear panel buttons function when Camera is powered with a newly fully charged battery?

Top plate only shows the battery icon and nothing else. Connecting this body with 18-55 AF lens appears fine, but no display. The shutter fires, the AF works fine, but nothing is getting recorded on the SD card?

I have opened the rear panel and cleaned the contacts, still no joy.........Any thoughts how to fix this issue? Has anyone had similar problem?

Amar

06-05-2015, 07:25 AM   #2
csa
Loyal Site Supporter
csa's Avatar

Join Date: Aug 2014
Location: Montana mountains
Posts: 8,172
Perhaps try another battery? The battery itself might be faulty.
06-05-2015, 08:15 AM   #3
Pentaxian
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 3,895
You can download a version of the K10D service manual from here. The comment says "not extremely useful, but interesting"

Downloads
06-06-2015, 08:16 AM   #4
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,167
QuoteOriginally posted by amarverma Quote
I have picked up a Pentax K10D body from ebay, thinking it might be a simple thing to fix. Its screen does not show any display and also none of the rear panel buttons function when Camera is powered with a newly fully charged battery?
<grimace> Good luck. Dead fully electronic cameras typically stay dead. At least that is the case without expert help and a supply of factory parts ($$). If you have a parts camera and knowledge of the camera innards you might have success, but it will not be simple. Sorry.


Steve

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, battery, body, camera, display, k10d, panel, pentax, pentax help, pentax k10d display, photography, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K3 Display panel brightness Edchristenson Pentax K-3 5 02-07-2014 10:43 PM
Panic! my pentax stopped working Austeja Visitors' Center 2 10-08-2013 05:47 AM
K-5 rear display stopped working nbu Troubleshooting and Beginner Help 10 04-07-2013 02:24 AM
Permanent ISO display on LCD-panel w/ K10D ? Peter_CH Pentax DSLR Discussion 4 04-22-2008 09:38 AM
K10 rear e-dial stopped working ryan s Pentax DSLR Discussion 5 03-10-2008 03:37 PM



All times are GMT -7. The time now is 05:56 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top