Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-12-2015, 03:38 AM   #1
Forum Member




Join Date: Apr 2012
Photos: Gallery
Posts: 93
Pentax Flucard - Slows Down General Operations of K-3?

Hi All,

My general observation after having used the Pentax FLUcard for awhile, is that it slows down and makes the K-3 lag in various ways:-

(1) After startup, it takes a while to preview a picture (i.e. pressing the PLAY button) and there is a wait of some considerable seconds;
(2) tends to be slow or lags when you're moving from menu-to-menu (occasionally);
(3) Even shutting off the camera (sometimes) it tends to lag before it completely shuts off (for a moment there I thought the K-3 'hanged').

Having said that, my usual shooting style is take some shots and then turn the camera off. Then turn it on again when I need the camera.

Are other FLUcard users experiencing this too? Is there a way to eliminate or lessen this effect?

06-12-2015, 05:08 AM   #2
Veteran Member




Join Date: May 2014
Location: Maryland
Photos: Gallery
Posts: 760
I bave been using the card for close to a year now, and no issues that you state other than start up being slow while it searches/activates the signal. I keep my camera on for that reason until I pack it up. if it is a big issues, you can move it to the other card slot so it won't activate the wifi if you dont need it at that time. I havent had any other issues of lagging that I have noticed.
06-12-2015, 01:12 PM   #3
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,957
QuoteOriginally posted by GSiGuy Quote
Hi All,

My general observation after having used the Pentax FLUcard for awhile, is that it slows down and makes the K-3 lag in various ways:-

(1) After startup, it takes a while to preview a picture (i.e. pressing the PLAY button) and there is a wait of some considerable seconds;
(2) tends to be slow or lags when you're moving from menu-to-menu (occasionally);
(3) Even shutting off the camera (sometimes) it tends to lag before it completely shuts off (for a moment there I thought the K-3 'hanged').

Having said that, my usual shooting style is take some shots and then turn the camera off. Then turn it on again when I need the camera.

Are other FLUcard users experiencing this too? Is there a way to eliminate or lessen this effect?
Apart from taking longer to save files I don't think it should slow the camera down...

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

06-13-2015, 03:09 AM   #4
Forum Member




Join Date: Apr 2012
Photos: Gallery
Posts: 93
Original Poster
Yes, i searched through a fair bit of the forum on flucard problems and I haven't seen this happen. Which is why I asked and am a little perplexed.

I am wondering now if it's really a flucard problem (always used in slot 2 with a Class 10 Extreme Pro SD Card to record RAW stills in slot 1), or am I facing other problems with the camera...

06-15-2015, 05:46 PM   #5
Junior Member




Join Date: Feb 2014
Posts: 47
The camera may be busy to initialize Flucard in Slot-2 for a few seconds when it powers up. You are prevented to play photos of Flucard for the period. You may be still allowed to play photos of a card in Slot-1. If you turn Flucard off, it may not happen.
06-15-2015, 07:59 PM   #6
Forum Member




Join Date: Apr 2012
Photos: Gallery
Posts: 93
Original Poster
QuoteOriginally posted by K-3-lover Quote
The camera may be busy to initialize Flucard in Slot-2 for a few seconds when it powers up. You are prevented to play photos of Flucard for the period. You may be still allowed to play photos of a card in Slot-1. If you turn Flucard off, it may not happen.
Yes, I expected that and realize that's probably how it works. Funny part is it actually slows down shutting off and navigating from menu-to-menu (occasionally).
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, flucard, k-3, pentax, pentax flucard, pentax help, photography, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
FLUCARD PRO for Pentax K-3 Setup and How To Guide Deedee Pentax K-3 25 08-24-2015 05:37 AM
First impression of FLUcard on K-3 JPT Pentax K-3 74 07-30-2014 06:59 AM
FluCard Pro for Pentax K-3 BEEPS Gemvision Pentax K-3 4 03-15-2014 03:20 PM
Q10 firmware update slows down readiness to shoot hydrogencarbonat Pentax Q 7 08-10-2013 05:54 PM
FPS slows down during AFC opiedog Pentax DSLR Discussion 28 06-22-2010 07:52 PM



All times are GMT -7. The time now is 05:26 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top