Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-19-2015, 08:14 AM   #1
New Member




Join Date: Jun 2015
Posts: 4
K3 and elinchrom skyport

Hey guys,

I'm having trouble triggering my elinchrom d-lite 4's using my skyport while attached to my k3. When I hit the test button on the skyport it works fine, but it doesn't seem the camera is 'talking' to the skyport. I cant find anyone that's had the same problem on forums etc.

The last camera I used with these lights was a Nikon d90 and it fine, worked straight away. I've tried changing the flash settings on the camera, switching to the wireless mode but I still can't seem to sync it.

Any ideas would be much appreciated. Cheers.

06-19-2015, 09:49 AM   #2
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,479
QuoteOriginally posted by Delahaye303 Quote
I've tried changing the flash settings on the camera, switching to the wireless mode but I still can't seem to sync it.
Welcome to the Pentax Forums!

It is not clear from your question what you are trying to do. I can provide you with a few bullet points that may help:
  • The flash settings on the camera are for the on-board flash
  • Your strobes sync using RF wireless
  • Your camera does not have a built-in transmitter for RF wireless
  • You must use a elinchrome-compatible RF wireless (accessory) transmitter to trigger sync from your camera
  • Your camera will support either a hot-shoe mounted transmitter or one that attaches via a PC cable
  • To the best of my knowledge, you will not be able to control your strobe's output using the camera's P-TTL system
You might want to contact elinchrome support to see what they might suggest.


Steve
06-19-2015, 10:46 AM   #3
New Member




Join Date: Jun 2015
Posts: 4
Original Poster
QuoteOriginally posted by stevebrot Quote
Welcome to the Pentax Forums!

It is not clear from your question what you are trying to do. I can provide you with a few bullet points that may help:
  • The flash settings on the camera are for the on-board flash
  • Your strobes sync using RF wireless
  • Your camera does not have a built-in transmitter for RF wireless
  • You must use a elinchrome-compatible RF wireless (accessory) transmitter to trigger sync from your camera
  • Your camera will support either a hot-shoe mounted transmitter or one that attaches via a PC cable
  • To the best of my knowledge, you will not be able to control your strobe's output using the camera's P-TTL system
You might want to contact elinchrome support to see what they might suggest.


Steve
Cheers for the reply. I am using the elinchrom radio trigger trigger - Skyport. The problem is that that it's triggering the flash when I fire a shot while attached to the hot shoe. But it does when I hit the test button on the skyport.
06-19-2015, 12:07 PM   #4
Junior Member




Join Date: Mar 2010
Location: Kamloops B.C.
Photos: Gallery | Albums
Posts: 26
Make sure that you're not trying to shoot with a shutter speed that is faster than Pentax's sync speed, as your flash guns will not fire then. Also, I have an inexpensive radio flash trigger set that i use on my K20D and if my battery isn't fully charged then it doesn't trigger the controller and my flash guns don't fire.
Hope that helps!

06-19-2015, 01:01 PM   #5
Veteran Member
fwbigd's Avatar

Join Date: Jun 2007
Location: Fort Worth TX
Posts: 313
After reading the original post I decided to test the system on my K3 and K3ii and got the same result as the original poster. I have used the Skyport with the Elinchrom dLite 2it and BX500RXi flashes with very inconstant results on the K5ii and K3 before, but never to the extent that the Skyport would not fire the flashes. Tried changing the battery with the same results. Pulled out my Nikon D600 and bingo the flashes fired constantly. After trying the Nikon, I remounted the Skyport on the K3 and it began firing with a pause of 2 to 3 seconds between shots. The position of the antenna seem to affect the constancy of the strobes firing with the K-3 over the D600. Same was true with the K3ii.
06-19-2015, 04:08 PM   #6
Pentaxian
amoringello's Avatar

Join Date: May 2008
Location: Virginia, USA
Photos: Gallery
Posts: 1,430
I has the Skyport years ago. Nothing but trouble.
Even when it did work, the sky port is slow and with the shutter speed above 1/125s I would often get black band showing from the shutter. (advertised to work up to 1/1000 with mechanical shutter) Argued with Elinchrom for six months about the problem... they finally admitted they are not fast enough and have since changed their marketing specs.

I had a long period where Skyport would simply not work at all. Sent the camera in for repair. They found nothing... yeah there was nothing wrong with the camera.

Finally sold the units and now use another brand. Never had another issue since.
06-20-2015, 06:19 AM   #7
New Member




Join Date: Jun 2015
Posts: 4
Original Poster
brilliant, shutter speed was the culprit. I was shooting on 200, which didn't seem excessive to me. Dropped down to 125 and they're now working. I've ordered a sync cable, do you think that will allow me to shoot at faster shutter speeds?
06-20-2015, 06:35 AM   #8
Pentaxian
amoringello's Avatar

Join Date: May 2008
Location: Virginia, USA
Photos: Gallery
Posts: 1,430
QuoteOriginally posted by Delahaye303 Quote
brilliant, shutter speed was the culprit. I was shooting on 200, which didn't seem excessive to me. Dropped down to 125 and they're now working. I've ordered a sync cable, do you think that will allow me to shoot at faster shutter speeds?
Yeah,sadly Pentax cripples their cameras by shutting off the flash completely if you exceed the sync-speed (1/180s) and you cannot fire any flash unless it is a PTTL-HighSpeedSync (HSS) compatible flash.

Most brands allow the photographer to use flash above the sync speed -- and it has its uses.
But Pentax thinks you'll just poke your eye out with that, kid.

06-20-2015, 11:15 AM   #9
New Member




Join Date: Jun 2015
Posts: 4
Original Poster
Thanks Pentax! lol

So if i buy the Sigma EF 610 DG i'll have the same issues obviously?
06-21-2015, 06:31 AM   #10
Junior Member




Join Date: Mar 2010
Location: Kamloops B.C.
Photos: Gallery | Albums
Posts: 26
QuoteOriginally posted by Delahaye303 Quote
Thanks Pentax! lol

So if i buy the Sigma EF 610 DG i'll have the same issues obviously?
If you want to use them off camera with radio triggers, yes. I have 2 610 supers and while they do have HSS it's only available in pttl mode and I'm not sure if any wireless trigger brands out there support Pentax ttl, so you're forced to switch the flash to manual and lose the HSS capabilities. Flash is not a forte of Pentax unless you spend a lot of money, glad I don't need it that often as I'm usually shooting landscape stuff.

---------- Post added 06-21-2015 at 06:34 AM ----------

QuoteOriginally posted by aitrus3 Quote
If you want to use them off camera with radio triggers, yes. I have 2 610 supers and while they do have HSS it's only available in pttl mode and I'm not sure if any wireless trigger brands out there support Pentax ttl, so you're forced to switch the flash to manual and lose the HSS capabilities. Flash is not a forte of Pentax unless you spend a lot of money, glad I don't need it that often as I'm usually shooting landscape stuff.
Oh if you use a tethering cord with the 610 super you'll be able to use hss though. You're limited only when you want to go wireless
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, capabilities, elinchrom, flash, hss, k3, k3 and elinchrom, landscape, lot, money, pentax, pentax help, photography, skyport, stuff, switch, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Elinchrom Flash Triggering system: Review and info Wired Flashes, Lighting, and Studio 7 09-04-2015 01:05 AM
Elinchrom Are Selling for 50% OFF Winder Flashes, Lighting, and Studio 2 05-11-2015 03:54 PM
strobes...need to replace my Elinchrom. Wired Flashes, Lighting, and Studio 6 03-09-2015 09:46 AM
Elinchrom Skyport system triggering flash late!!! Help! pkremer Flashes, Lighting, and Studio 15 07-07-2010 03:47 PM
AF-540FGZ + Elinchrom EL-Skyport Spag Pentax Camera and Field Accessories 4 07-24-2009 05:27 AM



All times are GMT -7. The time now is 03:14 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top