Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-28-2015, 04:14 AM   #1
New Member




Join Date: Feb 2008
Location: U.K.
Posts: 5
K-r problem with flash not working

I very rarely use flash, but last week, when the built-in flash popped up, the screen registered this only for a fraction of a second then showed normal exposure. Flash would fire but TTL metering ineffective.
When using my Metz external flash, the TTL metering was also ineffective.

Today, the flash will not fire at all. Is there an easy fix, or will it need an expensive visit to a professional repair shop?

06-28-2015, 07:25 AM   #2
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
Which lens are you using? Which exposure mode (Av, M, ...)?

Not sure if I can help further, but this information might be relevant.
06-29-2015, 07:52 AM   #3
New Member




Join Date: Feb 2008
Location: U.K.
Posts: 5
Original Poster
I've used the kit lens and also a Tamron tele zoom. Fixed flash does nothing. However, external Metz flash is now working fine when attached to camera body. Will try it off camera later.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, fire, flash, pentax help, photography, troubleshooting, ttl
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
AF360FGZ slave flash not working with Q7 shaolen Flashes, Lighting, and Studio 11 09-27-2014 12:58 PM
K-r: built-in flash stopped working after using external flash wedge Troubleshooting and Beginner Help 7 01-12-2014 07:57 PM
k-r built in flash not working and k-r starting to be slow mikol Welcomes and Introductions 3 01-05-2014 09:32 AM
K-r problem with flash Darlene Pentax K-r 8 01-25-2013 07:35 PM
K-r will not take photos, shutter button not working - HELP! seattledotcom Troubleshooting and Beginner Help 8 06-08-2011 04:19 PM



All times are GMT -7. The time now is 01:20 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top