Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-15-2015, 01:30 PM   #1
New Member




Join Date: Jan 2014
Location: Victoria, BC
Posts: 23
K10D shutter release

Hi! I'm sorry if this topic has been asked elsewhere but I'm running around like crazy right now and I want to know if there's a solution or it's something I have to live with:

the time from shutter release full depression to the shutter actually going off seems to be abnormally long. Coming from a *ist (I know, HUUUGE upgrade :P) I'm used to the near instant release as soon as the button is fully depressed. Is this normal? Is it a firmware thing? I've been through all the menus and can't seem to find anything obvious to change it. It only seems to do it in AF mode, but it's got a good focus, it just delays the shutter. Manual, fires right away no problem.

TBH I'm not even sure what firmware is on there -- I just got it but other life things take priority over messing around with a new camera, as fun as that is. =P

That being said, I've taken a couple test pictures really quick and holy crap am I ever glad I picked this camera up before I leave the country in two days =D It's gonna be a good trip!

Again, sorry if it's been asked but I just found out I'm leaving Friday so I'm all waaaaaahhh all the things!

07-15-2015, 02:55 PM   #2
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,432
It has been over a year since mine found a new home, but my memory of the K10D is that the shutter latency was very short and general response snappy. I took just took a short tour of online reviews from 2007 and did not find any particular comments regarding laggard shutter response. Imaging Resource recorded a 0.107s when the subject is pre-focused (AF-S) and 0.181s in manual focus mode which they judged to be average with above average overall responsiveness. These numbers are similar to those from the *ist D (0.13s/0.18s).

If your K10D is significantly slower than your *ist, it is hard to say what the cause might be.


Steve
07-15-2015, 03:18 PM   #3
Site Supporter




Join Date: Dec 2012
Location: Pekin, IL
Posts: 237
Are you using AF? Are you certain the focus has locked before you finish depressing? I've got a K200D, and whenever I found it wasn't shooting fast enough, it was usually because it hadn't locked on focus. You can change that with a custom menu option.
07-15-2015, 05:45 PM   #4
Pentaxian
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 4,261
If never experienced any significant delay between the full shutter button push and my K10D taking the exposure. Unless of course I have the 2 sec mirror lockup delay enabled.

The shutter will not fire in AF-S mode unless focus lock/confirmation is achieved but then the OP is saying "focus is good". So I'm stumped also unless there is some fault in the camera. Have you tried resetting the options to the factory defaults? What firmware version is the camera running under?

07-15-2015, 08:52 PM   #5
YQG
New Member




Join Date: Jan 2014
Location: Victoria, BC
Posts: 23
Original Poster
Correct, focus was good -- focus lights blink and I get the chirp. However, I upgraded the firmware from 1.30 to 1.31 and it seems to have cut the delay significantly. Either that or I've discovered I need to be really firm on the button. =) Regardless, whether it's firmware or just being unfamiliar with the quirks of a new camera, it seems to be resolved. Thanks for the replies everyone. =)
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, camera, firmware, k10d, k10d shutter, pentax help, photography, release, shutter, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shutter Release Problem tjohns024 Troubleshooting and Beginner Help 2 12-21-2013 12:11 PM
K10D solution for shutter release Darius4522 Pentax DSLR Discussion 9 09-02-2010 02:12 AM
Best Shutter Release for K10D? Hannican Pentax Camera and Field Accessories 6 05-25-2010 11:42 AM
K10D shutter release button not working well . Any ideas lesmore49 Pentax DSLR Discussion 6 07-19-2009 10:48 PM
K10D shutter release jnorth Pentax DSLR Discussion 3 01-17-2007 11:45 PM



All times are GMT -7. The time now is 04:04 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top