Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-06-2015, 10:20 AM   #1
Loyal Site Supporter
Mikesul's Avatar

Join Date: Sep 2009
Location: Phoenix, AZ
Posts: 2,620
AF-540FGZII Misfires

I have been having problems with the Flash often not firing, even with fresh batteries and waiting over a minute between attempts. Precision returned it with a note that they had done a complete repair of contacts and returned to factory specs. Same problem. However, I discovered this morning that if I do not tighten the "Fix" lever the flash fires properly almost every time. It fits fairly tightly in the shoe even with the lever is open. This is clearly not an acceptable solution and there are still occasional misfires. Does anyone have experience with this issue? I have had the same results with the K-3, K-3ii and K-01.

08-06-2015, 11:23 AM   #2
Pentaxian
mcgregni's Avatar

Join Date: Sep 2012
Location: Surrey, England
Posts: 1,746
Do you mean that you have to leave the Fix lever completely loose, or that it is over enough to hold but just not tightened?
08-06-2015, 11:34 AM   #3
Pentaxian




Join Date: Sep 2011
Location: Nelson B.C.
Posts: 3,247
QuoteOriginally posted by Mikesul Quote
I have been having problems with the Flash often not firing, even with fresh batteries and waiting over a minute between attempts. Precision returned it with a note that they had done a complete repair of contacts and returned to factory specs. Same problem. However, I discovered this morning that if I do not tighten the "Fix" lever the flash fires properly almost every time. It fits fairly tightly in the shoe even with the lever is open. This is clearly not an acceptable solution and there are still occasional misfires. Does anyone have experience with this issue? I have had the same results with the K-3, K-3ii and K-01.
The 'Fix' lever pushes a rubber mat down to seal and fix it in the hotshoe. Maybe it is deflecting one of the pins or one of the pins is getting pulled away from contact.
08-06-2015, 11:40 AM   #4
Loyal Site Supporter
Mikesul's Avatar

Join Date: Sep 2009
Location: Phoenix, AZ
Posts: 2,620
Original Poster
QuoteOriginally posted by derekkite Quote
The 'Fix' lever pushes a rubber mat down to seal and fix it in the hotshoe. Maybe it is deflecting one of the pins or one of the pins is getting pulled away from contact.
Yes, that is what I have been thinking but I can't figure out how to test. I thought about putting some color on the pins to see if they do not make contact but that seems a bit risky. Thanks for the input.

---------- Post added 08-06-15 at 12:20 PM ----------

It continues to be very random whether the fix is set or not. One thing I have not mentioned is that the ready light is almost always on. Sometimes it goes off after a shot but most of the time is either stays on or is on again immediately. That does not mean that the flash is ready to fire. Just to be sure I put my old Af 360FGZ on the camera and it fires with complete reliability as long as the ready light is lit which occurs quickly after each shot.

08-06-2015, 04:01 PM   #5
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,134
Three words:

*****************************

Send

It

Back

****************************

Alternatively, contact Ricoh requesting they replace rather than repair.

Steve
08-06-2015, 05:48 PM   #6
Loyal Site Supporter
Mikesul's Avatar

Join Date: Sep 2009
Location: Phoenix, AZ
Posts: 2,620
Original Poster
Stevebrot,

Yes you are right but I did that once without success. I was hoping there might be something I could do short of that. I think I will contact Ricoh first.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, contact, fix, flash, lever, light, pentax help, photography, pins, shot, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cactus V6 misfires on Pentax ME nono Flashes, Lighting, and Studio 12 01-03-2015 03:25 PM
Pentax K-x: focus confirmation in AF-S, AF-C, not AF-A manteiv Pentax DSLR Discussion 24 12-10-2010 07:25 PM
For Sale - Sold: Tamron-F AF Tele-Converters (1.4x Pz-AF MC4, 2X Pz-AF BBAR MC7) dgaies Sold Items 2 11-02-2010 08:22 AM
Trigger voltages of AF 540FGZ, AF 360FGZ and AF 200FG ??? GerryL Pentax Camera and Field Accessories 26 07-12-2009 05:58 AM



All times are GMT -7. The time now is 03:36 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top