Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-29-2015, 03:58 PM   #1
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 9,555
CPC 2x KR shows F--, grounding?

I got a cheap 2x tele on eBay intending to make a smart extension tube. It appears to have the right contacts. But when mounted to my camera and lens I get F--, which sucks.

It was advertised as KA but while similar to this one: CPC 2X it is labeled "MC KR" not "MC-4 PKA".

It arrived with bent aperture actuator ( easy fix ) and contacts look good and in the right place. However it has a black painted mount - so I'm suspecting grounding failure. How can I easily check that?

08-29-2015, 04:09 PM   #2
Pentaxian
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 3,901
The "R" would indicate it is for a Ricoh camera. I'm not sure about the pin comparability between Ricoh and Pentax "A". Does the "A" pin protrude more than the other pins? Otherwise try a bit of metal foil over the data pin on the camera mount side.
08-29-2015, 06:12 PM   #3
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 9,555
Original Poster
QuoteOriginally posted by Not a Number Quote
The "R" would indicate it is for a Ricoh camera. I'm not sure about the pin comparability between Ricoh and Pentax "A". Does the "A" pin protrude more than the other pins? Otherwise try a bit of metal foil over the data pin on the camera mount side.
Which one is the data pin? I can't recall - I guess I will go look it up. There is no Ricoh "pin" on the converter. I'm not sure what the Ricoh pin out is from that era.

---------- Post added 08-29-15 at 09:50 PM ----------

Pictures

Above my fingernail is what I think is the Ricoh Pin. It is very sloped and easy to push in and caused no problem on my K3 today. Notice also that the 3th pin from the left? is the highest.


Last edited by UncleVanya; 08-29-2015 at 06:51 PM.
08-29-2015, 08:02 PM   #4
Pentaxian
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 3,901
The data pin would be the 7th pin going clockwise on your second picture.

It looks like the "A" pins are recessed and protruding as they should. Try cleaning the contacts. If you have a multi-meter or continuity checker test each pin to see if they are conducting. Could be dirty or the springs on the pins are unseated so no electrical continuity. The pins look clean in the photo but a slight film of oil or grease could block the signal.

The TC has a Ricoh pin but it is well rounded so should cause no problems. I've never had a problem with my Vivitar 2x Macro focusing TC which also has a similar Ricoh pin.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
2x, camera, contacts, cpc, data, f--, pentax help, photography, pin, ricoh, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Charger shows 100%. Camera shows less. MJSfoto1956 Pentax K-3 4 02-17-2014 12:53 PM
For Sale - Sold: SP Tamron-F 2x KR BBAR MC7 (Worldwide) Jewelltrail Sold Items 5 04-05-2011 10:04 AM
Grounding Chris Pentax DSLR Discussion 7 06-14-2008 06:31 PM



All times are GMT -7. The time now is 02:34 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top