Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-15-2015, 01:14 PM   #1
Veteran Member




Join Date: Aug 2011
Location: Niagara
Photos: Gallery | Albums
Posts: 791
Pentax SF-10 not advancing film

Hi, folks! Having a problem with my SF-10 that is starting to cost money. I have a 36 roll of Ektar in it and have been using it without problems until the frame read 33. It then stops working except to just flash 33 in the lcd screen. I purchased a new battery ($17.99 Cdn), placed the new battery into it, it a started to advance the frame and then stopped. Same thing is happening now, stuck on a flashing 33. ould it just be as simple as the camera cannot handle a 36 roll? If the camera is kaput, can I get the film out without power and without exposing it?


Thanks

10-15-2015, 02:48 PM   #2
Site Supporter
gofour3's Avatar

Join Date: Oct 2008
Location: Vancouver, Canada
Posts: 5,115
Is the "end of film" symbol on the screen?

Phil.
10-15-2015, 02:55 PM   #3
Veteran Member




Join Date: Aug 2011
Location: Niagara
Photos: Gallery | Albums
Posts: 791
Original Poster
QuoteOriginally posted by gofour3 Quote
Is the "end of film" symbol on the screen?

Phil.
there is a top view of the camera with symbols for each spool and a flashing dashed line from one spool to the other, and of course the number 33 flashing as well

---------- Post added 10-15-15 at 05:56 PM ----------

QuoteOriginally posted by Franky2step Quote
there is a top view of the camera with symbols for each spool and a flashing dashed line from one spool to the other, and of course the number 33 flashing as well
the camera will not turn on or allow any other adjustments. If I remove the battery and then reinsert it, the lcd shows the normal "program mode" etc, and if I try to focus it tries to wind the film(whirs) and then stops, resulting in the flashing 33 again.

Last edited by Franky2step; 10-15-2015 at 03:01 PM. Reason: more info
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, camera, course, film, frame, line, pentax help, pentax sf-10, photography, roll, sf-10, spool, symbols, troubleshooting, view
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax SF-10/SF-7 won't read film VisualDarkness Troubleshooting and Beginner Help 3 05-08-2013 03:24 PM
Pentax SF-1 & SF-10 kiteman Pentax Film SLR Discussion 10 12-12-2012 11:12 AM
MZ-50 film advancing problem. Help! Leeumm Pentax Film SLR Discussion 15 01-04-2012 01:22 AM
film advancing problem on MZ-5n solisti Pentax Film SLR Discussion 4 03-17-2009 06:02 AM



All times are GMT -7. The time now is 06:04 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top