Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-17-2015, 12:32 PM   #1
New Member




Join Date: Oct 2015
Posts: 1
K-50 continually locks up / freezes

The K-50 I bought for my daughter a month ago has been having serious problems with all the controls locking up. It happened once the very first time I turned on the camera after unpacking it; then not again for a week or two; then it became completely unusable for several days until I spent an hour trying everything I could and it somehow recovered. Now it's broken again and my daughter is panicking because she has a photography midterm coming up and needs to shoot a lot of photos.

Symptoms are:
* Camera starts up fine
* About five seconds after turning on, the display freezes (except that any numbers that were blinking continue to blink)
* Absolutely none of the controls do anything. Even the on/off switch doesn't work.
* The only way to turn the camera off is to remove the battery and then put it back in.
* When turning the camera back on, almost always it locks up again just as above. As I said above, it spends a lot of time in this broken state, and then after a while will mysteriously recover.

A few weeks ago I updated it to the latest firmware (which was an adventure because I had only five seconds to get into the menus and maneuver to the firmware screen and press the update button, before the camera would lock up. Took me a dozen tries!) It hasn't helped.

I've seen a bunch of threads about camera lockups, but they mostly involve the K-5, they all seem to report an intermittent problem (not continuous), many of them describe the display going black not just freezing in place, and responses tend to blame old batteries (whereas my battery came brand new with the camera.) So I doubt this is the same exact problem, although of course they both sound like firmware issues.

My next step is to send the camera in for warranty repair (apparently to precisioncamera.com), but I thought I'd ask here in case anyone has a brilliant solution that I can apply myself :-)

10-17-2015, 01:53 PM   #2
Pentaxian
Aaron28's Avatar

Join Date: Jan 2015
Location: Huntsville, Al
Posts: 1,070
maybe a reset? does it do this with a particular lens or no lens at all? hate it for you....hope it gets worked out!
10-17-2015, 02:14 PM   #3
Forum Member




Join Date: Sep 2014
Location: Southwestern Ontario
Posts: 77
I've experienced similar problems with my K-50. I recommend cleaning the electrical contacts for the lens mount on both the camera and the lens. I'm an electronics technician so I have contact cleaner. If you don't, you could try using rubbing alcohol. This seems to have solved my problem in the past. Plus, I've never experienced the problem when using a manual lens (they don't have electrical contacts).
10-17-2015, 09:03 PM   #4
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,479
What you are describing is not within the scope of expected behaviors.

Your daughter's camera is still under warranty. That would be your most likely remedy. I don't want to sound preachy, but the first time it happened (within the first couple of days ownership), you should have contacted your dealer for an immediate exchange. Depending on the seller, you may still be able to do that.

But...before we do that...how is the camera powered? Are you using the lithium battery that came with it or the optional AA battery adapter? If AA, you might want to try the original battery that came with the camera (fully charged).

As for the contacts...that is a bit of a stretch, though not impossible. Does the camera lock up when no lens is mounted?


Steve

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, camera, controls, crash, daughter, display, firmware, five, freeze, k-50, lockup, lot, pentax help, photography, time, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-50 mirror freezes when shooting f/2.8 or faster esrandall Troubleshooting and Beginner Help 8 01-02-2015 11:11 PM
K5 IIs freezes up hjoseph7 Pentax K-5 4 09-01-2014 07:26 PM
k 5 freezes up marktn Troubleshooting and Beginner Help 4 04-17-2014 04:14 AM
K-30 - control wheel locks up jptreen Pentax K-30 & K-50 10 09-09-2012 09:35 PM
K-R Locks up in bulb mode on longer shots jostafew Troubleshooting and Beginner Help 3 09-08-2012 10:59 AM



All times are GMT -7. The time now is 03:22 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top