Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-20-2015, 12:41 PM   #1
Junior Member




Join Date: Jun 2015
Posts: 32
KM shutter lock: bug or feature?

Hi all,

On the KM, I noticed you can lock down the shutter button by giving it a quarter-turn when it's fully depressed. Is this a feature for B mode photos? Or is it just gummy?

EDIT: I'm actually leaning towards gummy, since I noticed the shutter button sometimes won't pop back up... is there a way to fix this?


Last edited by Whateverist; 10-20-2015 at 01:12 PM.
10-20-2015, 08:07 PM   #2
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,158
Welcome to the Pentax Forums!

First off...Do you have a K-m digital camera or a KM film camera? Shutter lock is not a feature of either camera, but how to do a fix will depend on which camera you own.


Steve
10-20-2015, 10:47 PM   #3
Junior Member




Join Date: Jun 2015
Posts: 32
Original Poster
It's a KM film camera. Everything else appears to be working normally, it's just the shutter button itself that seems to chafe sometimes.
10-20-2015, 11:43 PM   #4
Site Supporter
arnold's Avatar

Join Date: Aug 2012
Location: Queensland
Photos: Gallery | Albums
Posts: 3,193
QuoteOriginally posted by Whateverist Quote
It's a KM film camera. Everything else appears to be working normally, it's just the shutter button itself that seems to chafe sometimes.
The KX is the next model up, and has a designed button lock. Your KM must be getting stuck by friction.

10-21-2015, 12:01 AM   #5
Junior Member




Join Date: Jun 2015
Posts: 32
Original Poster
QuoteOriginally posted by arnold Quote
The KX is the next model up, and has a designed button lock. Your KM must be getting stuck by friction.
Is there a fix for this?
10-21-2015, 12:31 AM   #6
Site Supporter
arnold's Avatar

Join Date: Aug 2012
Location: Queensland
Photos: Gallery | Albums
Posts: 3,193
QuoteOriginally posted by Whateverist Quote
Is there a fix for this?
Try squirting some WD40 into small container; just enough to dip a toothpick into. Touch the toothpick against the button so an imperceptible amount flows in. Oil can damage shutter curtains or get on aperture blades or glass, so be careful with lube.
10-21-2015, 07:42 PM   #7
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,158
QuoteOriginally posted by arnold Quote
Try squirting some WD40 into small container; just enough to dip a toothpick into. Touch the toothpick against the button so an imperceptible amount flows in. Oil can damage shutter curtains or get on aperture blades or glass, so be careful with lube.
WD-40 is not a lubricant per se. It is mostly Stoddard solvent and has a tendency to migrate quickly. A camera tech would do a partial disassembly to expose the mechanism. The button should lift off with the top plate allowing you to inspect and evaluate its operation with out risk to the rest of the camera. The actual release is done with a shaft that goes through to the bottom of the camera. Removal of the bottom plate will allow you to inspect and evaluate its operation. I suspect something might be bent or out of alignment down there.


Steve
10-21-2015, 07:45 PM   #8
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,158
QuoteOriginally posted by stevebrot Quote
A camera tech would do a partial disassembly to expose the mechanism
The K1000 manual at pentax-manuals.com should be adequate. I believe the KM and K1000 share shutter mechanism.

Pentax Manuals

Alternatively, a CLA (Clean, Lube, Adjust) would likely correct the problem. The price would be in the $45-$60 range.


Steve

10-22-2015, 07:26 AM   #9
Junior Member




Join Date: Jun 2015
Posts: 32
Original Poster
I don't feel comfortable opening up the camera. I'll shoot a roll, see if the problem is bad enough to bother me, and look into a CLA - though with the price I paid for the camera, I don't know if the cost would be justified just for this issue.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, km, km shutter, pentax help, photography, release, shutter, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-x mirror lock up feature waywardmouse Troubleshooting and Beginner Help 10 05-26-2016 04:21 AM
Wireless shutter release with lock? zzeitg Pentax Camera and Field Accessories 9 02-06-2015 02:12 AM
K-5 low battery shutter lock bug VisualDarkness Pentax K-5 3 04-09-2013 03:50 AM
removing SD card: a bug or a feature ? wolferl.m Pentax K-5 22 05-13-2012 10:27 AM
AEB burst with delay. Bug or feature? vladm11 Pentax DSLR Discussion 2 08-08-2010 12:42 PM



All times are GMT -7. The time now is 08:25 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top