Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-11-2015, 02:52 PM   #1
New Member




Join Date: Nov 2015
Posts: 1
k1000 weird shutter issues

Hi everyone! This is my first post on the forum and I wish it was under better circumstances. Recently, my k1000 has been acting wonky and I can't rely on my shutter speeds being accurate. My 1 second shutter speed is more like 1/1000 of a second and my 1/2 second is a full second long. Now for the weird thing, if I advance my film first and then set the speed, the speeds work correctly. If I set the shutter speed first and then cock it, I get those erroneous speeds. This is every time. Obviously something is messed up. Is there a quick mechanical fix or do I have something that needs to be professionally fixed? If I have to put it in for repair, it's probably cheaper to buy a used k1000 online.

11-11-2015, 03:26 PM   #2
Site Supporter
mattt's Avatar

Join Date: Feb 2011
Location: Niagara
Photos: Gallery | Albums
Posts: 2,777
Any K1000 you find cheap will need tlc. A camera is a precision device. It needs service to be reliable.
11-11-2015, 03:47 PM   #3
Senior Member
kiberkli's Avatar

Join Date: Aug 2013
Location: Central Valley, California
Posts: 111
Maybe it's time to replace it with a new K-50 which may be cost competitive with the K1000 repair. Remember your K mount lenses will work.
11-11-2015, 04:17 PM   #4
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,109
QuoteOriginally posted by ces1um Quote
Now for the weird thing, if I advance my film first and then set the speed, the speeds work correctly. If I set the shutter speed first and then cock it, I get those erroneous speeds.
Sounds like something is bent or broken. Your camera is likely repairable, but the cost would likely be more than a replacement body + CLA. If you decide to go the replacement route, you might want to keep your eyes open for a KM. It is similar to the K1000, but is usually less money and has the added benefit of having a self-timer and depth of field preview.


Steve

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k1000, k1000 weird shutter, pentax, pentax help, photography, problem, shutter, shutter speed, speeds, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird shutter button delay psamoluk Pentax K-3 19 12-15-2014 08:51 AM
K-500 shutter acting weird with Pentax F 35-70 sewerynthegreat Pentax K-30 & K-50 6 06-25-2014 08:41 AM
K1000 mirror issues greek_pentaxian Troubleshooting and Beginner Help 7 04-11-2014 01:43 PM
Shutter Issues with a K1000 SE... Eric Auer Pentax Film SLR Discussion 3 09-23-2012 11:56 AM
SD card issues (weird so bare with me) skinja Pentax Camera and Field Accessories 5 02-20-2008 07:12 PM



All times are GMT -7. The time now is 02:25 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top