Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-15-2015, 02:51 PM   #1
Forum Member




Join Date: Jun 2015
Location: Melbourne
Posts: 99
Sigma 150-500mm clunking noise

I recently bought a used Sigma 150-500mm zoom. The lens works fine and the pictures are excellent.
I have 2 issues with the lens that hopefully someone will be able to answer.
1. The zoom makes a clunking noise when moving across from 400mm to 500mm. When moving back 400mm to 500mm the clunking sound audible but less. The lens has been well used and outside appearance would be best described as average.
2. With the Pentax 20D having IS, is it better to use the lens IS system or the Cameras? Any preferences?

11-15-2015, 02:57 PM   #2
Site Supporter
boriscleto's Avatar

Join Date: Dec 2009
Location: Liverpool, NY
Photos: Gallery
Posts: 12,863
Mine has no clunking sound, zoom creep started about a month after I got it.

I use the in lens OS. The stabilized image in the viewfinder is the main advantage. OS mode 2 allows panning too.
11-15-2015, 03:48 PM   #3
Loyal Site Supporter
Bruce Clark's Avatar

Join Date: Mar 2010
Location: Brookfield, Victoria
Photos: Gallery | Albums
Posts: 3,768
If you want to have this lens checked professionally, CR Kennedy is the Australian distributor for Sigma. They are based in Port Melbourne. I can highly recommend their repair service. Their website is Welcome to C.R. Kennedy | Photographic, Digital, Medical, Surveying, Surveillance, Digital Audio. CR Kennedy. Australia
11-15-2015, 05:42 PM   #4
Veteran Member
VisualDarkness's Avatar

Join Date: Nov 2011
Location: Uppsala, Sweden
Photos: Gallery
Posts: 4,441
Well, it might be that at the longer focal lenghts the IS system simply moves more to compensate for the motion and that it is what you experience.

11-15-2015, 07:22 PM   #5
Pentaxian




Join Date: Nov 2007
Location: Western Canada
Posts: 4,094
I don't have any clunking noise in my 150-500 Sigma, nor do I have lens creep....when I use the lens lock.
11-27-2015, 02:48 AM   #6
Forum Member




Join Date: Jun 2015
Location: Melbourne
Posts: 99
Original Poster
Thanks for advice from all. VisualDarkness may well be spot on. I rang Michaels Camera store and they said to try the lens with IS turned off. I did and the clunking noise was far less. I pointed the lens in a downwards direction and twisted the zoom barrel over about 3 days and the noise stopped. The lens to date seems to work without any noise at all. I also called CR Kennedy and they said it may just be a temporary mis alignment problem that would cost no more than $70 to adjust. Thanks again all.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
400mm, 500mm, camera, lens, noise, pentax help, photography, sigma, sigma 150-500mm, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sigma 150-500mm lens pentaxpal Pentax SLR Lens Discussion 7 05-22-2014 04:32 PM
For Sale - Sold: Sigma 150-500mm F5-6.3 APO DG OS HSM for PENTAX 150-500 transam879 Sold Items 3 03-24-2014 05:02 AM
Need lens hood for Sigma 170-500mm...same as 50-500mm and 150-500mm? Help please! Edgar_in_Indy Pentax SLR Lens Discussion 10 09-09-2011 05:32 AM
Sigma 150-500mm versus Sigma 50-500mm? Ubuntu_user Pentax SLR Lens Discussion 6 08-31-2011 09:35 PM
Sigma 50-500mm or sigma 150-500mm?? stormcloud Pentax SLR Lens Discussion 27 10-30-2009 05:20 AM



All times are GMT -7. The time now is 12:14 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top