Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-24-2015, 08:45 PM   #1
New Member
walstib's Avatar

Join Date: May 2012
Posts: 3
K-3 firmware version no longer displays

I finally got around to trying to update to v1.21 and noticed my K-3 will no longer display the current firmware version when I turn it on while pressing the menu button. Changed the battery - no help. Inserted the memory card with the 1.21 update on the card and still the camera does not display the firmware version or display update menu. Also used the "reset" command in the camera menu to return all settings to default. That didn't work either. Anyone familiar with this issue?

11-24-2015, 08:46 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,944
QuoteOriginally posted by walstib Quote
I finally got around to trying to update to v1.21 and noticed my K-3 will no longer display the current firmware version when I turn it on while pressing the menu button. Changed the battery - no help. Inserted the memory card with the 1.21 update on the card and still the camera does not display the firmware version or display update menu. Also used the "reset" command in the camera menu to return all settings to default. That didn't work either. Anyone familiar with this issue?
Go into the setup menu and select "firmware". You should see the version there

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

11-25-2015, 12:40 PM   #3
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,158
QuoteOriginally posted by walstib Quote
That didn't work either. Anyone familiar with this issue?
Welcome to the Pentax Forums!

While that may work on some earlier bodies, with the K-3 it is different. With the K-3 you check the firmware version by:

menu > setup (p4) > Firmware Info/Options



Steve
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, display, firmware, k-3, k-3 firmware version, menu, pentax help, photography, troubleshooting, version
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
No longer a K-7 specific forum Mikesul Pentax DSLR Discussion 4 06-05-2016 10:08 AM
How to find firmware version on K-3 fstop18 Pentax K-3 3 10-16-2015 09:42 PM
Sigma 150-500 no longer available in K mount Scorpio71GR Pentax SLR Lens Discussion 29 06-09-2015 08:58 PM
Power outage / USB 3.0 ports no longer working r0ckstarr General Talk 5 01-08-2015 05:13 PM
Manual mode no longer available on K-01 ckbboy Pentax K-01 8 11-26-2014 10:30 PM



All times are GMT -7. The time now is 01:29 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top