Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-24-2015, 08:49 AM   #1
Site Supporter
Spodeworld's Avatar

Join Date: Aug 2011
Location: New Joisey
Photos: Gallery | Albums
Posts: 1,190
Fixing a screw mount mechanism

OK I meant screw drive autofocus mechanism (not screw mount)

I know that this is a bit of a repeat from what I wrote about the K20D a day or two ago, but this is more specific and I was wondering if anyone had any idea why this was happening and if there is a relatively straight forward remedy.

My K20D's AF seems to work fine when I put on a lens with an internal motor (e.g., HSM), but when it uses a screw drive lens, it goes wonky, having great difficulty finding focus, if it can find it before giving up. Any idea if there is a way to check on what is wrong with the screw drive autofocus mechanism and how it might be fixed?

Thanks

and Happy Holidays!


Last edited by Spodeworld; 12-24-2015 at 11:15 AM.
12-24-2015, 10:07 AM   #2
dms
Site Supporter




Join Date: Aug 2011
Location: New York, NY
Photos: Gallery
Posts: 1,555
The screw mount mechanism is in the lens; however,
1. Did you try manualy focusing the AF lens--just to rule out mechanical problems w/ manual focus lens?
2. Did you check if the focusing screen is properly mounted? If it is loose nomally in my experience it ends up out of the shelf it sits in and is askew/immediately obvious. Perhaps google focusing screen. (Do not touch it with bare skin. Use a tool or a covered finger.)

I just realized you meant screw drive AF lens--not screw mount (as in manual focus) lens right? Of course/sorry I misunderstood.
12-24-2015, 10:09 AM   #3
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,288
QuoteOriginally posted by Spodeworld Quote
but when it uses a screw mount lens,
Just FYI I think you mean "screw drive"? Screw Mount is M42, and has no auto focus at all.

No idea what your issue with the AF is though. Any other problems? Are the lenses identified correctly? Are the contacts clean? Is the problem with all screwdrive lenses or just one?
12-24-2015, 10:33 AM   #4
Pentaxian
aleonx3's Avatar

Join Date: Jul 2007
Location: Brampton, Ontario
Photos: Gallery | Albums
Posts: 3,873
QuoteOriginally posted by jatrax Quote
Just FYI I think you mean "screw drive"? Screw Mount is M42, and has no auto focus at all.

No idea what your issue with the AF is though. Any other problems? Are the lenses identified correctly? Are the contacts clean? Is the problem with all screwdrive lenses or just one?
I think the OP meant screw drive mechanism on the AF lens, not screw mount (m42) manual lens, although I could be wrong.. LOL

12-24-2015, 10:36 AM   #5
Pentaxian
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 3,898
The screw drive mechanism on the camera may be faulty. Either the motor is going bad or the gearing is. If you operated the manual focus ring on a screw drive lens with the AF switch engaged you may have damaged the drive. If the drive itself is damaged service or replacement are you options. Or the drive on the lenses maybe at fault. Test them on another body if possible. Same options - repair or replace if bad.
12-24-2015, 10:58 AM   #6
Site Supporter
Spodeworld's Avatar

Join Date: Aug 2011
Location: New Joisey
Photos: Gallery | Albums
Posts: 1,190
Original Poster
I meant screw drive autofocus system, sorry. The few screw mount lenses I've tried on this cam often have trouble finding focus with the drive going in and out and giving up. They're ok on my K30, for example. The HSM ones I've tried, though, find focus without problem and without much searching. So, I think something is going on with the screw drive mechanism.

And, MF lenses also work fine on it.

Last edited by Spodeworld; 12-24-2015 at 11:11 AM.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, idea, lens, mechanism, pentax help, photography, screw, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wiggle on a old 20mm Screw Mount prime lens Tighelander Pentax SLR Lens Discussion 7 10-29-2015 01:34 PM
Leica screw-mount lenses on a K-3? PALADIN85020 Pentax K-3 17 03-29-2014 06:56 PM
Possible to mount a ring flash to a reverse mounted Takumar 50 1.4 screw mount lens. Washingtonstater Photographic Technique 3 09-29-2013 08:32 PM
fixing a broken DAL 18-55 plastic mount drewski Troubleshooting and Beginner Help 20 07-22-2013 09:59 AM



All times are GMT -7. The time now is 12:06 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top