Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-01-2016, 05:39 PM   #1
New Member




Join Date: Jan 2016
Posts: 6
Shutter Firing Touching Any Button

Hello Everyone,

This is my first time posting here so I hope I make since. I have a Tamron 70-200 2.8 lens that I use on my K20D that is firing the shutter no matter what button I touch. It has always worked fine until the last week. All other lenses I have work fine on the camera. Any ideas ? Thank you

01-01-2016, 06:01 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 41,000
Try cleaning the mount on the lens and camera, then re-mount the lens and see if that helps.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

01-01-2016, 06:07 PM   #3
New Member




Join Date: Jan 2016
Posts: 6
Original Poster
Probably a stupid question, but what do I clean the mounts with ? Thank you

---------- Post added 01-01-16 at 06:22 PM ----------

Cleaning did not help. I have noticed also that one the battery is less than full charge the lens will work more often

---------- Post added 01-01-16 at 06:52 PM ----------

Well I feel stupid. Got to noticing the shutter lever did not have a gap between it and the guard like my other lenses do, so I bent it back out a little and the lens is working every shot, knock on wood. I must have bumped it at some point without knowing.
01-01-2016, 10:29 PM   #4
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 9,555
QuoteOriginally posted by Gary Andrews Quote
Probably a stupid question, but what do I clean the mounts with ? Thank you

---------- Post added 01-01-16 at 06:22 PM ----------

Cleaning did not help. I have noticed also that one the battery is less than full charge the lens will work more often

---------- Post added 01-01-16 at 06:52 PM ----------

Well I feel stupid. Got to noticing the shutter lever did not have a gap between it and the guard like my other lenses do, so I bent it back out a little and the lens is working every shot, knock on wood. I must have bumped it at some point without knowing.
Can you post a picture? I am lost.

01-01-2016, 10:33 PM   #5
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 41,000
So the aperture control lever got bent?

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

01-02-2016, 07:58 AM   #6
New Member




Join Date: Jan 2016
Posts: 6
Original Poster
Yes Adam. It was bent in and touching what I guess would be the guard. I bent it back out to where it was straight up and had a gap between the two and it has worked every shot since. Looks like it was bent enough that it was not sitting where the shutter could catch it. Not sure why that would make the shutter fire no matter which button you touch, but it is working right now.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
button, camera, lens, pentax help, photography, pm, post, shutter, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-r glitch? Shutter fires every time I press any button. Help? MrA Pentax K-r 22 12-09-2016 07:56 AM
K3 II shutter doesn't stop firing decpi Pentax K-3 5 09-07-2015 05:48 PM
spotmatic shutter not firing punkrockpete Troubleshooting and Beginner Help 7 03-05-2014 08:29 PM
Shutter goes off when any button pressed DianeFazio Troubleshooting and Beginner Help 6 12-02-2012 01:34 PM
K10D shutter release button not working well . Any ideas lesmore49 Pentax DSLR Discussion 6 07-19-2009 10:48 PM



All times are GMT -7. The time now is 06:13 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top