Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-30-2016, 05:02 AM   #1
Junior Member
MorgothV8's Avatar

Join Date: Jul 2015
Location: Minsk Mazowiecki
Posts: 49
Pentax 67 now meters only in stop-down mode

Hi there. I had (bad) idea...
I had 100% OK Pentax 67 with metering prism.
I decided to change focus screen (that I already had) to BB-61 (clear matte) instead of split image in the center which disturbed me.
First time I had focus beyond infinity.
After some googling and trial and errors with metering prism took of and loupe/maginfier over the focus screen I had perfect focus at lens in infinity and matter best focus on infinity too.
That took some time.
After assembling all together and connecting prism (according to manual, connecting it without lens mounted).... it was not metering...
I thought maybe battery, but after googling I found that it should show total overexposure when I click depth of field lever or set lens (block it) on MAN.
But to my surprise it is metering in that mode just OK.
But only in that mode.
So I set for example f=8, t=1/125s and I see "total underexposure), but once I block lens in MAN and change aperture or time I see metering just works...
It should work that way on full aperture without pressing DOF... that was working that way before.
I disassembled and assembled carefully again and the same.....
There is some sprint inside that is supposed to adjust matte height, but it is (and was) broken.... have it something in common?

I'm not totally dead with that, but I will ahve to use DOF anytime I meter ... what could I do wrong?
Any suggestions?

Thanks!
Best Regards!
BTW: all google pages say changing matte is so hard in P67 - this focus setting is supposed to be so hard. But this was actually possible with loupe, prism taken off and lens set to infinity - just maby 20 mintes of trials...

01-30-2016, 11:34 AM   #2
Site Supporter
gofour3's Avatar

Join Date: Oct 2008
Location: Vancouver, Canada
Posts: 5,299
QuoteOriginally posted by MorgothV8 Quote
Hi there. I had (bad) idea...
I had 100% OK Pentax 67 with metering prism.
I decided to change focus screen (that I already had) to BB-61 (clear matte) instead of split image in the center which disturbed me.
First time I had focus beyond infinity.
After some googling and trial and errors with metering prism took of and loupe/maginfier over the focus screen I had perfect focus at lens in infinity and matter best focus on infinity too.
That took some time.
After assembling all together and connecting prism (according to manual, connecting it without lens mounted).... it was not metering...
I thought maybe battery, but after googling I found that it should show total overexposure when I click depth of field lever or set lens (block it) on MAN.
But to my surprise it is metering in that mode just OK.
But only in that mode.
So I set for example f=8, t=1/125s and I see "total underexposure), but once I block lens in MAN and change aperture or time I see metering just works...
It should work that way on full aperture without pressing DOF... that was working that way before.
I disassembled and assembled carefully again and the same.....
There is some sprint inside that is supposed to adjust matte height, but it is (and was) broken.... have it something in common?

I'm not totally dead with that, but I will ahve to use DOF anytime I meter ... what could I do wrong?
Any suggestions?

Thanks!
Best Regards!
BTW: all google pages say changing matte is so hard in P67 - this focus setting is supposed to be so hard. But this was actually possible with loupe, prism taken off and lens set to infinity - just maby 20 mintes of trials...
The first thing that comes to mind is the BB-61 screen is for the 67ii and not the older 67 and 6x7 bodies. My guess is your TTL prism is not seeded properly and one of the contacts is not touching the camera body properly because your are using an incorrect focusing screen. Hence your previously working TTL meter now only works with the lens in MAN.

Best swap back to your original 67 screen. Note the 67 screens are not user changeable and should be done by an authorized Pentax repair man/tech.

Phil.
01-30-2016, 02:52 PM   #3
Junior Member
MorgothV8's Avatar

Join Date: Jul 2015
Location: Minsk Mazowiecki
Posts: 49
Original Poster
Manual says this 67 screen is OK...
I wasted 5 hours with loupe and focus is 101% ok, but without metering "full aperture"
Anyway - I'll live with stop-down deterring .... one more step to get light... but is this necessary.... ?
Hmmmm but it was just OK?
Anyway selling P67II?
Seriously....
01-30-2016, 03:42 PM   #4
Site Supporter




Join Date: Jun 2011
Location: Texas
Photos: Gallery
Posts: 1,142
Assuming the 67 is like the 6x7, the lens aperture setting is transmitted to the meter by a very thin chain linkage. If that linkage is broken the meter can't tell the set aperture unless you stop down manually.

01-30-2016, 11:03 PM   #5
Site Supporter
gofour3's Avatar

Join Date: Oct 2008
Location: Vancouver, Canada
Posts: 5,299
QuoteOriginally posted by MorgothV8 Quote
Manual says this 67 screen is OK...
No, if you read the "67ii Interchangeable Focusing Screen" manual it states these screens are not for the 67.

Also if you look at the 67 camera manual it shows the four 67 focusing screens that were available, they are not the same and are not user replaceable.

The BB-61 screen is causing the issue with your 67 & TTL meter, remove it and you will be OK, providing you can reinstall the original screen correctly.

Phil.
01-31-2016, 12:43 AM   #6
Junior Member
MorgothV8's Avatar

Join Date: Jul 2015
Location: Minsk Mazowiecki
Posts: 49
Original Poster
OK, so I prefer this focusing screen and I can live with stop-down metering.
THANKS.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, camera, focus, infinity, lens, matte, mode, pentax help, photography, prism, screen, time, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
645Z + FA 645 55mm: Sharpest f-stop at f8 or stop down? Hyperfocal issues.... steve645z Pentax Medium Format 31 01-09-2017 08:08 AM
Stop Down Metering in K30 (with Extension Tube & Lens Reversed) rp_dxn Pentax K-30 & K-50 5 09-23-2013 11:43 PM
Original Pentax 645 only fires once in S mode then needs reboot Steinback Pentax Medium Format 3 01-22-2012 01:51 AM
K-X in video mode -- questions about setting f-stop greenless Troubleshooting and Beginner Help 6 11-30-2009 01:06 PM
stop-down metering and Av mode Beau Pentax DSLR Discussion 15 06-02-2009 09:58 PM



All times are GMT -7. The time now is 01:57 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top