Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-18-2016, 05:04 PM   #1
New Member




Join Date: Feb 2016
Posts: 7
Frozen Aperture control K-50

Hello all new to the forum but not new to Pentax.

I had a Pentax K-200 and have a K-2000 and K-50.

A few months ago I noticed the K-50 occasionally not responding to the aperture control after a shot while in Aperture priority mode with Pentax-A and Pentax AF lenses. Now the aperture control stops responding after each shot, If you switch the mode wheel, turn the camera on and off or go to the menu it starts responding again but as soon as you take shot stops again.

Olympus m4/3 is my primary camera and Sony A7 is used for subject isolation so sadly the aps-c Pentax's just sit in a drawer most of the time so I don't know if this issue is progressive or just started all at once. I hope it is a setting or that there is some simple method of using aperture priority mode the only mode I shoot in in any format other than point and shoot. I dumped my Pentax-M lenses and acquired additional Pentax-A and AF lenses so this is a frustrating issue on top of the issues with using manual focus with DSLR and OVF. I may as well have kept the great Pentax-M lenses and used them full frame on the A7 and 1/4 frame on Oly's, although in some situations if I use a tripod with 500 and 1000mm lenses I can actually get better image quality out of the Pentax than the great OM-D which in turn completely wallops the A7 in almost all situations and of course makes canons and nikons seem like useless toys.


Thanks in advance.

02-18-2016, 05:53 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,280
Luckily this sounds like a simple problem associated with the default camera behavior.

Turn off instant review, or half-press before trying to turn the aperture wheel

Alternatively, you can map the aperture control to the front dial so that it responds even when in instant review.

Hope this helps!
02-19-2016, 04:27 PM   #3
New Member




Join Date: Feb 2016
Posts: 7
Original Poster
Thanks so much for the quick reply Adam I really love this camera hands down the best aps-c dslr buy. As far as half depressing the shutter button I believe that always used to work to regain aperture control but it no longer does unless my memory fails me. I dug through the settings and the instant review tip did not return dial function. I went into other modes like shutter priority and manual mode and tried the exposure button and found the all froze aftein camera r taking a picture regardless of display/live view settings and of course loosing manual mode and speed priority is not good worse than being stuck at a fixed aperture as no the camera is useless except for the same exposure.

I went to metering time and changed the setting from 10 seconds (apparently default) to 3 and presto chango after 3 seconds I gain control over the camera so now it is entirely usable although with a 3 second delay. It seems like it used to respond after a shutter half click so there still seems to be something wrong with the camera or settings. If it had not been sitting in a drawer for a couple of months I would certainly have noticed a major change that's why I contacted Pentax forums to contact others familiar with the K50.
02-19-2016, 04:34 PM   #4
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,280
That's very strange, because the e-dial should respond immediately unless the camera is in instant review mode...

I would try performing a full settings reset (via the setup menu) to see if something else is maybe getting in the way.


Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
a7, aperture, aperture control, aperture priority, camera, control, control freezing, frame, k-50, lenses, mode, pentax, pentax help, photography, settings?, shot, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-30 Aperture control and battery problem mgvh Troubleshooting and Beginner Help 10 10-21-2016 06:56 AM
CA and Distortion Control on K-30, K-50 indysteve Pentax K-30 & K-50 5 08-23-2014 10:23 AM
Aperture control during video shooting with K-x ? ilya80 Video and Pentax HDSLRs 8 05-02-2010 10:54 AM
K-x with prime -- no aperture control pentaxpup Pentax DSLR Discussion 9 12-15-2009 07:37 PM
Aperture control with old K mount lenses MattGunn Pentax SLR Lens Discussion 3 07-05-2009 09:04 AM



All times are GMT -7. The time now is 07:38 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top