Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-17-2016, 04:04 AM   #1
New Member




Join Date: Feb 2016
Location: PA
Photos: Albums
Posts: 16
New K50 & new user camera not working

I was taking photos at the bird feeder with my kit 55-300 lens, I took 6 or 7 photos and then the lens started auto focusing abnormally I took another photo and the LCD screen would no longer come on the shutter would take photo but no auto focus and no adjustments shutter, aperture? The battery says its 100% I removed battery I removed sd card, I tried 18-55 kit lens does the same thing takes one photo the lcd screen goes black after while the screen may or may not flash on. I reset settings, I have the newest update. Should I return the camera? Very disappointed I put a lot of time and energy into choosing what I thought was a reliable durable camera. I am new to dslr and pentax hopefully someone can help.

03-17-2016, 04:15 AM   #2
Site Supporter
Ex Finn.'s Avatar

Join Date: Nov 2007
Location: Southern Maryland.
Photos: Gallery | Albums
Posts: 6,283
That`s disappointing for sure, most definitely send it back and get it exchanged with a new one, that is , if you liked it while it worked.
03-17-2016, 04:47 AM   #3
Pentaxian




Join Date: Apr 2010
Location: Wangaratta, Victoria
Photos: Gallery
Posts: 3,500
A K50 is better than that - lots!!
Send it back for exchange.


The funny focussing thing could have been due to AF-C instead of AF-S selected.
But black LCD's aren't normal by any means
03-17-2016, 05:02 AM   #4
PJ1
Site Supporter
PJ1's Avatar

Join Date: Jul 2012
Location: Mosquito Creek, Australia
Photos: Gallery
Posts: 1,530
Don't be disheartened. Most Pentax cameras operate without glitches like that (mine have all be great). I don't know how long you have been using your K50 but you should be able to get it exchanged for a new one. The K50 is a very good camera and problems are rare from what I have seen. Also, this is a great forum. You won't find anywhere else that is as supportive and good for advice. Get yourself clicking again and stick with us.

03-17-2016, 05:50 AM   #5
Loyal Site Supporter




Join Date: Jun 2009
Location: Tumbleweed, Arizona
Photos: Gallery | Albums
Posts: 5,107
Unfortunately, today's cameras are not the same as the one's of yesteryear (analog film pretty much all mechanical contraptions). Today's cameras are hand held computers with a lens that you stick on the front. In that they are essentially electronic electro mechanical marvels, they are going to fail just like other consumer electronics - either right out of the box (referred to as infant mortality) or after hopefully a long and productive lifetime. That is just the nature of the electronic beast that we have created.

I hate to say this, - if you are within the return period, box it up and send it back (to the retailer) and get another unit.... If you are within the warranty period send it back to Pentax for repair.

03-17-2016, 06:04 AM   #6
Loyal Site Supporter
TER-OR's Avatar

Join Date: Apr 2009
Location: Dundee, IL
Photos: Gallery | Albums
Posts: 5,831
Yeah, one bad capacitor or regulator somewhere can cause all kinds of troubles. Every brand is vulnerable. Send it back for exchange and note its behavior. That's what the warranty is for.
03-17-2016, 08:37 AM   #7
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 9,831
Battery fully charged? It needs to be charged 6+ hours out of the box before first use.
03-17-2016, 09:31 AM   #8
New Member




Join Date: Feb 2016
Location: PA
Photos: Albums
Posts: 16
Original Poster
Thanks guys WAS very happy with Pentax

Thanks for the feed back. I have been using the camera since 2-24-16 and very happy? Hope B&H doesn't give me any trouble. Very hesitant Pentax rebuy??? I am/was trying to avoid the other big name cameras................

03-17-2016, 09:38 AM   #9
Loyal Site Supporter
TER-OR's Avatar

Join Date: Apr 2009
Location: Dundee, IL
Photos: Gallery | Albums
Posts: 5,831
Contact B&H, I'm not sure how the warranty works. They'll know. This is abnormal if the battery is charged.

Are you shooting via Live View? Your comments about the screen indicate you might be. Does the camera focus properly when you're using the viewfinder (not Live View)?

Also, make sure the MF/AF switch isn't stuck somewhere in-between. I've had that happen, where the switch gets knocked out of alignment.
03-17-2016, 09:52 AM   #10
New Member




Join Date: Feb 2016
Location: PA
Photos: Albums
Posts: 16
Original Poster
Thanks I will look?

I don't know what "live view is"? I take all my photos from view finder never from lcd screen? I will check the MF/AF switch. Thank you very much for the recommendations...........
03-17-2016, 10:01 AM   #11
Loyal Site Supporter
TER-OR's Avatar

Join Date: Apr 2009
Location: Dundee, IL
Photos: Gallery | Albums
Posts: 5,831
When you mention the LCD screen going off, do you mean the instant review after you take a picture? That's what's confusing me in your first message, why I thought the Live View might be used.

There is an LV button on the back. Press that and you use the LCD screen as your viewfinder, like a big mirrorless camera. The camera focuses in a different mode using that.
03-17-2016, 10:04 AM   #12
Forum Member




Join Date: Oct 2009
Location: North Oregon Coast
Posts: 89
You're within warranty, so contact them asap & send it back. No need to mess with it since you have the return option. It might be wise to do a straight return & refund now, relax a bit, and do further research.

Personally, I ordered a K-50 and sent it back without pulling it out of the box (had been looking for a second WR body to go with my K200d). My concern was the numerous postings I discovered (after ordering) related to an aperture-control-mechanism failure that has occurred frequently on this camera and it's earlier sibling, the K-30.

I later found a used like-new K-200d. These cameras are a bit old school now, but they take great pictures and are absolute tanks. You simply can't break them unless you throw them on the ground & stomp on 'em!

Not saying you should by a K200d, but just pointing out that there are many pathways to explore.

Last edited by bobore; 03-17-2016 at 10:10 AM.
03-17-2016, 10:08 AM   #13
New Member




Join Date: Feb 2016
Location: PA
Photos: Albums
Posts: 16
Original Poster
Got it>

No when i press the shutter the photo is taken and then I am used to seeing the shutter, aperture, iso. What is happening now the screen stays black you can press the shutter and the shutter fires but no auto focus screen stays black I cant adjust the shutter iso or aperture. the photo is taken when the shutter is pressed just no autofocus and no control with a black screen.

---------- Post added 03-17-16 at 10:15 AM ----------

QuoteOriginally posted by bobore Quote
You're within warranty, so contact them asap & send it back. No need to mess with it since you have the return option. It might be wise to do a straight return & refund now, relax a bit, and do further research.

Personally, I ordered a K-50 and sent it back without pulling it out of the box (had been looking for a second WR body to go with my K200d). My concern was the numerous postings I discovered (after ordering) related to an aperture-control-mechanism failure that has occurred frequently on this camera and it's earlier sibling, the K-30.

I later found a used like-new K-200d. These cameras are a bit old school now, but they take great pictures and are absolute tanks. You simply can't break them unless you throw them on the ground & stomp on 'em!

Not saying you should by a K200d, but just pointing out that there are many pathways to explore.
Good point about looking at other options...........I chose the K50 because of photo sports and catching the action. I don't know anything except what I've read? I just want to take sharp photos of action shots I know the nikon that is equil to the k50 stats is way out of my budget.............. Just very disappointed and frustrated with what so many people say is a awesome camera. Thanks for the food for thought
03-17-2016, 11:00 AM   #14
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 9,831
Press the info button - I think that's what changes the screen display mode. It sounds like you are in the "no display" mode. I no longer have a K-50 due to a trade so I can't fully explain it in detail but you might check the manual to see if you have just set your display off. That should not disable autofocus however.
03-17-2016, 03:08 PM   #15
Site Supporter




Join Date: Mar 2014
Location: Daphne, Alabama
Posts: 208
could it be set to "B" mode?

Wondering is the mode might be set to "B".
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
action, battery, bit, broken, camera, iso, k200d, k50, kit, lcd, lens, not working, pentax help, photo, photography, photos, press, screen, shutter, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hello folks, old GR user and 645 user - new GRV user and 645Z user, coming fr Leica. bilbrown Welcomes and Introductions 3 02-28-2016 03:59 AM
Tamron 70-300 not working after k50 firmware update Andre771 Troubleshooting and Beginner Help 5 09-13-2015 02:31 PM
New to DSLR: Camera recommendations (KS1 or K50) thaliagoo Pentax DSLR Discussion 25 08-24-2015 06:59 PM
New Pentax User Love my K50 digitalbarn Welcomes and Introductions 3 12-12-2014 01:38 PM
Alert!!! Read now!!! Pentax K50 & kit lens for $299 new arnold111 Pentax Price Watch 18 11-27-2014 01:32 PM



All times are GMT -7. The time now is 02:04 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top