Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-19-2016, 10:37 AM   #1
Site Supporter




Join Date: May 2012
Posts: 2,642
K3 Problem

I think there have been previous posts on this but I don't know what exactly it is that I should be searching for to find the answer.

I previously owned a K5 and now a K3 without any problems whatsoever with either body. However today when I was out shooting with the K3 I pressed the shutter and the thing ran away without me. It probably did 30 clicks or more. It was basically machine gunning.

I turned the camera off and it stopped. Then I took the battery out and put it back and there wasn't a problem. Never had a problem before and so far I haven't had a problem since. Since that one incident I maybe took 100 shots and there hasn't been an issue. My lens was a 31mm.

My camera was set on M mode doing single frames, but all of the sudden it just had a mind of it's own for about 5 - 10 seconds. I have had my K3 for quite some time now. If I am not mistaken I bought it in September or October of last year...maybe even longer than that. Basically let's call it 6 to 8 months.

Is it anything I need to worry about? I sure hope my camera doesn't develop problems because right about now would be next to impossible to get a replacement.

03-19-2016, 10:59 AM   #2
Senior Member




Join Date: Dec 2015
Location: Calgary Alberta Canada
Photos: Gallery
Posts: 138
Try searching for "K3 Mirror Flop". There was a firmware update to mitigate it (maybe 1.11, I don't recall exactly). There is a true fix, but it requires a trip to the service centre. The mitigation basically stops the runaway mirror, and resets a few things. IIRC you wind up with a single black frame stored to the card. I experienced it once with my K3 (although it required battery removal to stop), but not since the FW update.
03-19-2016, 11:38 AM   #3
Site Supporter




Join Date: May 2012
Posts: 2,642
Original Poster
But why would it randomly start after 6 or 8 months?
03-19-2016, 01:10 PM - 1 Like   #4
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 42,816
QuoteOriginally posted by alamo5000 Quote
But why would it randomly start after 6 or 8 months?
The whole mirror flop thing seems pretty random in general. Your best bet would be to upgrade the firmware to the latest version. Unless the mirror flop issue increases in frequency, I wouldn't worry about it.


Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

03-19-2016, 01:12 PM   #5
Site Supporter




Join Date: May 2012
Posts: 2,642
Original Poster
QuoteOriginally posted by Adam Quote
The whole mirror flop thing seems pretty random in general. Your best bet would be to upgrade the firmware to the latest version. Unless the mirror flop issue increases in frequency, I wouldn't worry about it.
How can I tell which firmware I have and which one is the latest version?

Like I said... 8 months in and never a flop one...so I will give it time and hope and pray that it's nothing major. I am in Africa right now so I am hoping it was just a one off thing.
03-19-2016, 01:29 PM - 1 Like   #6
Site Supporter




Join Date: Dec 2014
Posts: 47
QuoteOriginally posted by alamo5000 Quote
How can I tell which firmware I have and which one is the latest version?
.
Page 23 in your owner's manual. Or try screen/page 4 in the Tools menu....
Those owner manuals can be helpful.
03-19-2016, 01:50 PM   #7
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 42,816
QuoteOriginally posted by alamo5000 Quote
How can I tell which firmware I have and which one is the latest version?

Like I said... 8 months in and never a flop one...so I will give it time and hope and pray that it's nothing major. I am in Africa right now so I am hoping it was just a one off thing.
Pentax K-3 Firmware v1.21 Released - Firmware Updates | PentaxForums.com

See step 9 for info on checking the current firmware version.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

03-19-2016, 01:58 PM   #8
Site Supporter




Join Date: May 2012
Posts: 2,642
Original Poster
QuoteOriginally posted by Adam Quote
Pentax K-3 Firmware v1.21 Released - Firmware Updates | PentaxForums.com

See step 9 for info on checking the current firmware version.
Thanks!

Done.

Let's hope that avoids any other problems.

03-20-2016, 06:20 AM   #9
Pentaxian




Join Date: Sep 2009
Location: Texas
Photos: Gallery
Posts: 3,430
QuoteOriginally posted by Adam Quote
The whole mirror flop thing seems pretty random in general. Your best bet would be to upgrade the firmware to the latest version. Unless the mirror flop issue increases in frequency, I wouldn't worry about it.
Mine did the mirror flop thing after upgrading to the latest firmware, so that may not be the cure. But, it is random and not often. Out of three K3's, it's only happened to me twice with the same camera.

https://www.pentaxforums.com/forums/172-pentax-k-3/254464-k3-crazy-mirror-sic...s-here-60.html
03-20-2016, 06:34 AM   #10
Loyal Site Supporter
Scorpio71GR's Avatar

Join Date: Nov 2014
Location: Michigan
Photos: Gallery | Albums
Posts: 3,705
I have it happen one on my K3. My mirror used to stick up until the last firmware. The only fix was to pull both batteries.
03-21-2016, 06:21 AM   #11
Site Supporter
charchri4's Avatar

Join Date: Sep 2015
Location: Sunny SW Minnesota
Posts: 234
Mine did the mirror stick too but less than a year old so I sent it in under warrenty. I never could get them to tell me what they did but supposedly they reap replaced something in it. So far so good.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k3, pentax help, photography, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shutter problem ? K3 Crumplebury Pentax K-3 7 03-08-2016 01:03 AM
K3-Strange Exposure Problem Setter Dog Pentax K-3 7 04-21-2015 04:43 PM
Problem with K3-Help Needed Please Setter Dog Pentax K-3 7 02-27-2015 03:47 AM
Problem with Pentax DA 16-50 F2.8 lens on K3 ifegent Troubleshooting and Beginner Help 14 07-14-2014 10:13 PM
K3 and DA* AF problem fixed?? RedBoomer Pentax K-3 2 12-05-2013 05:24 AM



All times are GMT -7. The time now is 01:46 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top