Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-31-2016, 01:02 PM   #1
New Member




Join Date: Mar 2016
Posts: 2
Memory card issue K10D

Hello,

I'm (was ?) the happy owner of a K10D since 6 years. I never had an issue until recently.

I never had any issue until recently when I started to get a "memory card error" notice or "the image couldn't be taken" (not sure if it's the exact translation).

I've tried two different cards : an 32 GB Emtec Card (class 4) and a 8GB Kingston Card (class 4 also). The problem stay the same in both situation.

I've already tried formatting cards both through computer and camera. I also already updated the firmware (ver 1.31). The problem stays the same.

I'm currently in the middle of nowhere (south Ecuador) and I need my camera to work as I'm here for a job.

Any ideas ? Thanks

03-31-2016, 01:25 PM   #2
Site Supporter
wtlwdwgn's Avatar

Join Date: Jan 2007
Location: Billings, MT
Photos: Gallery | Albums
Posts: 8,590
Check to make sure the cards are not locked as I've had that the cause of the error before. If not, the cards may be corrupted.
03-31-2016, 01:32 PM   #3
New Member




Join Date: Mar 2016
Posts: 2
Original Poster
After this message, I tried with a few more cards I've, including smaller ones because someone told me the K10D had occcasional issues with more than 4GB memory.

Problem is the same. (and they're not locked either).

Thanks anyway
03-31-2016, 01:32 PM   #4
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,958
Maybe the cards have gone bad? I'd try to buy a sandisk card (class 10 or better) if you can, and test the camera with that. Also, make sure the write protection pin isn't engaged on accident.


Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

03-31-2016, 01:44 PM   #5
Loyal Site Supporter
blackcloudbrew's Avatar

Join Date: Mar 2009
Location: Cotati, California USA
Photos: Gallery | Albums
Posts: 3,782
Make sure there isn't a broken piece of plastic in the card reader in the camera. Not saying this is the problem but I had this happen on my Q system and the error messages were kinda like that.
04-02-2016, 03:36 PM   #6
Site Supporter
slip's Avatar

Join Date: Oct 2006
Location: 2 hours north of toronto ontario canada
Photos: Gallery | Albums
Posts: 3,515
Make sure your firmware is up to date first

Good luck

Randy
04-02-2016, 03:46 PM   #7
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,190
QuoteOriginally posted by slip Quote
Make sure your firmware is up to date first

Good luck

Randy
Good luck updating if the camera cannot read a card...just say'in...


Steve
04-02-2016, 04:07 PM   #8
Pentaxian
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 3,897
Version 1.31 is the latest for the K10D.

04-02-2016, 05:49 PM   #9
Pentaxian
aleonx3's Avatar

Join Date: Jul 2007
Location: Brampton, Ontario
Photos: Gallery | Albums
Posts: 3,873
Could it be the problem with the SD slot in k10D camera? It's been working does not mean that it will not fail as it is after all, an old camera.
04-26-2016, 01:11 AM   #10
New Member




Join Date: Jan 2015
Posts: 19
Hi there.

I've had the same problem with my k10d. It looks like it is a connection problem with the SD card slot.

The problem came and went so I ended up buying another low mileage k10d. It is still a great camera. No bells and whistles but everything you really need in a brilliant easy to use package.
04-26-2016, 02:58 AM   #11
New Member
dunearn's Avatar

Join Date: Aug 2007
Location: Highlands Scotland
Posts: 4
Try taking the battery out whilst camera is switched on and leave the memory card in .... worked for me anyways

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, cards, class, issue, k10d, memory card issue, pentax help, photography, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Memory Card Issue Pentax K-50 Zoomer Troubleshooting and Beginner Help 6 08-11-2014 06:24 PM
Memory card issue bass3587 Pentax K-5 9 03-15-2013 08:01 PM
Memory Card issue with K10 VTPentax Pentax DSLR Discussion 6 04-05-2010 05:22 AM
K20D Memory Card Issue George Lama Pentax DSLR Discussion 11 11-27-2009 07:32 PM
K10D problem or memory card issue? harv3589 Pentax DSLR Discussion 19 07-16-2007 07:29 PM



All times are GMT -7. The time now is 01:22 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top