Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-15-2016, 08:07 AM   #1
Junior Member
Gampa's Avatar

Join Date: Mar 2008
Location: Cranston, RI
Posts: 34
Battery grip not working on K5IIs

I have a Pentax D-BG4 grip on my K5IIs. Until recently it had been working fine but now none of the controls on the grip are working, focus, shutter, AE-L, etc. The camera reads the battery okay and shows both the grip battery and in body battery. The grip works fine on my K5, shutter, focus, etc. are all working. What am I missing? Thanks in advance for your help.

05-15-2016, 08:20 AM   #2
Pentaxian
Oldbayrunner's Avatar

Join Date: Mar 2013
Location: Havre de Grace, MD
Posts: 1,220
You sure you have it switched to the on position?
05-15-2016, 08:56 AM   #3
Junior Member
Gampa's Avatar

Join Date: Mar 2008
Location: Cranston, RI
Posts: 34
Original Poster
Yes, it's in the on position. The grip works fine on my K5 but not on the K5IIs.
05-15-2016, 09:50 AM   #4
Pentaxian
Oldbayrunner's Avatar

Join Date: Mar 2013
Location: Havre de Grace, MD
Posts: 1,220
try cleaning the contacts on the bottom of your K5lls.

05-17-2016, 01:33 PM   #5
Junior Member
Gampa's Avatar

Join Date: Mar 2008
Location: Cranston, RI
Posts: 34
Original Poster
QuoteOriginally posted by Oldbayrunner Quote
try cleaning the contacts on the bottom of your K5lls.
Thank you for your reply. I apologize for not responding sooner but we had unexpected guests the day I posted. Anyway, what do you recommend to clean the contacts?
05-17-2016, 03:18 PM   #6
Site Supporter
forensicscientist's Avatar

Join Date: Jun 2008
Location: DFW Texas and Maine - I commute :)
Posts: 866
Dip a 'q-tip' into some alcohol and clean the contacts......allow the contacts to dry, then re-attach the grip.

Since the grip works on another body, that suggests that pins on grip are intact, so I'm with Oldbayrunner, contacts on the K5IIs would be the first stop.....

let us know if that solves the problem. If not, this may require more thought......
05-18-2016, 02:40 PM   #7
Junior Member
Gampa's Avatar

Join Date: Mar 2008
Location: Cranston, RI
Posts: 34
Original Poster
QuoteOriginally posted by forensicscientist Quote
Dip a 'q-tip' into some alcohol and clean the contacts......allow the contacts to dry, then re-attach the grip.

Since the grip works on another body, that suggests that pins on grip are intact, so I'm with Oldbayrunner, contacts on the K5IIs would be the first stop.....

let us know if that solves the problem. If not, this may require more thought......
Oldbayrunner and forensicscientist, thank you for your help! I had to clean the contacts on the camera body twice but the grip is working now. I never had that happen before on my K10D or K-5 so didn't know what the cause might be. Thanks again to both of you.
05-18-2016, 03:23 PM   #8
Site Supporter
forensicscientist's Avatar

Join Date: Jun 2008
Location: DFW Texas and Maine - I commute :)
Posts: 866
Glad it's working now....

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, battery grip, camera, focus, grip, k5iis, pentax help, photography, shutter, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Pentax K5IIS body with Pentax battery grip olypdd Sold Items 7 05-13-2016 01:03 AM
Battery grip not working with AA lotech Pentax K-3 9 04-28-2016 06:43 AM
For Sale - Sold: Pentax K5iis and Pentax battery grip TroutHunterJohn Sold Items 2 11-09-2015 07:41 AM
Pentax K5iis $526 New with battery grip ttran88 Pentax Price Watch 92 11-23-2014 09:00 AM
For Sale - Sold: Pentax D-BG4 battery grip for K5/K5II/K5IIS/K7 hongzhibin1987 Sold Items 7 04-01-2013 07:18 PM



All times are GMT -7. The time now is 01:43 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top