Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-20-2016, 02:55 AM   #1
New Member




Join Date: May 2016
Posts: 4
Pentax 645nii shooting problem

Hi

I'm new with pentax 645nii, and I have a problem.

Just got the camera, everything was fine for the first roll. On second roll, after 11th or so frame, it suddenly stopped fired. The condition:
1. View finder info is off
2. Top lcd stay on
3. When I turned it off, the lcd keep showing info as if it is on
4. Took the battery then replace it
5. It worked for one or two shutter release, then stopped again.

After finished the roll, I cleaned every contact on it. It worked fine.

But today I put a roll again, after 3rd frame, it happened again. So frustrating

Anyone ever experienced the same? Any suggestions for me?

Thanks so much for the feedback

Regards

05-20-2016, 07:04 AM   #2
Pentaxian




Join Date: Jul 2013
Photos: Gallery | Albums
Posts: 601
I had a similar event with mine, which I believe was due to poor quality batteries and cold conditions. I'd check the batteries first. Even brand new ones can be defective. I recommend Energizer Lithium. Those things last forever. Pricey though!
05-20-2016, 07:36 AM   #3
New Member




Join Date: May 2016
Posts: 4
Original Poster
QuoteOriginally posted by Wolfeye Quote
I had a similar event with mine, which I believe was due to poor quality batteries and cold conditions. I'd check the batteries first. Even brand new ones can be defective. I recommend Energizer Lithium. Those things last forever. Pricey though!
Hi..thanks for the response. So your problem solved after replacing the batteries with lithium? I'll give it a try though. Thanks
05-20-2016, 08:01 AM - 1 Like   #4
Pentaxian




Join Date: Jul 2013
Photos: Gallery | Albums
Posts: 601
QuoteOriginally posted by irawan_tn Quote
Hi..thanks for the response. So your problem solved after replacing the batteries with lithium? I'll give it a try though. Thanks
Well, what fixed my issue was replacing some cheapo, underperforming batteries with new Duracell ones, and getting the camera out of the cold. The Energizer batteries are my favorites. In general, alkaline batteries perform very poorly in cold weather. When I next take the 645nII out in the cold I'll have the lithium batteries onboard.

05-20-2016, 03:50 PM   #5
New Member




Join Date: May 2016
Posts: 4
Original Poster
QuoteOriginally posted by Wolfeye Quote
Well, what fixed my issue was replacing some cheapo, underperforming batteries with new Duracell ones, and getting the camera out of the cold. The Energizer batteries are my favorites. In general, alkaline batteries perform very poorly in cold weather. When I next take the 645nII out in the cold I'll have the lithium batteries onboard.
I see. Hope it works for mine. I'll get some tomorrow morning. Thanks!
05-21-2016, 05:48 AM   #6
New Member




Join Date: May 2016
Posts: 4
Original Poster
QuoteOriginally posted by irawan_tn Quote
I see. Hope it works for mine. I'll get some tomorrow morning. Thanks!
Got energizer lithium today, so far it is working. We'll see tomorrow after a cold night
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
645nii, camera, frame, info, lcd, pentax, pentax 645nii, pentax help, photography, roll, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax 645NII Focusing nightmare Wolfeye Troubleshooting and Beginner Help 6 11-23-2015 12:13 PM
Pentax 645Nii Lens Question tbovey Troubleshooting and Beginner Help 3 07-01-2015 07:43 AM
Interval shooting problem stubyles Pentax K-3 8 11-04-2014 04:56 AM
K01 interval shooting problem arc90901 Pentax K-01 2 08-12-2014 03:20 PM
Pentax ist ds problem with shooting denise60 Troubleshooting and Beginner Help 3 01-02-2014 07:55 PM



All times are GMT -7. The time now is 08:43 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top