Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-22-2016, 04:35 AM   #1
New Member




Join Date: May 2016
Posts: 4
K-S2 PDAF issue

Hi all! Long time lurker, first time poster.

Went out for a walk this morning and PDAF has completely packed in, it seems. Live view focusing works fine, but when viewing through the viewfinder, the following happens:

With focus assist light on:
  • The central AF point lights red
  • The camera focuses the lens from wherever it is to infinity
  • It then bumps back to about the 3m mark on my 50-200mm; with a 50mm prime on it bumps back a tiny way
  • The focus-confirmation hexagon starts flashing along with the flash-needed notification on the left of the viewfinder
  • No AF points light

With focus assist light off:
  • The central AF point lights red
  • The camera focuses the lens from wherever it is to infinity
  • The camera focuses the lens from infinity to MFD
  • It then bumps back to about the 3m mark on my 50-200mm; with a 50mm prime on it bumps back to near infinity
  • The focus-confirmation hexagon starts flashing along with the flash-needed notification on the left of the viewfinder
  • No AF points light

I get the same behaviour with SDM lenses.

After trying this, if I flip to live view, it hunts for a while, but then starts functioning perfectly. Unfortunately, live view is pretty inadequate for my needs!

I've tried air-blow the PDAF sensor area, factory reset + firmware update, four different lenses, and still have no idea.

The camera was a Christmas gift from a relative who's no longer with us and I've not been able to locate a receipt, so I'm a bit stuck for a shop to take it back to - consequently, any ideas before I try approaching Pentax UK (and inevitably get told where to go) appreciated!

05-22-2016, 05:24 AM   #2
New Member
scottmasterton's Avatar

Join Date: Feb 2013
Location: Edinburgh, Scotland.
Posts: 15
I'm sure you will have tried this but the one thing I always do when my camera glitches is to take the battery out for a little while.
05-22-2016, 05:59 AM   #3
New Member




Join Date: May 2016
Posts: 4
Original Poster
Indeed - should have mentioned this - turning it off and on again was tried first, followed by a 30 min period without a battery
05-22-2016, 07:56 AM   #4
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 9,495
QuoteOriginally posted by Maerlyn Quote
Indeed - should have mentioned this - turning it off and on again was tried first, followed by a 30 min period without a battery

I wonder if the serial number would give Ricoh enough info to know which store had it. Doubtful, but maybe.

Try longer - days or more. That's all I have. I wish I could come up with more.

07-06-2016, 05:01 AM - 1 Like   #5
New Member




Join Date: May 2016
Posts: 4
Original Poster
As an update on this (and an FYI for K-S2 users):

The camera went in for warranty repair in the UK, and they stated that they couldn't find any fault and sent it back. It worked for me for all of an hour before re-developing the fault, and nothing I tried could get it to work.

I took videos of the issue occurring and sent these off to Johnsons Photopia (the UK warranty repair company). They again couldn't replicate the fault, so contacted Pentax Europe to ask if anyone had ever come across this before - and they hadn't.

In frustration, they replaced the autofocus module and main PCB and sent it back. Still working 4 days later. Seems like it was a randomly occurring intermittent fault (probably with the autofocus module), which only occurred in my presence
07-06-2016, 09:20 AM   #6
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,178
QuoteOriginally posted by Maerlyn Quote
Seems like it was a randomly occurring intermittent fault (probably with the autofocus module), which only occurred in my presence



Steve
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, bumps, camera, infinity, lens, light, pdaf, pentax help, photography, troubleshooting, view, viewfinder
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale: Instantly download your Pentax eBook! (K-1, K-70,K-3, K-5, K-50, K-S2 and more DSLRs) ebooks4pentax Photographic Equipment for Sale 100 2 Days Ago 11:12 PM
Pentax S2 35mm SLR film winder issue Penduboy Pentax Film SLR Discussion 6 01-14-2016 11:57 PM
K-x upgrade - K-s2 kit vs. K-3 body? agraspar Pentax DSLR Discussion 10 12-21-2015 12:52 PM
Upgrade Advice? K-3, K-3II, K-50, K-S2???? Blacknight659 Pentax DSLR Discussion 7 10-16-2015 09:36 PM
Upgrade from K-30 to K-3/K-S2 dilemma Davidparis Pentax K-3 35 07-06-2015 12:35 PM



All times are GMT -7. The time now is 11:40 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top