Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-23-2016, 06:45 PM   #1
New Member




Join Date: Oct 2014
Posts: 5
K50 radically underexposing. Please help

I have a K50 that has been really reliable through about 10000 clicks with only rare minor freezing issues. Recently nearly all of my exposures are coming out black unless I slow the shutter to 2 seconds. I'm talking about black at 1/30th f/2 with midday sun. exposure compensation is at zero from what I can tell I've also tried rebooting the setting with no change. Any suggestions?

05-23-2016, 08:45 PM   #2
KDD
Veteran Member




Join Date: Sep 2013
Photos: Gallery | Albums
Posts: 354
Possible sensor dirty?
05-23-2016, 08:49 PM   #3
New Member




Join Date: Oct 2014
Posts: 5
Original Poster
I flipped up the mirror and from what I can tell the sensor looks pristine. When I slow down the shutter a lot I can get images but anything faster than a few seconds and the image is way underexposed.
05-23-2016, 09:17 PM   #4
Pentaxian




Join Date: Sep 2012
Location: NY
Photos: Gallery
Posts: 2,400
You could reset your functions to see if anything changes. I do not have a K-50 manual, but you most likely have the option. Before trying that, another thing you might want to try is using Green mode (if you have it) and see if there are any changes. Also you may want to try the other modes. Make sure the SD card contacts are clean and the card has been formatted in the camera you are using.

05-23-2016, 10:20 PM   #5
Site Supporter
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,772
This might help: https://www.pentaxforums.com/forums/151-pentax-k-30-k-50/315725-dark-exposure...-me-first.html
05-23-2016, 10:52 PM   #6
Pentaxian
richandfleur's Avatar

Join Date: Mar 2014
Location: Palmerston North, New Zealand
Photos: Albums
Posts: 1,191
Hope it's still under warranty. Aperture motor failure most likely.
05-24-2016, 12:09 AM   #7
New Member




Join Date: Oct 2014
Posts: 5
Original Poster
Thanks a lot for the help looks like it's aperture block failure. It does give proper exposures when not in the A setting. Looks like its back to stop down metering for a bit.
05-24-2016, 12:43 AM   #8
Pentaxian
richandfleur's Avatar

Join Date: Mar 2014
Location: Palmerston North, New Zealand
Photos: Albums
Posts: 1,191
If it's under warranty, move quick and sort it.

If not, sorry but Pentax doesn't want to know.

05-24-2016, 10:15 AM   #9
New Member




Join Date: Oct 2014
Posts: 5
Original Poster
Yeah it's out of warranty. Bad luck I guess but thanks for the advice.
05-24-2016, 02:45 PM   #10
Pentaxian
richandfleur's Avatar

Join Date: Mar 2014
Location: Palmerston North, New Zealand
Photos: Albums
Posts: 1,191
QuoteOriginally posted by wkzsh54 Quote
Yeah it's out of warranty. Bad luck I guess but thanks for the advice.
Bugger. FYI the repair does work. It's unclear if they replace it with a different version, or give you a new one of the same part again, and hope it lasts longer.


Others will comment on the costs to repair, and then it's over to you to decide if it's worth that, or if it becomes a manual aperture setting lens only camera.


In my opinion, if this had happened all at once, then this would have sparked a recall. Instead Pentax have been quiet about it, waiting until users are out of their warranty periods. They're basically saying that the will stand by you for the warranty period only. It's dented my confidence in them, and I'm concerned by reports of similar occurrences on the K-S2 even.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k50, pentax help, photography, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Just got pentax k50 with 18-55 wr lens. Need help getting started please max77p Troubleshooting and Beginner Help 7 08-24-2015 09:21 PM
I have a dead K50 - help nonstopnick Troubleshooting and Beginner Help 11 04-08-2015 09:42 PM
Pentax K50 Flash - need help chicagovianka Flashes, Lighting, and Studio 23 11-19-2014 03:18 AM
k50 purchase help. focusr3 Pentax K-30 & K-50 14 11-13-2014 06:49 PM
Oh man, please please please help.... deckroid Photographic Technique 8 07-01-2011 09:08 AM



All times are GMT -7. The time now is 04:29 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top