Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-30-2016, 05:09 AM   #16
Loyal Site Supporter




Join Date: Mar 2012
Location: Rochester, NY
Photos: Gallery
Posts: 2,030
Have you tried to do a complete reset back to default settings?

07-30-2016, 07:01 AM   #17
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 9,750
The contacts look fine. I'm stumped. I don't have a Ks-2 to check my 18-135 on. I am sorry.
07-30-2016, 11:02 AM   #18
New Member




Join Date: Jul 2016
Posts: 4
Correction

One correction: interestingly, the camera does actually take pictures while in the spot focus/multi-focus frenzy; it also appears to try to auto-focus, even though the display shows MF mode.
07-30-2016, 11:00 PM   #19
New Member




Join Date: Jul 2016
Posts: 4
Reset to default settings

Unfortunately, the reset to default settings did not change the behavior. I now also believe that this is an electrical contact issue, since both camera body and 18-135 lens work properly in different environments. Perhaps this body and this lens both fall at the wrong end of their respective tolerance ranges for proper physical electrical contact (??).

07-31-2016, 12:34 PM   #20
Senior Member




Join Date: Oct 2012
Location: weston-super-mare
Posts: 223
Do you have a friendly Pentax dealer, or friend with SDM or DC lens to try out?
08-01-2016, 12:51 PM   #21
New Member




Join Date: May 2016
Posts: 6
Original Poster
I didn't post anything because nothing works and I finally sent it to camera precision, it will be in my hand in one or two weeks.

In my personal research I found that all the screwdrive lenses (SDM) works fine, but with the DC motor the camera goes crazy. I tested with two differentes 18-135, that by the way, works fine in other pentax body (so is discarded that the problem is the lens).

I hope that camera precision say me something about the error, at least was cover under warranty the reparation.

When the camera arrives I will post if it get fixed or not.

Last edited by Regi; 08-01-2016 at 12:53 PM. Reason: add new information
08-02-2016, 09:13 AM   #22
New Member




Join Date: Jul 2016
Posts: 4
Not all DC lenses fail with K-s2 body

Thanks for the update, Regi. Of course, the 18-50 kit lens that came with my K-s2 is a DC lens and it works, so it must not be as simple as DC vs. SDM. Also, B&H (for example) sells the K-s2 with the 18-135 lens as a package. I'm anxiously awaiting your post when you get your camera back.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
18-135mm, 18-135wr, af, behaviour, body, camera, database, firmware, focus, issue, k-s2, ks2, lens, lenses, menu, past, pentax, pentax help, photography, photos, problem, strange, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disappointing Continuous Autofocus AF-C with K-S2 and 18-135WR Turbofrog Pentax K-S1 & K-S2 11 04-25-2016 06:18 AM
For Sale - Sold: Pentax K-S2 with 18-135 WR Lens rrwilliams64 Sold Items 4 04-15-2016 09:38 AM
For Sale - Sold: Pentax K5 with DA 18-135WR Aaronofford Sold Items 5 02-20-2015 01:24 PM
K-S2+18-135WR Kit Setter Dog Pentax DSLR Discussion 17 02-19-2015 05:50 PM



All times are GMT -7. The time now is 03:42 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top